Bug 143405 - List of Kmail IMAP Crashes
Summary: List of Kmail IMAP Crashes
Status: RESOLVED DUPLICATE of bug 126715
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-23 23:44 UTC by Gabriel Ambuehl
Modified: 2007-03-24 10:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Ambuehl 2007-03-23 23:44:29 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Ubuntu Packages
OS:                Linux

I will use this report to add all the crashes I experience with kmail as requested in some OpenSUSE related blog post on planetkde. Note that I use Kubuntu Feisty.

Here's the first. I will add further as they occur. This one happened when hitting N to get to the next message.

[KCrash handler]
#6  0x00000001 in ?? ()
#7  0xb7e40240 in KMail::ImapJob::slotGetNextMessage ()
   from /usr/lib/libkmailprivate.so
#8  0xb7e7ca39 in KMail::ImapJob::init () from /usr/lib/libkmailprivate.so
#9  0xb7e7df0d in KMail::ImapJob::execute () from /usr/lib/libkmailprivate.so
#10 0xb7bbb25d in KMail::FolderJob::start () from /usr/lib/libkmailprivate.so
#11 0xb7da3b4d in KMMainWidget::slotMsgSelected ()
   from /usr/lib/libkmailprivate.so
#12 0xb7ea8d40 in KMMainWidget::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0xb7083097 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb7c023ae in KMHeaders::selected () from /usr/lib/libkmailprivate.so
#15 0xb7cfddc9 in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#16 0xb7cfe1bc in KMHeaders::highlightMessage ()
   from /usr/lib/libkmailprivate.so
#17 0xb7deedb6 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#18 0xb7083097 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb7427999 in QListView::currentChanged () from /usr/lib/libqt-mt.so.3
#20 0xb717d849 in QListView::setCurrentItem () from /usr/lib/libqt-mt.so.3
#21 0xb718163d in QListView::contentsMousePressEventEx ()
   from /usr/lib/libqt-mt.so.3
#22 0xb7181d42 in QListView::contentsMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#23 0xb5d883d7 in KListView::contentsMousePressEvent ()
   from /usr/lib/libkdeui.so.4
#24 0xb7cfe2f9 in KMHeaders::contentsMousePressEvent ()
   from /usr/lib/libkmailprivate.so
#25 0xb71b8a69 in QScrollView::viewportMousePressEvent ()
   from /usr/lib/libqt-mt.so.3
#26 0xb71b9f06 in QScrollView::eventFilter () from /usr/lib/libqt-mt.so.3
#27 0xb71821b0 in QListView::eventFilter () from /usr/lib/libqt-mt.so.3
#28 0xb7d000e9 in KMHeaders::eventFilter () from /usr/lib/libkmailprivate.so
#29 0xb7082644 in QObject::activate_filters () from /usr/lib/libqt-mt.so.3
#30 0xb70826c2 in QObject::event () from /usr/lib/libqt-mt.so.3
#31 0xb70b9d9b in QWidget::event () from /usr/lib/libqt-mt.so.3
#32 0xb701a2ec in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#33 0xb701c4aa in QApplication::notify () from /usr/lib/libqt-mt.so.3
#34 0xb7756ce2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0xb6fac3dd in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#36 0xb6fab042 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#37 0xb6fa912c in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#38 0xb6fc04b0 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#39 0xb70349c2 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#40 0xb70347d2 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#41 0xb701be95 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#42 0x0804a2de in ?? ()
#43 0xbff331d4 in ?? ()
#44 0xbff331cc in ?? ()
#45 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2007-03-24 08:25:06 UTC
Should be fixed in KDE 3.5.7

*** This bug has been marked as a duplicate of 126715 ***
Comment 2 Stephan Kulow 2007-03-24 10:09:45 UTC
it should be note though that Will's blog talks about "running 3.5 branch" - you're running 3.5.6 as released. So you're still welcome to update to svn and _then_ report crashes