Bug 143372 - Deleting folder full of spam crashes kmail
Summary: Deleting folder full of spam crashes kmail
Status: RESOLVED DUPLICATE of bug 138334
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-23 02:42 UTC by Joe Biden
Modified: 2007-03-23 10:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Biden 2007-03-23 02:42:50 UTC
Version:           1.9.6 (using KDE 3.5.6, Kubuntu (edgy) 4:3.5.6-0ubuntu1~edgy1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.20.2

I had a few dozen spams in my Spam folder. 13 were marked as new. I highlighted everything and hit delete. Crashes are reproducible with just that folder.


(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1249438032 (LWP 32581)]
[New Thread -1278239840 (LWP 32585)]
[New Thread -1269847136 (LWP 32584)]
[New Thread -1261454432 (LWP 32583)]
[New Thread -1253061728 (LWP 32582)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7bc4da5 in FolderStorage::moveMsg () from /usr/lib/libkmailprivate.so
#7  0xb7b98b05 in KMFolder::moveMsg () from /usr/lib/libkmailprivate.so
#8  0xb7c7558f in KMMoveCommand::execute () from /usr/lib/libkmailprivate.so
#9  0xb7be0639 in KMCommand::slotPostTransfer ()
   from /usr/lib/libkmailprivate.so
#10 0xb7c76eb6 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0xb7c7728b in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#12 0xb7c77317 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0xb7c7738b in KMDeleteMsgCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#14 0xb70a3957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb7be075e in KMCommand::messagesTransfered ()
   from /usr/lib/libkmailprivate.so
#16 0xb7cd6431 in KMCommand::transferSelectedMsgs ()
   from /usr/lib/libkmailprivate.so
#17 0xb7cd6597 in KMCommand::slotStart () from /usr/lib/libkmailprivate.so
#18 0xb7c76ec8 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#19 0xb7c7728b in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#20 0xb7c77317 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#21 0xb7c7738b in KMDeleteMsgCommand::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#22 0xb70a3957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#23 0xb742ff44 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#24 0xb70c38ea in QSignal::activate () from /usr/lib/libqt-mt.so.3
#25 0xb70cb300 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#26 0xb703ab88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#27 0xb703c9b7 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#28 0xb7742c82 in KApplication::notify () from /usr/lib/libkdecore.so.4
#29 0xb6fcd389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#30 0xb702d5d3 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#31 0xb6fe1ec5 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#32 0xb705525e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#33 0xb705506e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#34 0xb703c731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#35 0x0804a0fe in ?? ()
#36 0xbfdbb7f4 in ?? ()
#37 0xbfdbb7ec in ?? ()
#38 0x00000000 in ?? ()



And Also, here is when it is run under strace kmail:
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "dec_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "select_current_folder"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "inc_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "dec_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "select_current_message"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "delete"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "edit"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "use_template"
kdecore (KAction): WARNING: KAction::plugAccel(): call to deprecated action.
kdecore (KAction): WARNING: KAction::plugAccel( kacc = 0x8693538 ): KAccel object already contains an action name "display_message"
"\2\6\0\0021\0\0\0", 8)         = 8
read(3, "\2\0\0\0", 4)                  = 4
read(3, "\0\0\0\6kmail\0\0\0\0\17anonymous-2050\0\0\0\0"..., 49) = 49
close(3)                                = 0
exit_group(0)                           = ?
Process 2050 detached
WeaverThreadLogger: thread (ID: 4) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
WeaverThreadLogger: thread (ID: 1) suspended.
QInputContext: no input method context available
QInputContext: no input method context available
*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...
Comment 1 Tommi Tervo 2007-03-23 10:59:20 UTC

*** This bug has been marked as a duplicate of 138334 ***