Bug 143339 - finer grained (15 minutes) scheduler
Summary: finer grained (15 minutes) scheduler
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 150831 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-22 14:04 UTC by Konstantinos Georgokitsos
Modified: 2007-11-12 19:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantinos Georgokitsos 2007-03-22 14:04:28 UTC
Version:           2.1.2 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.27-0.6-smp

I use the scheduler in ktorrent on a regular basis. However I would like to have a finer grained schedule. Half or even quarter of an hour would really be great. Alternatively, this could be configurable up to e.g. 5 minutes or even 1 minute.
Comment 1 Joris Guisson 2007-10-14 19:14:34 UTC
*** Bug 150831 has been marked as a duplicate of this bug. ***
Comment 2 Joris Guisson 2007-11-12 19:39:12 UTC
SVN commit 735836 by guisson:

Finished the bandwidth scheduler plugin. This means that you can now schedule to the minute and so we can close 143339.

BUG: 143339



 M  +3 -1      bwscheduler/additemdlg.cpp  
 M  +99 -69    bwscheduler/bwschedulerplugin.cpp  
 M  +6 -3      bwscheduler/bwschedulerplugin.h  
 M  +47 -0     bwscheduler/schedule.cpp  
 M  +14 -0     bwscheduler/schedule.h  
 M  +9 -1      bwscheduler/scheduleeditor.cpp  
 M  +13 -0     bwscheduler/scheduleeditor.h  
 M  +22 -3     bwscheduler/weekscene.cpp  
 M  +9 -0      bwscheduler/weekscene.h  
 M  +5 -1      bwscheduler/weekview.cpp  
 M  +8 -0      bwscheduler/weekview.h  
 M  +1 -0      infowidget/infowidgetplugin.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=735836