Bug 143250 - Crash when deleting IMAP messages
Summary: Crash when deleting IMAP messages
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 150038 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-20 09:47 UTC by David Jarvie
Modified: 2008-02-17 01:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Jarvie 2007-03-20 09:47:57 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Compiled From Sources
Compiler:          gcc 4.1.2 
OS:                Linux

Several times when deleting multiple IMAP messages, kmail has crashed. The backtrace from one crash is:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
...
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1519450432 (LWP 17386)]
[New Thread -1549571152 (LWP 17390)]
[New Thread -1541178448 (LWP 17389)]
[New Thread -1532785744 (LWP 17388)]
[New Thread -1524393040 (LWP 17387)]
[KCrash handler]
#6  0xa7c5b6a6 in KMMsgBase::storage ()
   from /opt/kde3.5/lib/libkmailprivate.so
#7  0xa7c96052 in KMFolderImap::deleteMessage ()
   from /opt/kde3.5/lib/libkmailprivate.so
#8  0xa7c967af in KMFolderImap::removeMsg ()
   from /opt/kde3.5/lib/libkmailprivate.so
#9  0xa7bd6eb6 in KMFolder::removeMsg ()
   from /opt/kde3.5/lib/libkmailprivate.so
#10 0xa7d4ec1d in KMMoveCommand::execute ()
   from /opt/kde3.5/lib/libkmailprivate.so
#11 0xa7d41be9 in KMCommand::slotPostTransfer ()
   from /opt/kde3.5/lib/libkmailprivate.so
#12 0xa7d49f84 in KMCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#13 0xa7d4a1bb in KMMenuCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#14 0xa7d58345 in KMMoveCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#15 0xa5f70829 in QObject::activate_signal ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#16 0xa7d41dbe in KMCommand::messagesTransfered ()
   from /opt/kde3.5/lib/libkmailprivate.so
#17 0xa7d587b1 in KMCommand::transferSelectedMsgs ()
   from /opt/kde3.5/lib/libkmailprivate.so
#18 0xa7d589a7 in KMCommand::slotStart ()
   from /opt/kde3.5/lib/libkmailprivate.so
#19 0xa7d49f96 in KMCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#20 0xa7d4a1bb in KMMenuCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#21 0xa7d58345 in KMMoveCommand::qt_invoke ()
   from /opt/kde3.5/lib/libkmailprivate.so
#22 0xa5f70829 in QObject::activate_signal ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#23 0xa629dade in QSignal::signal () from /opt/qt-3.3.6/lib/libqt-mt.so.3
#24 0xa5f8c765 in QSignal::activate () from /opt/qt-3.3.6/lib/libqt-mt.so.3
#25 0xa5f93a73 in QSingleShotTimer::event ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#26 0xa5f12487 in QApplication::internalNotify ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#27 0xa5f13219 in QApplication::notify () from /opt/qt-3.3.6/lib/libqt-mt.so.3
#28 0xa667570e in KApplication::notify () from /opt/kde3.5/lib/libkdecore.so.4
#29 0xa5f078ac in QEventLoop::activateTimers ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#30 0xa5ec1cec in QEventLoop::processEvents ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#31 0xa5f28e21 in QEventLoop::enterLoop ()
   from /opt/qt-3.3.6/lib/libqt-mt.so.3
#32 0xa5f28ce6 in QEventLoop::exec () from /opt/qt-3.3.6/lib/libqt-mt.so.3
#33 0xa5f120ef in QApplication::exec () from /opt/qt-3.3.6/lib/libqt-mt.so.3
#34 0x0804a74f in ?? ()
#35 0xaf9348c0 in ?? ()
#36 0xaf934ab0 in ?? ()
#37 0x00000000 in ?? ()
Comment 1 Stephan Kulow 2007-03-22 09:40:51 UTC
if you can, please compile the current 3.5 branch with debug. Otherwise I can't reproduce your problem and you don't provide debug infos.
Comment 2 David Jarvie 2007-03-26 00:53:49 UTC
I "don't provide debug info"??? Isn't that what the backtrace is?

Anyway, I recompiled up-to-date sources, and I can't reproduce it any more. So it looks like it has probably been fixed.
Comment 3 Thomas McGuire 2008-02-17 01:37:56 UTC
*** Bug 150038 has been marked as a duplicate of this bug. ***