Bug 143139 - Kmail imap crash (when viewing large folders?)
Summary: Kmail imap crash (when viewing large folders?)
Status: RESOLVED DUPLICATE of bug 132056
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-18 00:25 UTC by Peter Alfredsen
Modified: 2007-03-18 00:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen 2007-03-18 00:25:09 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          GCC 4.1.2 Compiled with -Os -pipe -ggdb3
OS:                Linux

Kmail has a tendency to crash on me when I read the Linux Kernel Mailing List. I am reading this off a local Dovecot imap server. The folder I'm reading has more than 3000 mails in it. These crashes do also happen on smaller folders, though less often. These crashes usually only happen when I am doing something actively. Not when I'm scrolling in the current message. I may be clicking another message, I may be changing to another folder when the crash happens. I will try to provide more backtraces as they become available. I found Bug 412261 on bugs.debian.org which describes a situation similar to mine:
http://bugs.debian.org/412261

My backtrace:
Backtrace:
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1246869840 (LWP 4935)]
[New Thread -1275786352 (LWP 5081)]
[New Thread -1267393648 (LWP 5080)]
[New Thread -1259000944 (LWP 5079)]
[New Thread -1250608240 (LWP 5078)]
[KCrash handler]
#6  DwStrcasecmp (aStr=@0x37, aCstr=0x8d110f8 "X-UID")
    at ./mimelib/string.h:629
#7  0xb72e697f in DwHeaders::FindField (this=0x81d39e0, 
    aFieldName=0x8d110f8 "X-UID") at headers.cpp:291
#8  0xb7e34159 in KMMessage::headerField (this=0x8105fa0, aName=@0xbfc13750)
    at kmmessage.cpp:2224
#9  0xb7e362a7 in FolderJob (this=0x89a4498, msg=0x8105fa0, 
    jt=KMail::FolderJob::tGetMessage, folder=0x0, partSpecifier=@0xbfc137a8)
    at folderjob.cpp:53
#10 0xb7e37ecc in ImapJob (this=0x89a4498, msg=0x8105fa0, 
    jt=KMail::FolderJob::tGetMessage, folder=0x0, partSpecifier=@0xbfc137f4, 
    as=0x83abe40) at imapjob.cpp:59
#11 0xb7e38dc0 in KMFolderImap::doCreateJob (this=0x81d39e0, msg=0x8105fa0, 
    jt=KMail::FolderJob::tGetMessage, folder=0x0, partSpecifier=@0xbfc13848, 
    as=0x83abe40) at kmfolderimap.cpp:1593
#12 0xb7cc00c7 in FolderStorage::createJob (this=0x81d39e0, msg=0x8105fa0, 
    jt=KMail::FolderJob::tGetMessage, folder=0x0, partSpecifier=@0xbfc13898, 
    as=0x83abe40) at folderstorage.cpp:564
#13 0xb7c95d01 in KMFolder::createJob (this=0x81d3800, msg=0x8105fa0, 
    jt=KMail::FolderJob::tGetMessage, folder=0x0, partSpecifier=@0xbfc138e8, 
    as=0x83abe40) at kmfolder.cpp:342
#14 0xb7dca51c in KMMainWidget::slotMsgSelected (this=0x82f9448, 
    msg=0x8105fa0) at kmmainwidget.cpp:2034
#15 0xb7e66c10 in KMMainWidget::qt_invoke (this=0x82f9448, _id=54, 
    _o=0xbfc13994) at kmmainwidget.moc:507
#16 0xb6315d2c in QObject::activate_signal (this=0x831b5f8, clist=0x8361298, 
    o=0xbfc13994) at kernel/qobject.cpp:2356
#17 0xb7d0bad4 in KMHeaders::selected (this=0x831b5f8, t0=0x8105fa0)
    at kmheaders.moc:250
#18 0xb7dcf338 in KMHeaders::highlightMessage (this=0x831b5f8, lvi=0x8a6b700, 
    markitread=false) at kmheaders.cpp:2033
#19 0xb7dd0d85 in KMHeaders::highlightMessage (this=0x831b5f8, i=0x8a6b700)
    at kmheaders.cpp:2282
#20 0xb7ddbd31 in KMHeaders::qt_invoke (this=0x831b5f8, _id=106, 
    _o=0xbfc13ad4) at kmheaders.moc:295
#21 0xb6315d2c in QObject::activate_signal (this=0x831b5f8, clist=0x83542e8, 
    o=0xbfc13ad4) at kernel/qobject.cpp:2356
#22 0xb6578cb2 in QListView::currentChanged (this=0x831b5f8, t0=0x8a6b700)
    at .moc/release-shared-mt/moc_qlistview.cpp:328
#23 0xb63b7209 in QListView::setCurrentItem (this=0x831b5f8, i=0x8a6b700)
    at widgets/qlistview.cpp:5477
#24 0xb63bfbd5 in QListView::contentsMousePressEventEx (this=0x831b5f8, 
    e=0xbfc13dac) at widgets/qlistview.cpp:4353
#25 0xb63c010d in QListView::contentsMousePressEvent (this=0x831b5f8, 
    e=0xbfc13dac) at widgets/qlistview.cpp:4237
#26 0xb6af1b2c in KListView::contentsMousePressEvent (this=0x831b5f8, 
    e=0xbfc13dac) at klistview.cpp:805
#27 0xb7dd0f54 in KMHeaders::contentsMousePressEvent (this=0x831b5f8, 
    e=0xbfc13dac) at kmheaders.cpp:2194
#28 0xb63dd335 in QScrollView::viewportMousePressEvent (this=0x831b5f8, 
    e=0xbfc1421c) at widgets/qscrollview.cpp:1733
#29 0xb63ddf58 in QScrollView::eventFilter (this=0x831b5f8, obj=0x831c108, 
    e=0xbfc1421c) at widgets/qscrollview.cpp:1496
#30 0xb63b4da4 in QListView::eventFilter (this=0x831b5f8, o=0x831c108, 
    e=0xbfc1421c) at widgets/qlistview.cpp:3867
#31 0xb7d85e53 in KMHeaders::eventFilter (this=0x831b5f8, o=0x831c108, 
    e=0xbfc1421c) at kmheaders.cpp:244
#32 0xb6313fb6 in QObject::activate_filters (this=0x831c108, e=0xbfc1421c)
    at kernel/qobject.cpp:903
#33 0xb6314e21 in QObject::event (this=0x831c108, e=0xbfc1421c)
    at kernel/qobject.cpp:735
#34 0xb633bc14 in QWidget::event (this=0x831c108, e=0xbfc1421c)
    at kernel/qwidget.cpp:4659
#35 0xb62d40b2 in QApplication::internalNotify (this=0xbfc146c0, 
    receiver=0x831c108, e=0xbfc1421c) at kernel/qapplication.cpp:2635
#36 0xb62d4457 in QApplication::notify (this=0xbfc146c0, receiver=0x831c108, 
    e=0xbfc1421c) at kernel/qapplication.cpp:2421
#37 0xb690a81e in KApplication::notify (this=0xbfc146c0, receiver=0x831c108, 
    event=0xbfc1421c) at kapplication.cpp:550
#38 0xb6287e8c in QApplication::sendSpontaneousEvent (receiver=0x831c108, 
    event=0x0) at kernel/qapplication.h:499
#39 0xb628537d in QETWidget::translateMouseEvent (this=0x831c108, 
    event=0xbfc145ac) at kernel/qapplication_x11.cpp:4298
#40 0xb62843a5 in QApplication::x11ProcessEvent (this=0xbfc146c0, 
    event=0xbfc145ac) at kernel/qapplication_x11.cpp:3562
#41 0xb6295371 in QEventLoop::processEvents (this=0x806f1a8, flags=4)
    at kernel/qeventloop_x11.cpp:192
#42 0xb62e0b27 in QEventLoop::enterLoop (this=0x806f1a8)
    at kernel/qeventloop.cpp:198
#43 0xb62e09ea in QEventLoop::exec (this=0x806f1a8)
    at kernel/qeventloop.cpp:145
#44 0xb62cf660 in QApplication::exec (this=0xbfc146c0)
    at kernel/qapplication.cpp:2758
#45 0x0804a3b8 in main (argc=) at main.cpp:110
#46 0xb5aff83c in __libc_start_main (main=0x804a2b8 <main>, argc=3, 
    ubp_av=0xbfc14964, init=0x804a4e0 <__libc_csu_init>, 
    fini=0x804a4d0 <__libc_csu_fini>, rtld_fini=0xb7f4ceb0 <_dl_fini>, 
    stack_end=0xbfc1495c) at libc-start.c:238
#47 0x0804a1c1 in _start ()
Comment 1 Bram Schoenmakers 2007-03-18 00:43:28 UTC

*** This bug has been marked as a duplicate of 132056 ***