Bug 143038 - Message body gets deleted
Summary: Message body gets deleted
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-16 02:56 UTC by matzematiker
Modified: 2010-01-03 23:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matzematiker 2007-03-16 02:56:14 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-6 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-3-k7

Hi,

the contents of an email got deleted. I use IMAP and kontact. Unlike in other bug reports moving the message from one folder to another, like it helped me before, didn't help. I checked the email on the provider's webmail system and there is no body either. Also parts of the Headers get lost. I use bogofilter, and marked this message as ham, but I'm not sure if this has to do with it since I couldn't reproduce this error. This is what the mail looks like when showing the source with 'v':

X-UID: 325
X-Length: 2792
From: <mailer@domain.de>
Sender: <mailer@domain.de>
Reply-To: <address@hotmail.com>
To: <otheraddress@gmx.de>
Subject: Willkommen auf Dragon Army
Message-ID: <bfebad4e44ed48af6b0e211ca8f1aeaa@dragon-army.domain.de>
Date: Wed, 14 Mar 2007 22:53:49 +0100
Content-Type: text/plain
X-KMail-Filtered: 8940
Status: RO
X-Status: OHC
X-KMail-EncryptionState:  
X-KMail-SignatureState:  
X-KMail-MDN-Sent:  
X-Bogosity: Ham, tests=bogofilter, spamicity=0.000000, version=1.1.3
Comment 1 Clemens Bergmann 2007-04-05 08:03:57 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-6 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-4-k7 

Same problem here: Kmail/Postfix/Cyrus deleted at least twice the message body. No bogofilter here, so this one is perhaps innocent... In both cases, I have read the messages and when I checked back some time later, they were empty.


Example source:

X-UID: 460
X-Length: 5039
From: Constantine Kousoulos <wuwei@freemail.gr>
Sender: Constantine Kousoulos <wuwei@freemail.gr>
Reply-To: Constantine Kousoulos <wuwei@freemail.gr>
To: <debian-amd64@lists.debian.org>
Subject: cpu overheating
Message-ID: <4613E2CD.9030400@freemail.gr>
Date: Wed, 04 Apr 2007 20:39:25 +0300
Content-Type: text/plain
Status: RO
X-Status: OC
X-KMail-EncryptionState: N
X-KMail-SignatureState: N
X-KMail-MDN-Sent:  
Comment 2 Benjamin 2007-07-09 11:36:26 UTC
I have the same problem, kmail 1.9.5 deleted message bodies several times (both on gentoo and kubuntu). No filter activated. If you open the e-mail immediately in your webmail system, it is complete. After moving it to another folder, the body is irrecoverable.

Example:

X-UID: 908
X-Length: 7650
X-Flags: 1
From: XXXXXXXXXX
Sender: XXXXXXXXXXX
Reply-To: XXXXXXXXXXXXX
To: XXXXXXXXX
Subject: XXXXXXXXXX
Message-ID: XXXXXXXXXX
In-Reply-To: XXXXXXXXXXX
References: XXXXXXXXXXX
Date: Sun, 8 Jul 2007 23:30:08 +0200
Content-Type: text/plain
Status: RO
X-Status: ORC
X-KMail-EncryptionState: N
X-KMail-SignatureState: N
X-KMail-MDN-Sent:  

Comment 3 Alan Krempler 2007-08-15 13:42:13 UTC
I observe the same problem on a SuSE 10.1 desktop with KMail 1.9.4 and KDE 3.5.4. My IMAP server runs courier-imap 3.0.8-3. 
Although I cannot reproduce the behavior, two observations:
The problem occurred on messages with and without an attachment.
All affected messages resided in the inbox, I did not observe the problem in other folders.
Comment 4 Matthias 2008-10-13 19:57:00 UTC
Version:           1.9.9 (using KDE 3.5.9, Gentoo)
Compiler:          gcc-4.1.2
OS:                Linux (i686) release 2.6.25-r7

Hi,

same Problem here! Body of mail on IMAP account get lost. I think it happens mostly on marked (important) messages. It happend two or three times now. The mails are correct if I use the Web frontend of my provider (GMX).

Regrads Matthias
Comment 5 Björn Ruberg 2010-01-03 23:19:41 UTC
Message body deletion bugs got fixed in recent kmail versions. Please check whether this is still a problem for you.