Bug 142935 - Kmail crashes (kmail+gpg issue)
Summary: Kmail crashes (kmail+gpg issue)
Status: RESOLVED DUPLICATE of bug 92737
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-13 23:33 UTC by Yevgeny Kosarzhevsky
Modified: 2007-03-14 07:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yevgeny Kosarzhevsky 2007-03-13 23:33:04 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
Compiler:          from debian etch 
OS:                Linux

steps to reproduce a crash:
point to gpg-encrypted message.
in pinetry window which is asking for password hit cancel.
see window PGP warning - Kmail, do not push any button in it.
choose another not encrypted message in kmail main window.
hit cancel in PGP warning - Kmail window.

kmail always crashing after that. here the log:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1249339168 (LWP 12945)]
[New Thread -1280853072 (LWP 12952)]
[New Thread -1272460368 (LWP 12951)]
[New Thread -1264067664 (LWP 12950)]
[New Thread -1255674960 (LWP 12949)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0xb7e48bfb in KMail::ObjectTreeParser::parseObjectTree ()
   from /usr/lib/libkmailprivate.so
#7  0xb7e4da63 in KMReaderWin::parseMsg () from /usr/lib/libkmailprivate.so
#8  0xb7d49d71 in KMReaderWin::displayMessage ()
   from /usr/lib/libkmailprivate.so
#9  0xb7dccc4d in KMReaderWin::updateReaderWin ()
   from /usr/lib/libkmailprivate.so
#10 0xb7e4831c in KMReaderWin::qt_invoke () from /usr/lib/libkmailprivate.so
#11 0xb70a8d4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb70a97e0 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0xb7433e5e in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#14 0xb70d0603 in QTimer::event () from /usr/lib/libqt-mt.so.3
#15 0xb7040c26 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#16 0xb7042a43 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#17 0xb7768e0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0xb6fd4421 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#19 0xb7033623 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#20 0xb6fe876f in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#21 0xb705b179 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#22 0xb705af9a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#23 0xb70427bf in QApplication::exec () from /usr/lib/libqt-mt.so.3
#24 0x0804a094 in ?? ()
#25 0xbf8e39d4 in ?? ()
#26 0xbf8e3bc0 in ?? ()
#27 0x00000000 in ?? ()
Comment 1 Tommi Tervo 2007-03-14 07:43:52 UTC

*** This bug has been marked as a duplicate of 92737 ***