Bug 142920 - Message list mixes up emails
Summary: Message list mixes up emails
Status: RESOLVED DUPLICATE of bug 85013
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.5
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-13 17:50 UTC by Zoltan Peczoli
Modified: 2007-03-13 20:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
List item changes when clicking it (29.54 KB, image/gif)
2007-03-13 17:52 UTC, Zoltan Peczoli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Peczoli 2007-03-13 17:50:51 UTC
Version:           1.9.5 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

KMail, message list. When I select a message, its sender and subject changes to that of another mail. I know it sounds strange, so I attached an animated gif that shows what happens. You can see that in the second frame when I select the second mail, its properties change. Better yet, the same can happen again when I double click it. The actual content of the mail is always the same, so the problem is limited to the message list.

The bug frequently shows up when I do the following:

1. Fire up KMail
2. Check IMAP account for new mail
3. Quit KMail
4. Launch another IMAP client (I use pine)
5. Delete one mail from the IMAP inbox
6. Quit pine
7. Launch KMail again, click around in the message list to check which message exhibits the problem

I suspect inconsistencies between KMail local cache and the IMAP server. When I empty the .kde/share/apps/kmail/imap directory, the problem goes away.
Comment 1 Zoltan Peczoli 2007-03-13 17:52:54 UTC
Created attachment 19961 [details]
List item changes when clicking it
Comment 2 Thomas McGuire 2007-03-13 20:27:29 UTC
Sounds very much like bug #85013, comment #31.

*** This bug has been marked as a duplicate of 85013 ***