Bug 142756 - Crash after trying to disable identity picture sending (xface)
Summary: Crash after trying to disable identity picture sending (xface)
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-09 18:49 UTC by Paul
Modified: 2009-08-05 13:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Chrash report (3.12 KB, text/plain)
2007-03-09 18:51 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2007-03-09 18:49:27 UTC
Version:           1.9.5 (using KDE 3.5.6, Kubuntu (edgy) 4:3.5.6-0ubuntu1~edgy1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-10-generic

I had [settings][picture][send picture with every message] on.
Picture is not available any more.
I cannot unset [send picture with every message]. Kmail will crash.
Also mail in outbox will not be send.
Comment 1 Paul 2007-03-09 18:51:48 UTC
Created attachment 19922 [details]
Chrash report

This is the crash report.
Comment 2 Bram Schoenmakers 2007-03-09 19:54:17 UTC
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1249409360 (LWP 6983)]
[New Thread -1278452832 (LWP 6987)]
[New Thread -1270060128 (LWP 6986)]
[New Thread -1261667424 (LWP 6985)]
[New Thread -1253274720 (LWP 6984)]
[KCrash handler]
#6  0xb6fd4128 in QShared::ref (this=0x1) at ../include/qshared.h:49
#7  0xb73c352f in QString (this=0xbfcab084, s=@0x844ed30)
    at tools/qstring.cpp:1397
#8  0xb673865e in qHeapSort<QValueList<KPIM::Identity> > ()
   from /usr/lib/libkpimidentities.so.1
#9  0xb67347f0 in KPIM::IdentityManager::sort ()
   from /usr/lib/libkpimidentities.so.1
#10 0xb7bb6088 in IdentityPage::save () from /usr/lib/libkmailprivate.so
#11 0xb6023b4d in KCModuleProxy::save () from /usr/lib/libkutils.so.1
#12 0xb6023d1f in KCMultiDialog::apply () from /usr/lib/libkutils.so.1
#13 0xb6023f4b in KCMultiDialog::slotOk () from /usr/lib/libkutils.so.1
#14 0xb7bb2f7f in ConfigureDialog::slotOk () from /usr/lib/libkmailprivate.so
#15 0xb5f11b09 in KDialogBase::qt_invoke () from /usr/lib/libkdeui.so.4
#16 0xb60231f3 in KCMultiDialog::qt_invoke () from /usr/lib/libkutils.so.1
#17 0xb7bb1578 in ConfigureDialog::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#18 0xb70ab957 in QObject::activate_signal (this=0x833af30, clist=0x833af08, 
    o=0xbfcab30c) at kernel/qobject.cpp:2356
#19 0xb70ac3fc in QObject::activate_signal (this=0x833af30, signal=4)
    at kernel/qobject.cpp:2325
#20 0xb7440f5f in QButton::clicked (this=0x833af30)
    at .moc/debug-shared-mt/moc_qbutton.cpp:152
#21 0xb7149fe8 in QButton::mouseReleaseEvent (this=0x833af30, e=0xbfcab780)
    at widgets/qbutton.cpp:836
#22 0xb70e2729 in QWidget::event (this=0x833af30, e=0xbfcab780)
    at kernel/qwidget.cpp:4702
#23 0xb7042b88 in QApplication::internalNotify (this=0xbfcabdd4, 
    receiver=0x833af30, e=0xbfcab780) at kernel/qapplication.cpp:2635
#24 0xb7044d46 in QApplication::notify (this=0xbfcabdd4, receiver=0x833af30, 
    e=0xbfcab780) at kernel/qapplication.cpp:2421
#25 0xb774ac82 in KApplication::notify () from /usr/lib/libkdecore.so.4
#26 0xb6fd53fd in QApplication::sendSpontaneousEvent (receiver=0x833af30, 
    event=0xbfcab780) at kernel/qapplication.h:523
#27 0xb6fd4062 in QETWidget::translateMouseEvent (this=0x833af30, 
    event=0xbfcabbd8) at kernel/qapplication_x11.cpp:4303
#28 0xb6fd214c in QApplication::x11ProcessEvent (this=0xbfcabdd4, 
    event=0xbfcabbd8) at kernel/qapplication_x11.cpp:3480
#29 0xb6fe9320 in QEventLoop::processEvents (this=0x806c7e0, flags=4)
    at kernel/qeventloop_x11.cpp:192
#30 0xb705d25e in QEventLoop::enterLoop (this=0x806c7e0)
    at kernel/qeventloop.cpp:198
#31 0xb705d06e in QEventLoop::exec (this=0x806c7e0)
    at kernel/qeventloop.cpp:145
#32 0xb7044731 in QApplication::exec (this=0xbfcabdd4)
    at kernel/qapplication.cpp:2758
Comment 3 Bram Schoenmakers 2007-03-09 19:59:51 UTC
Can not reproduce.
Comment 4 Paul 2007-03-09 20:15:15 UTC
Goeienavond,

I just had to reinstall kdebase yesterday (and kmail was included in the reinstall).

Strange thing is that I cannot send any mail any more. Will redefine my mail-accounts.

Paul.
Comment 5 Thomas McGuire 2007-03-09 21:43:03 UTC
Adjusting summary.
Comment 6 Pau Tallada Crespí 2007-07-31 17:16:38 UTC
Hi!

This has happened to me for the last 2 months. I'm unable to disable this setting because it crashes every time I try.

I've deleted emailidentities, then gets recreated with below settings:


[General]
Default Identity=2031585806

[Identity #0]
Bcc=
Dictionary=
Drafts=
Email Address=
Fcc=
Identity=Omissió
Inline Signature=
Name=Pau Tallada Crespi
Organization=
PGP Encryption Key=
PGP Signing Key=
Preferred Crypto Message Format=auto
Reply-To Address=
SMIME Encryption Key=
SMIME Signing Key=
Signature Type=disabled
Templates=
Transport=
VCardFile=
X-Face=
X-FaceEnabled=false
uoid=2031585806

Kconfig documentation says, in reference of boolean values:
Currently "on", "yes", "1" and "true" are accepted as true, everything else if false.

I'll try to debug a bit, but I'm newbie debugging...

Thanks
Comment 7 Martin Koller 2009-08-05 13:04:19 UTC
can't reproduce with KDE 4.3 - closing