Bug 142715 - copying large chunks of mails between imap accounts or local folders crashes kmail
Summary: copying large chunks of mails between imap accounts or local folders crashes ...
Status: RESOLVED DUPLICATE of bug 110574
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.6
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-09 08:45 UTC by Sebastian Reitenbach
Modified: 2007-03-09 14:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Reitenbach 2007-03-09 08:45:55 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs
OS:                Linux

crash 1:
uploading a lot of mails to imap server from cached-imap account:
System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1240672592 (LWP 17739)]
[New Thread -1283892320 (LWP 17755)]
[New Thread -1275499616 (LWP 17754)]
[New Thread -1267106912 (LWP 17753)]
[New Thread -1258714208 (LWP 17752)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb68547d0 in raise () from /lib/libc.so.6
#8  0xb6855ea3 in abort () from /lib/libc.so.6
#9  0xb6a013a0 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0xb69fedc5 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#11 0xb69fee02 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb69fef3a in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0xb69ff37e in operator new () from /usr/lib/libstdc++.so.6
#14 0xb69ff45d in operator new[] () from /usr/lib/libstdc++.so.6
#15 0xb4fce226 in mem_alloc () from /opt/kde3/lib/libmimelib.so.1
#16 0xb4fd15ff in DwString::_replace () from /opt/kde3/lib/libmimelib.so.1
#17 0xb4fd2227 in DwString::append () from /opt/kde3/lib/libmimelib.so.1
#18 0xb4fd22d3 in DwString::append () from /opt/kde3/lib/libmimelib.so.1
#19 0xb4fb94f0 in DwBody::Assemble () from /opt/kde3/lib/libmimelib.so.1
#20 0xb4fbf45b in DwEntity::Assemble () from /opt/kde3/lib/libmimelib.so.1
#21 0xb51c61ef in KMMessage::asDwString ()
   from /opt/kde3/lib/libkmailprivate.so
#22 0xb51c9098 in KMMessage::asString () from /opt/kde3/lib/libkmailprivate.so
#23 0xb542cdbe in KMail::CachedImapJob::slotPutNextMessage ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb5428fd7 in KMail::CachedImapJob::slotPutMessageResult ()
   from /opt/kde3/lib/libkmailprivate.so
#25 0xb542aaff in KMail::CachedImapJob::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#26 0xb6cb967d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb77a4dae in KIO::Job::result () from /opt/kde3/lib/libkio.so.4
#28 0xb77ee7cd in KIO::Job::emitResult () from /opt/kde3/lib/libkio.so.4
#29 0xb7805cae in KIO::SimpleJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#30 0xb78063cd in KIO::TransferJob::slotFinished ()
   from /opt/kde3/lib/libkio.so.4
#31 0xb77ee3fa in KIO::TransferJob::qt_invoke () 
from /opt/kde3/lib/libkio.so.4
#32 0xb6cb967d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb6cba2dd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb779fe1c in KIO::SlaveInterface::finished ()
   from /opt/kde3/lib/libkio.so.4
#35 0xb7804b95 in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#36 0xb7815dca in KIO::SlaveInterface::dispatch ()
   from /opt/kde3/lib/libkio.so.4
#37 0xb77b471c in KIO::Slave::gotInput () from /opt/kde3/lib/libkio.so.4
#38 0xb77f4060 in KIO::Slave::qt_invoke () from /opt/kde3/lib/libkio.so.4
#39 0xb6cb967d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb6cba1e2 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb6ff3190 in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb6cd7880 in QSocketNotifier::event () 
from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb6c5a547 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb6c5b311 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb7315e23 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#46 0xb6c4ee64 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb6c09874 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0xb6c71368 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#49 0xb6c711fe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#50 0xb6c5a0ff in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#51 0x08058c39 in main ()


crash 2: moving mails from cached-imap to local folder
System configuration startup check disabled.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1248806352 (LWP 19724)]
[New Thread -1280607328 (LWP 19744)]
[New Thread -1272214624 (LWP 19743)]
[New Thread -1263821920 (LWP 19742)]
[New Thread -1255429216 (LWP 19741)]
[KCrash handler]
#6  0xffffe410 in __kernel_vsyscall ()
#7  0xb6e7b7d0 in raise () from /lib/libc.so.6
#8  0xb6e7cea3 in abort () from /lib/libc.so.6
#9  0xb70283a0 in __gnu_cxx::__verbose_terminate_handler ()
   from /usr/lib/libstdc++.so.6
#10 0xb7025dc5 in std::set_unexpected () from /usr/lib/libstdc++.so.6
#11 0xb7025e02 in std::terminate () from /usr/lib/libstdc++.so.6
#12 0xb7025f3a in __cxa_throw () from /usr/lib/libstdc++.so.6
#13 0xb702637e in operator new () from /usr/lib/libstdc++.so.6
#14 0xb702645d in operator new[] () from /usr/lib/libstdc++.so.6
#15 0xb65e2226 in mem_alloc () from /opt/kde3/lib/libmimelib.so.1
#16 0xb65e55ff in DwString::_replace () from /opt/kde3/lib/libmimelib.so.1
#17 0xb65e6410 in DwString::DwString () from /opt/kde3/lib/libmimelib.so.1
#18 0xb7b379b6 in KMMessage::fromString ()
   from /opt/kde3/lib/libkmailprivate.so
#19 0xb7d55bcd in KMCopyCommand::execute ()
   from /opt/kde3/lib/libkmailprivate.so
#20 0xb7d4be99 in KMCommand::slotPostTransfer ()
   from /opt/kde3/lib/libkmailprivate.so
#21 0xb7d53fa6 in KMCommand::qt_invoke () 
from /opt/kde3/lib/libkmailprivate.so
#22 0xb7d5428b in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#23 0xb7d543e6 in KMCopyCommand::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#24 0xb72e167d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0xb7d4bf2e in KMCommand::messagesTransfered ()
   from /opt/kde3/lib/libkmailprivate.so
#26 0xb7d54f61 in KMCommand::transferSelectedMsgs ()
   from /opt/kde3/lib/libkmailprivate.so
#27 0xb7d550c7 in KMCommand::slotStart () 
from /opt/kde3/lib/libkmailprivate.so
#28 0xb7d53fb8 in KMCommand::qt_invoke () 
from /opt/kde3/lib/libkmailprivate.so
#29 0xb7d5428b in KMMenuCommand::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#30 0xb7d543e6 in KMCopyCommand::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#31 0xb72e167d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0xb761a3be in QSignal::signal () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0xb72fd727 in QSignal::activate () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb7304ae3 in QSingleShotTimer::event ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xb7282547 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0xb7283311 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0xb793ce23 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#38 0xb72776e6 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb7231940 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0xb7299368 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#41 0xb72991fe in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#42 0xb72820ff in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0x0804a0db in main ()

later I tried to copy about 2000 mails at once from an imap account to another imap account, and after about 300 mails kmail just dissapeared without opening a crash handler.

I am here on suse 10.1 and 10.2, i386.
Comment 1 Thomas McGuire 2007-03-09 12:40:58 UTC
Do any of these mails have large attachments (>5MB)?
KMail does not handle large attachments very well (it needs lots of memory for it), and your crashes look like out-of-memory conditions.

See bug #110574.
Comment 2 Sebastian Reitenbach 2007-03-09 14:33:55 UTC
Yes, I there are some mails in the bunch I tried to copy or move that contain large attachements, some much larger than >5MB.

Comment 3 Thomas McGuire 2007-03-09 14:39:22 UTC
Ok, I'll mark this as a duplicate then, since it is the same cause (large attachments use much memory)

*** This bug has been marked as a duplicate of 110574 ***