Bug 142714 - Kmail crashed signal 11 (SIGSEGV): QListViewItem::firstChild
Summary: Kmail crashed signal 11 (SIGSEGV): QListViewItem::firstChild
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 140724 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-09 07:06 UTC by Bob Tanner
Modified: 2009-02-21 22:38 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Tanner 2007-03-09 07:06:16 UTC
Version:           3.5.5.dfsg.1-6 (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Random crashed when deleting messsage in an imap folder.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46914326383216 (LWP 12997)]
[New Thread 1107310944 (LWP 13002)]
[New Thread 1098918240 (LWP 13001)]
[New Thread 1090525536 (LWP 13000)]
[New Thread 1082132832 (LWP 12999)]
[KCrash handler]
#5  0x000000000271c840 in ?? ()
#6  0x00002aab11ff1572 in QListViewItem::firstChild (this=0x2b73a80)
    at widgets/qlistview.cpp:3996
#7  0x00002aab10c8375a in KMMainWidget::updateMessageActions (this=0x1338870)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmmainwidget.cpp:2998
#8  0x00002aab10c8a793 in KMHeaders::slotMoveCompleted (this=0x13428a0, 
    command=0x2131d50)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmheaders.cpp:1548
#9  0x00002aab10cc7474 in KMHeaders::qt_invoke (this=0x13428a0, _id=140, 
    _o=0x7fff9a353a50) at ./kmheaders.moc:328
#10 0x00002aab11f05c26 in QObject::activate_signal (this=0x2131d50, 
    clist=0x31a0d50, o=0x7fff9a353a50) at kernel/qobject.cpp:2356
#11 0x00002aab10ac68ae in KMCommand::completed (this=<value optimized out>, 
    t0=0x2131d50) at ./kmcommands.moc:139
#12 0x00002aab10ac6a0e in KMMoveCommand::completeMove (this=0x2131d50, 
    result=KMCommand::OK)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmcommands.cpp:2071
#13 0x00002aab10b3a686 in KMMoveCommand::execute (this=0x2131d50)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmcommands.cpp:2002
#14 0x00002aab10ac6d10 in KMCommand::slotPostTransfer (this=0x2131d50, 
    result=KMCommand::OK)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmcommands.cpp:256
#15 0x00002aab10b3bac3 in KMCommand::qt_invoke (this=0x2131d50, _id=5, 
    _o=0x7fff9a353db0) at ./kmcommands.moc:148
#16 0x00002aab10b3bd49 in KMMenuCommand::qt_invoke (this=0x2b73a80, _id=33, 
    _o=0x1cf3a00) at ./kmcommands.moc:2509
#17 0x00002aab10b3bdcd in KMMoveCommand::qt_invoke (this=0x2131d50, _id=5, 
    _o=0x7fff9a353db0) at ./kmcommands.moc:2692
#18 0x00002aab10b3be09 in KMDeleteMsgCommand::qt_invoke (this=0x2b73a80, 
    _id=33, _o=0x1cf3a00) at ./kmcommands.moc:2767
#19 0x00002aab11f05c26 in QObject::activate_signal (this=0x2131d50, 
    clist=0x1c9b8b0, o=0x7fff9a353db0) at kernel/qobject.cpp:2356
#20 0x00002aab10ac6e3c in KMCommand::messagesTransfered (
    this=<value optimized out>, t0=KMCommand::OK) at ./kmcommands.moc:126
#21 0x00002aab10b8df7d in KMCommand::transferSelectedMsgs (this=0x2131d50)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/kmcommands.cpp:351
#22 0x00002aab10b3bad7 in KMCommand::qt_invoke (this=0x2131d50, _id=4, 
    _o=0x7fff9a353fa0) at ./kmcommands.moc:147
#23 0x00002aab10b3bd49 in KMMenuCommand::qt_invoke (this=0x2b73a80, _id=33, 
    _o=0x1cf3a00) at ./kmcommands.moc:2509
#24 0x00002aab10b3bdcd in KMMoveCommand::qt_invoke (this=0x2131d50, _id=4, 
    _o=0x7fff9a353fa0) at ./kmcommands.moc:2692
#25 0x00002aab10b3be09 in KMDeleteMsgCommand::qt_invoke (this=0x2b73a80, 
    _id=33, _o=0x1cf3a00) at ./kmcommands.moc:2767
#26 0x00002aab11f05c26 in QObject::activate_signal (this=0x13e1750, 
    clist=0x2cd95e0, o=0x7fff9a353fa0) at kernel/qobject.cpp:2356
#27 0x00002aab12272f88 in QSignal::signal (this=0x13e1750, t0=@0x13e17a0)
    at .moc/debug-shared-mt/moc_qsignal.cpp:100
#28 0x00002aab11f24cf7 in QSignal::activate (this=0x13e1750)
    at kernel/qsignal.cpp:212
#29 0x00002aab11f2bcb6 in QSingleShotTimer::event (this=0x13e1700)
    at kernel/qtimer.cpp:286
#30 0x00002aab11ea1262 in QApplication::internalNotify (this=0x7fff9a354850, 
    receiver=0x13e1700, e=0x7fff9a354490) at kernel/qapplication.cpp:2635
#31 0x00002aab11ea300c in QApplication::notify (this=0x7fff9a354850, 
    receiver=0x13e1700, e=0x7fff9a354490) at kernel/qapplication.cpp:2358
#32 0x00002aab117fc8be in KApplication::notify (this=0x7fff9a354850, 
    receiver=0x13e1700, event=0x7fff9a354490)
    at /build/buildd/kdelibs-3.5.5a.dfsg.1/./kdecore/kapplication.cpp:550
#33 0x00002aab11e34802 in QApplication::sendEvent (receiver=0x13e1700, 
    event=0x7fff9a354490) at ../include/qapplication.h:520
#34 0x00002aab11e9457c in QEventLoop::activateTimers (this=0x564ce0)
    at kernel/qeventloop_unix.cpp:556
#35 0x00002aab11e48584 in QEventLoop::processEvents (this=0x564ce0, flags=4)
    at kernel/qeventloop_x11.cpp:389
#36 0x00002aab11eba7ee in QEventLoop::enterLoop (this=0x564ce0)
    at kernel/qeventloop.cpp:198
#37 0x00002aab11eba5f7 in QEventLoop::exec (this=0x564ce0)
    at kernel/qeventloop.cpp:145
#38 0x00002aab11ea2d40 in QApplication::exec (this=0x7fff9a354850)
    at kernel/qapplication.cpp:2758
#39 0x000000000040291d in main (argc=<value optimized out>, 
    argv=<value optimized out>)
    at /build/buildd/kdepim-3.5.5.dfsg.1/./kmail/main.cpp:110
#40 0x00002aab113f94ca in __libc_start_main () from /lib/libc.so.6
#41 0x00000000004026aa in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 1 Tommi Tervo 2007-03-09 10:24:23 UTC
*** Bug 140724 has been marked as a duplicate of this bug. ***
Comment 2 Bram Schoenmakers 2007-05-15 13:20:25 UTC
Could you try this with the nearly released KDE 3.5.7 please (next week from now). A lot of crashes regarding IMAP have been fixed in the meantime.
Comment 3 Bram Schoenmakers 2007-07-03 00:23:35 UTC
Have you tried already?
Comment 4 Bram Schoenmakers 2007-08-02 23:15:32 UTC
Reopen if the crash still happens. No reply means 'issue solved' to me.
Comment 5 Dario Andres 2009-02-21 22:38:23 UTC
Bug 185165 looks related to this (but in KDE4.1.3)