Bug 142633 - crash on ctrl + z (undo)
Summary: crash on ctrl + z (undo)
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 151046 161819 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-07 08:03 UTC by Daniel Dumitrache
Modified: 2010-01-03 21:55 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Dumitrache 2007-03-07 08:03:40 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs

deleted all messages in a folder (with shift + del), and immediately after that pressed ctrl + z, and I got this crash:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241569584 (LWP 23913)]
[New Thread -1279673456 (LWP 23919)]
[New Thread -1271280752 (LWP 23918)]
[New Thread -1262888048 (LWP 23917)]
[New Thread -1254495344 (LWP 23916)]
[KCrash handler]
#9  0xb5699695 in FolderStorage::moveMsg ()
   from /opt/kde3/lib/libkmailprivate.so
#10 0xb567b815 in KMFolder::moveMsg () from /opt/kde3/lib/libkmailprivate.so
#11 0xb573bed3 in KMail::UndoStack::undo ()
   from /opt/kde3/lib/libkmailprivate.so
#12 0xb563d755 in KMHeaders::undo () from /opt/kde3/lib/libkmailprivate.so
#13 0xb57ef0cb in KMMainWidget::slotUndo ()
   from /opt/kde3/lib/libkmailprivate.so
#14 0xb5800e57 in KMMainWidget::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so
#15 0xb6c303cd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0xb6c3100d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0xb744ea39 in KAction::activated () from /opt/kde3/lib/libkdeui.so.4
#18 0xb7486cc2 in KAction::slotActivated () from /opt/kde3/lib/libkdeui.so.4
#19 0xb7555f3f in KAction::qt_invoke () from /opt/kde3/lib/libkdeui.so.4
#20 0xb6c303cd in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0xb6c3100d in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb71ab089 in KAccelPrivate::menuItemActivated ()
   from /opt/kde3/lib/libkdecore.so.4
#23 0xb71faa07 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde3/lib/libkdecore.so.4
#24 0xb72415ee in KAccelPrivate::eventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#25 0xb6c2fccc in QObject::activate_filters ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb6c2fd3b in QObject::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0xb6c68e3c in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0xb6d24232 in QMainWindow::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0xb6bd1647 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb6bd2968 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0xb728f2b2 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0xb7207379 in KAccelEventHandler::x11Event ()
   from /opt/kde3/lib/libkdecore.so.4
#33 0xb728d6e3 in KApplication::x11EventFilter ()
   from /opt/kde3/lib/libkdecore.so.4
#34 0xb6b60c14 in qt_set_x11_event_filter ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0xbfb27bbc in ?? ()
#36 0xbfb27ac8 in ?? ()
#37 0x00000001 in ?? ()
#38 0xb709cff4 in ?? () from /usr/lib/qt3/lib/libqt-mt.so.3
#39 0xb709cff4 in ?? () from /usr/lib/qt3/lib/libqt-mt.so.3
#40 0x085150c0 in ?? ()
#41 0xbfb279d8 in ?? ()
#42 0xb6b6fa73 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#43 0xb6b6fa73 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#44 0xb6b8091a in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#45 0xb6be80e0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#46 0xb6be7f76 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#47 0xb6bd100f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#48 0x08058c22 in main ()
Comment 1 Thomas McGuire 2007-03-08 12:31:49 UTC
Are you using IMAP or POP3?
Comment 2 Daniel Dumitrache 2007-03-08 12:40:24 UTC
I'm using both of them. The crash happened with a local folder with messages downloaded with pop3. The thing is I couldn't reproduce this :)
Comment 3 Thomas McGuire 2007-10-19 18:52:30 UTC
*** Bug 151046 has been marked as a duplicate of this bug. ***
Comment 4 Olivier Vitrat 2007-11-03 22:58:39 UTC
You can find another backtrace in Debian BTS at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=448713
Comment 5 Marcus Better 2007-11-05 13:21:58 UTC
I just hit this (see comment #4) for the second time when pressing Undo. This is with Kmail 1.9.7 (Debian package version 4:3.5.7-4).
Comment 6 Thomas McGuire 2008-05-16 19:36:03 UTC
*** Bug 161819 has been marked as a duplicate of this bug. ***
Comment 7 Björn Ruberg 2010-01-03 21:55:25 UTC
Cannot reproduce in KDE 4.3. Can anyone else?