Bug 142538 - crashes if you try to delete many massagea on an imap account
Summary: crashes if you try to delete many massagea on an imap account
Status: RESOLVED DUPLICATE of bug 112128
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-03-05 08:24 UTC by Reinhard.Thies
Modified: 2007-03-05 11:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reinhard.Thies 2007-03-05 08:24:30 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-6 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-kanotix-1

Trying to delete 560 messages on an imap account let kmail crash.
The failure is reproduceable.
Comment 1 Thomas McGuire 2007-03-05 10:36:57 UTC
Can you please paste the backtrace here?
Comment 2 Reinhard.Thies 2007-03-05 10:55:05 UTC
Hi Thomas,

in this case I had a folder with 555 read mails and 2 unread mails. I used 
Ctrl-A to mark all messages and then Shift-Delete to delete all messages.
After confirming the delete KMail crashes .


On Monday, 5. March 2007 10:36, Thomas McGuire wrote:
[bugs.kde.org quoted mail]
(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242065216 (LWP 8343)]
[New Thread -1285088336 (LWP 8350)]
[New Thread -1276699728 (LWP 8349)]
[New Thread -1268311120 (LWP 8348)]
[New Thread -1259922512 (LWP 8347)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0x00000049 in ?? ()
#6  0xb51ca625 in KMHeaders::msgRemoved () from /usr/lib/libkmailprivate.so
#7  0xb52c4779 in KMHeaders::qt_invoke () from /usr/lib/libkmailprivate.so
#8  0xb700cd4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#9  0xb50da120 in KMFolder::msgRemoved () from /usr/lib/libkmailprivate.so
#10 0xb51bf74d in KMFolder::qt_emit () from /usr/lib/libkmailprivate.so
#11 0xb700cd23 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb50d9230 in FolderStorage::msgRemoved ()
   from /usr/lib/libkmailprivate.so
#13 0xb5237651 in FolderStorage::removeMsg () from /usr/lib/libkmailprivate.so
#14 0xb5308378 in KMFolderImap::removeMsg () from /usr/lib/libkmailprivate.so
#15 0xb5091576 in KMFolder::removeMsg () from /usr/lib/libkmailprivate.so
#16 0xb515d900 in KMMoveCommand::execute () from /usr/lib/libkmailprivate.so
#17 0xb50d3549 in KMCommand::slotPostTransfer ()
   from /usr/lib/libkmailprivate.so
#18 0xb515f126 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#19 0xb515f4fb in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#20 0xb515f593 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#21 0xb700cd4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb50d366e in KMCommand::messagesTransfered ()
   from /usr/lib/libkmailprivate.so
#23 0xb51c0184 in KMCommand::transferSelectedMsgs ()
   from /usr/lib/libkmailprivate.so
#24 0xb51c02e7 in KMCommand::slotStart () from /usr/lib/libkmailprivate.so
#25 0xb515f138 in KMCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#26 0xb515f4fb in KMMenuCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#27 0xb515f593 in KMMoveCommand::qt_invoke () from /usr/lib/libkmailprivate.so
#28 0xb700cd4f in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#29 0xb7395d97 in QSignal::signal () from /usr/lib/libqt-mt.so.3
#30 0xb702c8d2 in QSignal::activate () from /usr/lib/libqt-mt.so.3
#31 0xb70342a4 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#32 0xb6fa4c26 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#33 0xb6fa6a43 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#34 0xb76cce0e in KApplication::notify () from /usr/lib/libkdecore.so.4
#35 0xb6f38421 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#36 0xb6f97623 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#37 0xb6f4c76f in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#38 0xb6fbf179 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#39 0xb6fbef9a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#40 0xb6fa67bf in QApplication::exec () from /usr/lib/libqt-mt.so.3
#41 0x0805ac3f in ?? ()
#42 0xbf8330ec in ?? ()
#43 0x00000001 in ?? ()
#44 0x00000001 in ?? ()
#45 0x00000000 in ?? ()
Comment 3 Thomas McGuire 2007-03-05 11:08:10 UTC
Thanks for the backtrace. The backtrace looks the same like that in bug #126999.
Since that bug has been closed as a duplicate of bug #112128, I'll close this one as a dupe of bug #112128 as well.

*** This bug has been marked as a duplicate of 112128 ***