Bug 142222 - It doesn't load. Crashes instead.
Summary: It doesn't load. Crashes instead.
Status: RESOLVED DUPLICATE of bug 141299
Alias: None
Product: basket
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastien
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-26 13:55 UTC by Scott Warner
Modified: 2007-04-12 18:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Warner 2007-02-26 13:55:28 UTC
Version:           4:3.5.5-0ubuntu1 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

I installed Kubuntu Dapper.  Then I upgraded to Edgy.  I had not used Kontact in Dapper.  It doesn't load up.  Gives a Signal 11.  Below is a Backtrace.

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242039504 (LWP 5421)]
[New Thread -1280570464 (LWP 5428)]
[New Thread -1272177760 (LWP 5427)]
[New Thread -1263785056 (LWP 5426)]
[New Thread -1255392352 (LWP 5425)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x53e58955 in ?? ()
#7  0xb6ffc72e in QObject::connect () from /usr/lib/libqt-mt.so.3
#8  0xb7dde1df in Kontact::Plugin::part () from /usr/lib/libkpinterfaces.so.1
#9  0x08061160 in ?? ()
#10 0x082857b0 in ?? ()
#11 0x00000000 in ?? ()
Comment 1 Thomas McGuire 2007-02-26 18:06:38 UTC
Do you, by chance, have basket installed?
Can you try to install the debug packages to get a better backtrace?
Comment 2 Scott Warner 2007-02-26 18:35:03 UTC
I do have basket installed.  I also installed kdepim-dbg.  Is that the debugging package you mentioned?
Comment 3 Thomas McGuire 2007-02-26 18:41:10 UTC
>I do have basket installed.  
Try deinstalling it.

>I also installed kdepim-dbg.  Is that the debugging package you mentioned? 
Yes. The debug packages of kdelibs and qt should also be installed.
Comment 4 Scott Warner 2007-02-26 20:36:07 UTC
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1241822416 (LWP 5849)]
[New Thread -1280353376 (LWP 5853)]
[New Thread -1271960672 (LWP 5852)]
[New Thread -1263567968 (LWP 5851)]
[New Thread -1255175264 (LWP 5850)]
[KCrash handler]
#6  0x53e58955 in ?? ()
#7  0xb703172e in QObject::connect (sender=0xb5a210cc, 
    signal=0xb7e165da "2destroyed()", receiver=0x827fb40, 
    member=0xb7e165c9 "1partDestroyed()") at kernel/qobject.cpp:1732
#8  0xb7e131df in Kontact::Plugin::part (this=0x827fb40)
    at /usr/share/qt3/include/qobject.h:228
#9  0x08061160 in Kontact::MainWindow::selectPlugin (this=0x810b260, 
    plugin=0x827fb40)
    at /build/buildd/kdepim-3.5.5/./kontact/src/mainwindow.cpp:536
#10 0x0805a4b2 in Kontact::MainWindow::loadSettings (this=0x810b260)
    at /build/buildd/kdepim-3.5.5/./kontact/src/mainwindow.cpp:636
#11 0x0805f9e2 in Kontact::MainWindow::initObject (this=0x810b260)
    at /build/buildd/kdepim-3.5.5/./kontact/src/mainwindow.cpp:160
#12 0x080606df in KontactApp::newInstance (this=0xbf880590)
    at /build/buildd/kdepim-3.5.5/./kontact/src/main.cpp:107
#13 0xb76e0adf in KUniqueApplication::processDelayed ()
   from /usr/lib/libkdecore.so.4
#14 0xb76e71b8 in KUniqueApplication::qt_invoke ()
   from /usr/lib/libkdecore.so.4
#15 0xb702f957 in QObject::activate_signal (this=0x8101558, clist=0x8101650, 
    o=0xbf87ff38) at kernel/qobject.cpp:2356
#16 0xb73bbf44 in QSignal::signal (this=0x8101558, t0=@0x8101580)
    at .moc/debug-shared-mt/moc_qsignal.cpp:100
#17 0xb704f8ea in QSignal::activate (this=0x8101558) at kernel/qsignal.cpp:212
#18 0xb7057300 in QSingleShotTimer::event (this=0x8101530)
    at kernel/qtimer.cpp:286
#19 0xb6fc6b88 in QApplication::internalNotify (this=0xbf880590, 
    receiver=0x8101530, e=0xbf880288) at kernel/qapplication.cpp:2635
#20 0xb6fc89b7 in QApplication::notify (this=0xbf880590, receiver=0x8101530, 
    e=0xbf880288) at kernel/qapplication.cpp:2358
#21 0xb76efdb2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#22 0xb6f59389 in QApplication::sendEvent (receiver=0x8101530, 
    event=0xbf880288) at ../include/qapplication.h:520
#23 0xb6fb95d3 in QEventLoop::activateTimers (this=0x80f5360)
    at kernel/qeventloop_unix.cpp:556
#24 0xb6f6dec5 in QEventLoop::processEvents (this=0x80f5360, flags=4)
    at kernel/qeventloop_x11.cpp:389
#25 0xb6fe125e in QEventLoop::enterLoop (this=0x80f5360)
    at kernel/qeventloop.cpp:198
#26 0xb6fe106e in QEventLoop::exec (this=0x80f5360)
    at kernel/qeventloop.cpp:145
#27 0xb6fc8731 in QApplication::exec (this=0xbf880590)
    at kernel/qapplication.cpp:2758
#28 0x0805ad81 in main (argc=1, argv=)
    at /build/buildd/kdepim-3.5.5/./kontact/src/main.cpp:161
#29 0xb778d8cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#30 0x08058311 in _start ()


Will I still be able to use basket later, if I uninstall it now.  I mean, does basket work with kontact?

Thanks,
Scott
Comment 5 Thomas McGuire 2007-02-27 14:37:35 UTC
> Will I still be able to use basket later, if I uninstall it now. 
Comment 6 Scott Warner 2007-03-06 22:33:54 UTC
Kontact did work when Basket was uninstalled.  It also works if Basket is already running when I try to run Kontact.  Thanks for you help
Comment 7 Thomas McGuire 2007-03-07 00:25:40 UTC
Closing since this is a Basket bug, not a Kontact bug.
Comment 8 Bram Schoenmakers 2007-03-07 16:32:19 UTC
Nice try Thomas :)
Comment 9 Thomas McGuire 2007-03-08 12:17:38 UTC
>Nice try Thomas :) 
Oops, I didn't know that basket has its own category in the bug system. Sorry.
Comment 10 Thomas McGuire 2007-04-12 18:50:08 UTC

*** This bug has been marked as a duplicate of 141299 ***