Bug 141910 - Maximize for widescreen
Summary: Maximize for widescreen
Status: RESOLVED DUPLICATE of bug 59338
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-19 07:10 UTC by Quentin Jackson
Modified: 2007-06-04 14:18 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Quentin Jackson 2007-02-19 07:10:52 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs
OS:                Linux

This could be part of XGL/Compiz but I feel it would be just as essential in the non-3d desktop.  

The idea is simply that nowadays if you have a widescreen desktop, a lot of this space is wasted.  Often I will be working on two documents, or two applications and maximise my appliaction so that it is bigger, however in the case of openoffice for example the document I'm working with shows in only the left hand side of the screen and the rest of the screen is grey and wasted.  I feel it would be very very nice to have maximise options specific for widescreen displays. Something as simple as maximise to left or to right would be great, though I'm sure your clever selves could come up with somethine more automatic and cool than that.  It seems to me that we've had a major change in our screen real estate over the past year or so, but nobody's taking advantage of it.  I would love KDE to be the first to do so! ;}

Q
Comment 1 jos poortvliet 2007-02-19 11:02:07 UTC
Op Monday 19 February 2007, schreef Quentin Jackson:
> This could be part of XGL/Compiz but I feel it would be just as essential
> in the non-3d desktop.
>
> The idea is simply that nowadays if you have a widescreen desktop, a lot of
> this space is wasted.  Often I will be working on two documents, or two
> applications and maximise my appliaction so that it is bigger, however in
> the case of openoffice for example the document I'm working with shows in
> only the left hand side of the screen and the rest of the screen is grey
> and wasted.  I feel it would be very very nice to have maximise options
> specific for widescreen displays. Something as simple as maximise to left
> or to right would be great, though I'm sure your clever selves could come
> up with somethine more automatic and cool than that.  It seems to me that
> we've had a major change in our screen real estate over the past year or
> so, but nobody's taking advantage of it.  I would love KDE to be the first
> to do so! ;}


Well, then, I think the developers love how much you trust them coming up with 
great ideas, but the fact is that KDE needs it's users for this more than for 
anything. You're right, doing something with the transition to widescreen is 
very important. Microsoft has already made a stupid decision here - their new 
office places all it's info on top of a window, while Koffice is working on 
sidebars - much more space-efficient. But you might be right, maybe Kwin can 
help here too.

But for that, we need ideas. Some developers here might be very smart (true, 
they are) but it's hard to come up with a solution for this. Any thoughts 
from other people would help, so if you or someone you know can spend a few 
hours brooding about this would be great, even more so as you might think.

Hint: I always think during showering, and get the greatest ideas then. My 
problem is I've forgotten most of them when I finally get to a pc or paper to 
write it down ;-)

> Q


Superstoned
Comment 2 Lubos Lunak 2007-02-19 11:06:16 UTC
Jos: Please don't include reply quotation like this in bugzilla.
Comment 3 jos poortvliet 2007-02-19 12:38:05 UTC
I'm sorry, won't do it again. I replied using mail, works nice but there is this force of habit to keep too much of what the other person said ;-)
Comment 4 Lubos Lunak 2007-06-04 14:18:29 UTC

*** This bug has been marked as a duplicate of 59338 ***