Bug 141455 - kmail hangs when doing 'add to adressbook'
Summary: kmail hangs when doing 'add to adressbook'
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 141926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-09 20:59 UTC by jos poortvliet
Modified: 2010-01-03 12:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
gdb, didnt' seem to work?!? (9.53 KB, text/plain)
2007-02-19 23:58 UTC, jos poortvliet
Details
second try, with --nofork (9.53 KB, text/plain)
2007-02-21 01:58 UTC, jos poortvliet
Details
problem file 1 (158.15 KB, text/x-vcard)
2007-03-06 15:42 UTC, jos poortvliet
Details
problem file 2 (156.08 KB, text/x-vcard)
2007-03-06 15:43 UTC, jos poortvliet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jos poortvliet 2007-02-09 20:59:40 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    Unlisted Binary Package
Compiler:          gcc 4.1.x 
OS:                Linux

When I recieve a mail from a 'new' person and want to add it to the addressbook, I do a righmouseclick on the mailadress, and choose 'add to addressbook. Kmail not only doesn't do that (as I can see in the addressbook) but it kind'a hangs. It doesn't accept input, just waits. I can resize the window, and it repaints, but I can't click anything, mouseovers don't work etcetera. I have to kill Kmail (or kill kontact, but it doesn't matter if I do this from Kontact or Kmail seperately).

I use archlinux packages with KDE 3.5.6, but I've been having this problem for a long while - was too lazy to report it...
Comment 1 Thomas McGuire 2007-02-19 15:37:57 UTC
*** Bug 141926 has been marked as a duplicate of this bug. ***
Comment 2 Bram Schoenmakers 2007-02-19 23:30:47 UTC
Could you please try to run in KMail in GDB and send a kill signal whenever it happens and post a backtrace here?

(BTW, changing severity to normal, it's not a crash after all. There seems to be a rule for that in BKO).
Comment 3 jos poortvliet 2007-02-19 23:58:29 UTC
Created attachment 19750 [details]
gdb, didnt' seem to work?!?
Comment 4 Ismail Onur Filiz 2007-02-21 01:04:22 UTC
Please use the packages with debugging symbols. And try running kmail with --nofork ( call "set args --nofork" before "run" in gdb )
Comment 5 jos poortvliet 2007-02-21 01:54:40 UTC
Hmm, sorry, don't have debug packages. You can't reproduce it? It's fairly easy - open a mail, rightmouseclick on the sender's address, add to addressbook - now try to open another mail, do anything. Here, that would be impossible...
Comment 6 jos poortvliet 2007-02-21 01:58:20 UTC
Created attachment 19769 [details]
second try, with --nofork
Comment 7 Ismail Onur Filiz 2007-02-21 02:47:34 UTC
I tried it and it works properly. It most probably hangs while querying for resources ( a corrupt resource file, an invalid server etc). Could you try with a new user, with a single addressbook resource?
Comment 8 jos poortvliet 2007-02-21 12:19:11 UTC
I fixed it by exporting my current addressbook to a vcf file, removing the std.vcf, and choosing the new vcf as default addressbook. Now I can add ppl to it without any hangs. If you want, I can email the std.vcf which lead to crashes - but if you think that's pretty useless (with akonadi & friends upcoming), say so, and (let me) close the bug.
Comment 9 Allen Winter 2007-03-06 02:50:32 UTC
I think we would like to see the std.vcf that caused the hang.
If you still have the file.  But it will surely get lost unless you can attach it to this bug report.  It's up to you if you want to do that.
Comment 10 jos poortvliet 2007-03-06 15:42:33 UTC
Created attachment 19894 [details]
problem file 1

I get the problem when I add these two files as active to my addressbook (as
you see, it doesn't make sense, as they are practically the same so you get
everything doubled, but at least it reliably reproduces the crash...)
Comment 11 jos poortvliet 2007-03-06 15:43:07 UTC
Created attachment 19895 [details]
problem file 2
Comment 12 jos poortvliet 2007-03-06 15:44:08 UTC
I hope it helps debugging the problem ;-)
Comment 13 Igor Lautar 2007-05-21 17:16:40 UTC
I experience the same problem.

One of my resources is LDAP users directory (1000+ entries), which is cached locally.

Disabling (unchecking it) and restarting kontact helps.

Cannot GDB it (GDB finishes while kmail is running, fork()? ).
Comment 14 Thomas McGuire 2007-05-21 17:22:14 UTC
>Cannot GDB it (GDB finishes while kmail is running, fork()? ). 
Use --nofork as argument to KMail
Comment 15 Björn Ruberg 2010-01-03 01:50:39 UTC
Still happening in KDE 4.3+?
Comment 16 jos poortvliet 2010-01-03 12:20:25 UTC
Nope, doesn't... Guessing with all the rewriting this ain't relevant anymore. I've closed it as fixed. Thanks for reminding me!