Bug 141234 - KMail crash on quit
Summary: KMail crash on quit
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: SVN (3.5 branch)
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-05 20:18 UTC by Michael Seiwert
Modified: 2007-03-22 18:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Seiwert 2007-02-05 20:18:49 UTC
Version:           1.9.6 (using KDE KDE 3.5.6)
Installed from:    Compiled From Sources
Compiler:          gcc version 4.1.2 20061115 (prerelease) (SUSE Linux) 
OS:                Linux

Sice some weeks kmail constantly crashes while quitting it. This is really annoying. I'm using SuSE 10.2, kdepim 3_5_BRANCH from 05.02.2007. Please see attached bt:
Comment 1 Michael Seiwert 2007-02-05 20:19:28 UTC
Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1250740528 (LWP 8909)]
[New Thread -1280869488 (LWP 8913)]
[New Thread -1272476784 (LWP 8912)]
[New Thread -1264084080 (LWP 8911)]
[New Thread -1255691376 (LWP 8910)]
[KCrash handler]
#9  0x082d7fdd in ?? ()
#10 0xb7c87985 in KMFolderDir::label (this=0x8158680)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:148
#11 0xb7c87c3a in KMFolderDir::prettyURL (this=0x8158680)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:163
#12 0xb7c87b82 in KMFolderDir::prettyURL (this=0x8199880)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:159
#13 0xb7c87b82 in KMFolderDir::prettyURL (this=0x81a3d60)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:159
#14 0xb7c87b82 in KMFolderDir::prettyURL (this=0x8233480)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:159
#15 0xb7c40c62 in KMFolder::prettyURL (this=0x8233ad0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolder.cpp:567
#16 0xb7cec728 in KMFolderMbox::close (this=0x8233cc8, aForced=true)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldermbox.cpp:261
#17 0xb7ceda30 in ~KMFolderMbox (this=0x8233cc8)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldermbox.cpp:86
#18 0xb7cfa523 in ~KMFolderImap (this=0x8233cc8)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderimap.cpp:105
#19 0xb7c41fbe in ~KMFolder (this=0x8233ad0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolder.cpp:148
#20 0xb7c891b6 in QPtrList<KMFolderNode>::deleteItem (this=0x82334b8, 
    d=0x8233ad0) at /usr/lib/qt3/include/qptrlist.h:150
#21 0xb615c10d in QGList::clear () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0xb7c89225 in QPtrList<KMFolderNode>::clear (this=0x82334b8)
    at /usr/lib/qt3/include/qptrlist.h:93
#23 0xb7c8802c in ~KMFolderDir (this=0x8233480)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:90
#24 0xb7c891b6 in QPtrList<KMFolderNode>::deleteItem (this=0x81a3d98, 
    d=0x8233480) at /usr/lib/qt3/include/qptrlist.h:150
#25 0xb615c10d in QGList::clear () from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0xb7c89225 in QPtrList<KMFolderNode>::clear (this=0x81a3d98)
    at /usr/lib/qt3/include/qptrlist.h:93
#27 0xb7c8802c in ~KMFolderDir (this=0x81a3d60)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:90
#28 0xb7c891b6 in QPtrList<KMFolderNode>::deleteItem (this=0x81998b8, 
    d=0x81a3d60) at /usr/lib/qt3/include/qptrlist.h:150
#29 0xb615c10d in QGList::clear () from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0xb7c89225 in QPtrList<KMFolderNode>::clear (this=0x81998b8)
    at /usr/lib/qt3/include/qptrlist.h:93
#31 0xb7c8802c in ~KMFolderDir (this=0x8199880)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:90
#32 0xb7c891b6 in QPtrList<KMFolderNode>::deleteItem (this=0x81586b8, 
    d=0x8199880) at /usr/lib/qt3/include/qptrlist.h:150
#33 0xb615c10d in QGList::clear () from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0xb7c89225 in QPtrList<KMFolderNode>::clear (this=0x81586b8)
    at /usr/lib/qt3/include/qptrlist.h:93
#35 0xb7c8802c in ~KMFolderDir (this=0x8158680)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:90
#36 0xb7c891b6 in QPtrList<KMFolderNode>::deleteItem (this=0x8148b54, 
    d=0x8158680) at /usr/lib/qt3/include/qptrlist.h:150
#37 0xb615c10d in QGList::clear () from /usr/lib/qt3/lib/libqt-mt.so.3
#38 0xb7c89225 in QPtrList<KMFolderNode>::clear (this=0x8148b54)
    at /usr/lib/qt3/include/qptrlist.h:93
#39 0xb7c88f5a in ~KMFolderRootDir (this=0x8148b1c)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfolderdir.cpp:35
#40 0xb7c8c25e in ~KMFolderMgr (this=0x8148af0)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmfoldermgr.cpp:51
#41 0xb7d21830 in KMKernel::cleanup (this=0xbf83bb24)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/kmkernel.cpp:1714
#42 0x0804a960 in main (argc=7, argv=0xbf83bce4)
    at /home/mseiwert/src/svn/kde/branches/3.5/kdepim/kmail/main.cpp:112
Comment 2 Stephan Kulow 2007-03-21 07:56:30 UTC
try with valgrind if you can reproduce
Comment 3 Stephan Kulow 2007-03-21 07:56:34 UTC
try with valgrind if you can reproduce
Comment 4 Michael Seiwert 2007-03-22 18:11:49 UTC
seems to be fixed with the latest imap fixes, so closing this bug for now. I'll reopen if the crash comes back.