Bug 141200 - templates should allow to select language
Summary: templates should allow to select language
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR wishlist with 153 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 80472 146841 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-02-04 23:37 UTC by Christian Boltz
Modified: 2015-01-08 07:05 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 14.12.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Boltz 2007-02-04 23:37:29 UTC
Version:            (using KDE KDE 3.5.6)
Installed from:    SuSE RPMs

KMail's new template feature misses the option to select the language.

The reason why this is needed is the date - it doesn't look very professional if your mail contains

    on Sonntag, 4. Februar 2007, kmailuser wrote:
       ^^^^^^^^^^^^^^^^^^^^^^^^
       This should be in english
Comment 1 Jonathan Marten 2007-02-05 09:19:41 UTC
*** Bug 80472 has been marked as a duplicate of this bug. ***
Comment 2 brazzmonkey 2007-04-05 12:02:12 UTC
no no no, this bug should not be a duplicate of bug 80472 !!
Christian is right, there should be an option to select template language in newest kmail in kde 3.5.6 !
my linux box (kubuntu 6.10) is in english, but i need some mail templates to be in french otherwise i get a mix of french and english in templates generated email. this previously didn't happen with kmail phrases (before templates were introduced).

user should be able to select (at least) which language must be used in templates commands.

bug 1015 refers to templates language capabilities, but this feature is no where to be found in latest kmail.
Comment 3 Raphael Schneider 2007-04-18 11:13:08 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Thomas McGuire 2007-06-16 11:23:51 UTC
*** Bug 146841 has been marked as a duplicate of this bug. ***
Comment 5 Thomas McGuire 2007-07-17 13:39:08 UTC
Mass-changing component to "templates" and adding original template author to 
CC list.
Comment 6 Fisiu 2008-10-15 17:17:11 UTC
KMail 1.9.10, KDE 3.5.10, openSUSE 11.0

Templates still won't change during change of identify while reply. For each identify, templates are created. But only one used is template from Default Identify. And there is no option to change it automatically while changing Identify.

Any progres with this old bug?
Comment 7 Tristan Miller 2009-04-25 23:12:02 UTC
Feature still missing as of KDE 4.2.2.
Comment 8 Martin Koller 2009-08-04 23:04:04 UTC
this is not a bug but a missing feature. changing to wish
Comment 9 Björn Ruberg 2009-12-21 20:14:31 UTC
You should be able to write templates for different languages. In addition, bug #81754 needs to be implemented.
Comment 10 Anne-Marie Mahfouf 2011-11-30 14:47:29 UTC
Seems still valid for KMail2, reassigning to kmail2 product.
Comment 11 Rafał Rzepecki 2014-10-03 13:35:00 UTC
Still valid as of 4.14.
Comment 12 Laurent Montel 2015-01-06 08:02:25 UTC
We can force language but it will work only if i18n is installed on computer.
I can look at to add "%LANGUAGE="..." in templateparser
Comment 13 Laurent Montel 2015-01-08 07:05:57 UTC
Git commit 01ecc71f658627b7c4b788df3e8c1f269f0b4ce6 by Montel Laurent.
Committed on 08/01/2015 at 07:04.
Pushed by mlaurent into branch 'KDE/4.14'.

Fix Bug 141200 - templates should allow to select language

FIXED-IN: 14.12.1

Now we can specify language which is used in template for defined date/time and co.

But we need to have language installed on computer.

M  +20   -11   templateparser/templateparser.cpp

http://commits.kde.org/kdepim/01ecc71f658627b7c4b788df3e8c1f269f0b4ce6