Bug 140872 - crashing when shift + right arrow pressed
Summary: crashing when shift + right arrow pressed
Status: RESOLVED DUPLICATE of bug 136288
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-30 04:46 UTC by SasQ
Modified: 2007-01-30 07:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SasQ 2007-01-30 04:46:51 UTC
Version:           1.5.5 (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
Compiler:          gcc version 3.3.5-20050130 Gentoo 3.3.5.20050130-r1, ssp-3.3.5.20050130-1, pie-8.7.7.1
OS:                Linux

* How to reproduce:
Hold Shift key and press right arrow.

It's strange, but for me it is causing a crash.
Console output:

---cut start: console output---
$ umbrello
KCrash: Application 'umbrello' crashing...
KCrash cannot reach kdeinit, launching directly.
$ _
---cut end: console output---

The more strange is that with Ctrl pressed nothing happens. Crash occurs only when I press ONLY Shift + right arrow.

GDB output after pressing that key combination:

---cut start: GDB output after pressing Shift + right arrow ---
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 11833)]
0xb70dad7a in QTabWidget::currentPageIndex () from /usr/qt/3/lib/libqt-mt.so.3
(gdb) cont
Continuing.
KCrash: Application 'umbrello' crashing...
KCrash cannot reach kdeinit, launching directly.

Program exited with code 0375.
---cut end: GDB output after pressing Shift + right arrow ---

And here's backtrace from GDB after receiving SIGSEGV:

---cut start: GDB backtrace after pressing Shift + right arrow ---
#0  0xb705bd7a in QTabWidget::currentPageIndex ()
   from /usr/qt/3/lib/libqt-mt.so.3
#1  0x0817657a in UMLApp::slotChangeTabRight ()
#2  0x08176a16 in UMLApp::qt_invoke ()
#3  0xb6f301cc in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#4  0xb6f2fff4 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#5  0xb7818d5b in KAction::activated () from /usr/kde/3.5/lib/libkdeui.so.4
#6  0xb78184da in KAction::slotActivated () from /usr/kde/3.5/lib/libkdeui.so.4
#7  0xb7819016 in KAction::qt_invoke () from /usr/kde/3.5/lib/libkdeui.so.4
#8  0xb6f301cc in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#9  0xb6f2fff4 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#10 0xb75c0cdb in KAccelPrivate::menuItemActivated ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#11 0xb75bf5f9 in KAccelPrivate::emitActivatedSignal ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#12 0xb75bf3a4 in KAccelPrivate::eventFilter ()
   from /usr/kde/3.5/lib/libkdecore.so.4
#13 0xb6f2dafe in QObject::activate_filters () from /usr/qt/3/lib/libqt-mt.so.3
#14 0xb6f2da2c in QObject::event () from /usr/qt/3/lib/libqt-mt.so.3
#15 0xb6f6652f in QWidget::event () from /usr/qt/3/lib/libqt-mt.so.3
#16 0xb70250f2 in QMainWindow::event () from /usr/qt/3/lib/libqt-mt.so.3
#17 0xb6ed39df in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#18 0xb6ed3244 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb7529e12 in KApplication::notify () from /usr/kde/3.5/lib/libkdecore.so.4
#20 0xb6ecb542 in QAccelManager::tryAccelEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb6ecaf1e in qt_tryAccelEvent () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6e6b5af in QETWidget::translateKeyEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6e668f9 in QApplication::x11ProcessEvent ()
   from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb6e7dbb4 in QEventLoop::processEvents () from /usr/qt/3/lib/libqt-mt.so.3
#25 0xb6ee5d18 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb6ee5bc8 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb6ed3c31 in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#28 0x0814da51 in main ()
---cut end: GDB backtrace after pressing Shift + right arrow ---
Comment 1 Oliver Kellogg 2007-01-30 07:37:34 UTC
fixed in >= 1.5.52

*** This bug has been marked as a duplicate of 136288 ***