Bug 140490 - The application kmail crashes after startup. Which makes it impossible to access old and new mail.
Summary: The application kmail crashes after startup. Which makes it impossible to acc...
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 140491 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-23 13:01 UTC by Roel Meeuws
Modified: 2007-09-21 21:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
the mail that crashed kmail (3.36 KB, application/octet-stream)
2007-01-27 17:51 UTC, Roel Meeuws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roel Meeuws 2007-01-23 13:01:37 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

When I start up kmail I first get a kwalletmanager dialog. In the background I see I still have 2 unread emails, which is correct I had still 2 emails open. Then I enter my wallet password. Directly, kmail says there are 65 unread emails and actually, previously read mails are now marked unread. Then within 2 seconds or so, kmail crashes with a segmentation fault. 

First I thought there was something wrong with my gmail pop settings, so I deleted that from the kmailrc file and then the kwalletmanager didn't pop up after startup. Furthermore, I got the message to add an account. after clicking ok on that dialog, the same error occurs. 65 messages seem to be unread and the application crashes. The following trace was generated. Mainly the last few lines might help:

crash report:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 47551422807504 (LWP 12707)]
[New Thread 1107310912 (LWP 12711)]
[New Thread 1098918208 (LWP 12710)]
[New Thread 1090525504 (LWP 12709)]
[New Thread 1082132800 (LWP 12708)]
[KCrash handler]
#5  0x00002b3f631a8780 in KMSearchRuleStatus::matches ()
   from /usr/lib/libkmailprivate.so
#6  0x00002b3f631a58cf in KMSearchPattern::matches ()
   from /usr/lib/libkmailprivate.so
#7  0x00002b3f631a5aaf in KMSearchPattern::matches ()
   from /usr/lib/libkmailprivate.so
#8  0x00002b3f6316d6cf in FolderStorage::slotProcessNextSearchBatch ()
   from /usr/lib/libkmailprivate.so
#9  0x00002b3f6329ca5d in KMSearch::slotProcessNextBatch ()
   from /usr/lib/libkmailprivate.so
#10 0x00002b3f6329cb1e in KMSearch::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#11 0x00002b3f64c78baa in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#12 0x00002b3f64c79744 in QObject::activate_signal ()
   from /usr/lib/libqt-mt.so.3
#13 0x00002b3f64fe872e in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#14 0x00002b3f64c9f06b in QTimer::event () from /usr/lib/libqt-mt.so.3
#15 0x00002b3f64c140f6 in QApplication::internalNotify ()
   from /usr/lib/libqt-mt.so.3
#16 0x00002b3f64c15e85 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#17 0x00002b3f6433af48 in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0x00002b3f64ba6c62 in QApplication::sendEvent ()
   from /usr/lib/libqt-mt.so.3
#19 0x00002b3f64c073b0 in QEventLoop::activateTimers ()
   from /usr/lib/libqt-mt.so.3
#20 0x00002b3f64bbb38f in QEventLoop::processEvents ()
   from /usr/lib/libqt-mt.so.3
#21 0x00002b3f64c2d62b in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#22 0x00002b3f64c2d433 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#23 0x00002b3f64c15bbc in QApplication::exec () from /usr/lib/libqt-mt.so.3
#24 0x0000000000402b84 in ?? ()
#25 0x00002b3f63e268e4 in __libc_start_main () from /lib/libc.so.6
#26 0x00000000004028f9 in ?? ()
#27 0x00007fff47e57fd8 in ?? ()
#28 0x0000000000000000 in ?? ()
Comment 1 Bram Schoenmakers 2007-01-23 17:24:45 UTC
*** Bug 140491 has been marked as a duplicate of this bug. ***
Comment 2 Roel Meeuws 2007-01-27 17:49:52 UTC
Solved it by removing searches. then trying a search on each folder and then searching the folder that crashed the app. There was a mail that was empty. I removed the mail and voila everything was okay again. Somebody should fix this, it shouldn´t crash when an email is not okay. I attached the culprit for your review.
Comment 3 Roel Meeuws 2007-01-27 17:51:39 UTC
Created attachment 19443 [details]
the mail that crashed kmail

This is the email that crashed kmail when the search thread opened it.
Comment 4 Greg Martyn 2007-09-21 18:27:02 UTC
I got hit by this bug too. Happens every startup at the same place. I don't have time to use the GUI before the crash. Here is a more detailed backtrace:

Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912496423200 (LWP 20573)]
[New Thread 1115699536 (LWP 20577)]
[New Thread 1105209680 (LWP 20576)]
[New Thread 1094719824 (LWP 20575)]
[New Thread 1084229968 (LWP 20574)]
[KCrash handler]
#5  KMSearchRuleStatus::matches (this=0x1699740, msg=0x0)
    at kmsearchpattern.cpp:650
#6  0x00002aaab19fb8ff in KMSearchPattern::matches (this=0x169dc80, msg=0x0, 
    ignoreBody=false) at kmsearchpattern.cpp:711
#7  0x00002aaab19fbaed in KMSearchPattern::matches (this=0x169dc80, 
    serNum=<value optimized out>, ignoreBody=false) at kmsearchpattern.cpp:770
#8  0x00002aaab19c2086 in FolderStorage::slotProcessNextSearchBatch (
    this=0x10c3e40) at folderstorage.cpp:1084
#9  0x00002aaab1affc04 in KMSearch::slotProcessNextBatch (this=0x165de00)
    at kmfoldersearch.cpp:266
#10 0x00002aaab1affcbe in KMSearch::qt_invoke (this=0x165de00, _id=3, 
    _o=0x7fffdae8c000) at kmfoldersearch.moc:127
#11 0x0000003be9162a19 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#12 0x0000003be9163700 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#13 0x0000003be9186145 in QTimer::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#14 0x0000003be91019b5 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#15 0x0000003be9102c60 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#16 0x0000003bea3cca58 in KApplication::notify (this=0x7fffdae8c6f0, 
    receiver=0x1698d60, event=0x7fffdae8c340) at kapplication.cpp:550
#17 0x0000003be90f6bcc in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#18 0x0000003be90b02e1 in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#19 0x0000003be9119117 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#20 0x0000003be9118ff2 in QEventLoop::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#21 0x0000000000414d22 in main (argc=1, argv=<value optimized out>)
    at main.cpp:163
#22 0x0000003a2841dab4 in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000414519 in _start ()
Comment 5 Greg Martyn 2007-09-21 18:36:05 UTC
Was able to work around it by deleting my stored search for important mail. I'm going to miss that one..
Comment 6 Allen Winter 2007-09-21 21:19:51 UTC
SVN commit 715297 by winterz:

Fix bug "The application kmail crashes after startup. Which makes it impossible to access old and new mail."

BUGS: 140490


 M  +6 -3      kmsearchpattern.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=715297
Comment 7 Greg Martyn 2007-09-21 21:53:44 UTC
That was fast!

Thanks