Bug 140353 - Annoyance Filter Search Path Fails
Summary: Annoyance Filter Search Path Fails
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: filtering (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-20 16:05 UTC by michael papet
Modified: 2009-09-06 13:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michael papet 2007-01-20 16:05:54 UTC
Version:           1.9.5 (using KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-5 (4.0))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-3-686

/bin/sh: /home/myuser/.annoyance-filter/annoyance-filter: No such file or directory

I'm not sure what it's looking for there, but I made the directory and symbolic linked to /usr/bin/annoyance-filter and the Tools>Anti-Spam wizard then found annoyance filter.

Perhaps it should look for the executable the way it does the other spam-filtering options?
/bin/sh: bogofilter: command not found
/bin/sh: spamc: command not found
/bin/sh: spamassassin: command not found
/bin/sh: spamassassin: command not found
Comment 1 Martin Koller 2009-08-29 14:57:31 UTC
Did you probably remove the link afterwards ?
The error shows that it does not find the given file ...
Comment 2 michael papet 2009-08-30 05:00:59 UTC
These are the steps to recreate the error.
1. install kmail  the Debian way: apt-get install kmail
2. set up kmail to send/receive email.  Use kmail for a while. Close kmail
3. install annoyance-filter the Debian way: apt-get install annoyance-filter
4. Start kmail
5. Select tools->antispam wizard.
Expected behavior: kmail finds annoyance-filter and the wizard goes to the next step.
Actual behavior: kmail cannot find annoyance-filter.

Explanation: It can't find it because it looks for the annoyance-filter executable at /home/myuser/.annoyance-filter/annoyance-filter.  The issue is solved with a symbolic link from /home/myuser/.annoyance-filter/annoyance-filter to /usr/bin/annoyance-filter  But, that does not seem like very standard practices.
Comment 3 michael papet 2009-08-30 05:03:37 UTC
To answer your question directly.  There was no link in the first place.  If I remove the link annoyance-filter stops working.
Comment 4 Martin Koller 2009-08-30 11:59:32 UTC
Thanks for explaining. I now found the reason why the path is given that way:
If you download the pristine sources from http://www.fourmilab.ch/annoyance-filter and configure/make/make install it, then it installs the executable into $HOME/.annoyance-filter/ even though configure --help tells me it will install into /usr/local/bin (and I run as root).

So obviously Debian changed that.

I'll fix it.
Comment 5 Martin Koller 2009-08-30 12:16:35 UTC
SVN commit 1017340 by mkoller:

BUG: 140353

try to find the annoyance-filter executable in the default installation
path but also in a system path


 M  +4 -4      kmail.antispamrc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1017340
Comment 6 Martin Koller 2009-09-06 13:40:14 UTC
SVN commit 1020465 by mkoller:

Backport r1017340 by mkoller from trunk to the 4.3 branch:

CCBUG: 140353

try to find the annoyance-filter executable in the default installation
path but also in a system path



 M  +4 -4      kmail.antispamrc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1020465