Bug 140168 - Crash after clicking default settings button (and JavaScript bug?)
Summary: Crash after clicking default settings button (and JavaScript bug?)
Status: RESOLVED DUPLICATE of bug 118361
Alias: None
Product: kcontrol
Classification: Miscellaneous
Component: kcmkonqhtml (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-16 21:01 UTC by john
Modified: 2009-10-02 03:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description john 2007-01-16 21:01:06 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages

I've tried to load http://userpage.fu-berlin.de/~klaroth/ (university site), and clicked on "Lehrveranstaltungen". A password window should have opened, but it didn't. Only "ACHTUNG PASSWORT ERFORDERLICH!" appeared on the site, though this site is explicitly granted JavaScript in the Konqueror preferences. After that I granted global JavaScript access, then it worked. I suspected some misconfiguration and clicked on the default settings button, and Konqueror crashed.


Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1231907152 (LWP 8202)]
[KCrash handler]
#6  0x0896ddbb in ?? ()
#7  0xb5776c49 in DomainListView::save () from /usr/lib/kde3/kcm_konqhtml.so
#8  0xb5776e58 in KJavaScriptOptions::save ()
   from /usr/lib/kde3/kcm_konqhtml.so
#9  0xb576e0d8 in KJSParts::save () from /usr/lib/kde3/kcm_konqhtml.so
#10 0xb6621b3d in KCModuleProxy::save (this=0x8878b30)
    at /build/buildd/kdelibs-3.5.5/./kutils/kcmoduleproxy.cpp:533
#11 0xb6621d0f in KCMultiDialog::apply (this=0x8819d78)
    at /build/buildd/kdelibs-3.5.5/./kutils/kcmultidialog.cpp:147
#12 0xb6621f3b in KCMultiDialog::slotOk (this=0x8819d78)
    at /build/buildd/kdelibs-3.5.5/./kutils/kcmultidialog.cpp:179
#13 0xb6dde209 in KDialogBase::qt_invoke (this=0x8819d78, _id=74, 
    _o=0xbfc5b74c) at ./kdialogbase.moc:359
#14 0xb66211e3 in KCMultiDialog::qt_invoke (this=0x8819d78, _id=74, 
    _o=0xbfc5b74c) at ./kcmultidialog.moc:148
#15 0xb72b8957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#16 0xb72b93fc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#17 0xb764df5f in QButton::clicked () from /usr/lib/libqt-mt.so.3
#18 0xb7356fe8 in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#19 0xb72ef729 in QWidget::event () from /usr/lib/libqt-mt.so.3
#20 0xb724fb88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#21 0xb7251d46 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#22 0xb7945db2 in KApplication::notify (this=0xbfc5c4e8, receiver=0x87ff330, 
    event=0xbfc5bbc0)
    at /build/buildd/kdelibs-3.5.5/./kdecore/kapplication.cpp:550
#23 0xb71e23fd in QApplication::sendSpontaneousEvent ()
   from /usr/lib/libqt-mt.so.3
#24 0xb71e1062 in QETWidget::translateMouseEvent ()
   from /usr/lib/libqt-mt.so.3
#25 0xb71df14c in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#26 0xb71f6320 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#27 0xb726a25e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#28 0xb726a06e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#29 0xb7251731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#30 0xb676a2b4 in kdemain () from /usr/lib/libkdeinit_konqueror.so
#31 0xb7fa5524 in kdeinitmain () from /usr/lib/kde3/konqueror.so
#32 0x0804e4df in launch (argc=1, _name=0x80b09ec "konqueror", 
    args=0x80b09f6 "\001", cwd=0x0, envc=1, envs=0x80b0a06 "", 
    reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x80b0a0b "toshiba;1168975606;732864;6693_TIME744502033")
    at /build/buildd/kdelibs-3.5.5/./kinit/kinit.cpp:673
#33 0x0804ed6a in handle_launcher_request (sock=9)
    at /build/buildd/kdelibs-3.5.5/./kinit/kinit.cpp:1240
#34 0x0804f118 in handle_requests (waitForPid=0)
    at /build/buildd/kdelibs-3.5.5/./kinit/kinit.cpp:1443
#35 0x080503ac in main (argc=5, argv=0xbfc5cc74, envp=0xbfc5cc8c)
    at /build/buildd/kdelibs-3.5.5/./kinit/kinit.cpp:1909
#36 0xb7d208cc in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#37 0x0804b971 in _start ()
Comment 1 Dario Andres 2009-10-02 03:11:23 UTC

*** This bug has been marked as a duplicate of bug 118361 ***