Bug 139623 - Impossible add users in kcmsamba
Summary: Impossible add users in kcmsamba
Status: RESOLVED DUPLICATE of bug 94828
Alias: None
Product: kcontrol
Classification: Unclassified
Component: kcmsamba (show other bugs)
Version: 2.0
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jan Schaefer
URL:
Keywords:
: 139621 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-05 04:59 UTC by
Modified: 2008-05-10 16:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2007-01-05 04:59:36 UTC
Version:           2.0 (using KDE 3.5.5, compiled sources)
Compiler:          Target: x86_64-mandriva-linux-gnu
OS:                Linux (x86_64) release 2.6.17-6mdv

I enter in kcontrol->Internet & Network->Samba, click in the tab "Users" then i add a user (here the users appear doubled, so to add a user you have to select the 2 entries of that user) and the user was added i close kcontrol. 
 
 Then i run again kcontrol and i go to "Internet & Network->Samba", click the tab "Users" and i see that there isnt any user, so the user i add in previous step disappeared, istn possible to add users since they always disappear.
Comment 1 2007-01-05 05:01:02 UTC
To tried to enter this bug by clicking in "Help->Report Bug in Samba Module" when i was in kcontrol->Internet & Network->Samba, then appeared the konqueror window with url: 
 
 http://bugs.kde.org/wizard.cgi?os=Linux%20(x86_64)%20release%202.6.17-6mdv&compiler=Target%3A%20x86_64-mandriva-linux-gnu&kdeVersion=3.5.5,%20compiled%20sources&appVersion=2.0&package=kcmkcmsambaconf&kbugreport=1 
 
 then i click in button "Continue" and then appears a message in red saying: 
 
 I don't know anything about kcmkcmsambaconf. Please submit the bug and select the package manually. 
 
 Here the problem is that in report bug window in application appears: 
 kcmkcmsambaconf 
 
 and that doesnt exist, so thats why isnt possible to enter a bug using "Help->Report bug in Samba Module" 
 
 What should appear in Allplications (from "Help->Report bug in Samba Module" window) should be kcmsamba and not kcmkcmsambaconf.

To enter the bug im entering i used the url:

http://bugs.kde.org/wizard.cgi?os=Linux%20(x86_64)%20release%202.6.17-6mdv&compiler=Target%3A%20x86_64-mandriva-linux-gnu&kdeVersion=3.5.5,%20compiled%20sources&appVersion=2.0&package=kcmsamba&kbugreport=1 
Comment 2 Bram Schoenmakers 2007-01-05 17:18:16 UTC

*** This bug has been marked as a duplicate of 139621 ***
Comment 3 2007-01-05 19:00:09 UTC
If you take a better look this bug isnt a duplicate from bug 139621
Comment 4 Bram Schoenmakers 2007-01-05 22:27:45 UTC
*** Bug 139621 has been marked as a duplicate of this bug. ***
Comment 5 Luke Plant 2007-05-15 17:19:35 UTC
I am seeing exactly the same thing with KDE 3.5.6, as packaged in Kubuntu Feisty.  If I run KControl from a console, I get this output:

Load smb config files from /dev/null
Loaded services file OK.
Server role: ROLE_STANDALONE

This was a clean installation of Kubuntu Feisty, not an upgrade.
Comment 6 Luke Plant 2007-05-15 18:54:49 UTC
I've found I can add users via smbpasswd, and it does seem to work (i.e. I can then delete the user again, but I get an error message trying to delete a non-existent user).  However, I don't know *where* the data is being stored.  In the KDE gui, it says the password file is /etc/samba/smbpasswd.  However, this file does not exist on my system, and the smb.conf file does not refer to it.  I do have this line:

passdb backend = tdbsam

Having added a user manually using smbpasswd, the list of users is *still* empty in the KDE gui -- both in the total list of users (mentioned above), and in the GUI you get if you try to add users to a specific share.

It also seems the GUI is failing to create users as well -- if I try 'sudo smbpasswd -x mytestuser' after creating the user in the KDE gui, I get the same error message I get when trying to delete a non-existent user.  

So, there seem to be 3 bugs 
 - the KDE gui cannot create Samba users 
 - it fails to create users silently rather than loudly 
 - it cannot find the list of users.  

NB - for testers -- be aware of the other major bugs with Samba in feisty: bug #95460
Comment 7 Luke Plant 2007-05-15 18:56:57 UTC
Hmm, I just realised I may be mixing up some issues in Kubuntu Feisty with the actual KDE issues.  Sorry for that, it's difficult to tell which is which.
Comment 8 Jan Schaefer 2008-05-10 16:02:18 UTC

*** This bug has been marked as a duplicate of 94828 ***