Bug 139482 - GpG signatures from me are marked bad when I receive them, either from myself or via a mailing list.
Summary: GpG signatures from me are marked bad when I receive them, either from myself...
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: 1.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-01 22:14 UTC by Robert Smits
Modified: 2007-12-13 21:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Smits 2007-01-01 22:14:49 UTC
Version:           1.2 (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

I'm using SuSE Linux 10.1, along with Kontact 1.2, Kmail 1.9.1, KDE 3.5.1 level "a" and KGpg 1.2.2 

This problem occurs on four different computers, one of which is on an entirely different Isp.

If I digitally sign an email (not encrypt it) either to myself or a mailing list, when I receive the email it is marked as being bad. Emails I send to other people apparently have nothing wrong with them. If I encrypt email to myself it works fine. If I go to a windows partition and send myself a test message using eudora and PGP 8.1, it arrives just fine on my linux partition.

My Kmail settings normally use standard Pop3 settings on port 110, with tls encrytion. SMTP is on port 2525 with tls. (Setting them to operate with no encryption makes no difference, nor does changing the SMTP port to 25. )

I have tried back leveling SuSE to version 10.0, with no difference in performance. 

As far as I can tell, there is no difference between the message sent and received, but KGpg obviously detects something. 

This may seem like an insignificant bug, but it removes my ability to check that emails I send to mailing lists have not been altered.

I'd be very happy to work with anyone to do further tests, etc.
Comment 1 Rolf Eike Beer 2007-12-13 12:47:12 UTC
When you say mailing list, you probably want to say "mailman" instead, don't you? This is a known bug in mailman that alters the content-type header (removes linebreaks) so the signatures will not match anymore.

Please confirm.
Comment 2 Robert Smits 2007-12-13 17:01:35 UTC
Well, generally mailman is the listserve software of choice, but I'm on several dozen lists, and cannot at this time confirm which I was using at the time but I think you are correct. I did find that setting the identity's crypto message format to inline  OpenGPG (deprecated) would let the sigs go through.  It does not explain why sending mail to myself would cause a similar condition.

Bob

Comment 3 Rolf Eike Beer 2007-12-13 18:55:21 UTC
If the mail server does some reformatting of the message (e.g. qp recoding or whatever) it might cause similar problems.
Comment 4 Robert Smits 2007-12-13 20:56:51 UTC
Thanks Rolf. I reset my encryption to PGP/Mime and sent a message to myself and it came through just fine. Of course, it's almost a year since I posted the bug and I'm no longer using OpenSuse 10.1, I'm on 10.3 by now, so that may have an impact too. 

I'll test later this morning from my office with a mailman listserve and see if the problem is still there.
Comment 5 Robert Smits 2007-12-13 21:03:48 UTC
I have now tested this with at least one of the listserves that does use mailman and find it is now handling OpenPGP/Mime signatures just fine, Rolf. The bug appears to have been overcome, probably by patching Mailman. I guess the bug can now be marked as resolved.
Comment 6 Robert Smits 2007-12-13 21:07:05 UTC
I'm no longer getting the indication that there was anything wrong with my PGP signature, even when I've changed back to OpenPGP/Mime instead of inline signatures. 

Since I can no longer generate the problem, and no longer have the original versions of the software where this was happening, I'm going to mark it as resolved.

Bob Smits