Bug 138725 - kmail doesnt supports utf-8 when dragging address to TO: field
Summary: kmail doesnt supports utf-8 when dragging address to TO: field
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: composer (show other bugs)
Version: 1.9.5
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 81078 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-12 22:09 UTC by
Modified: 2009-08-30 20:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description 2006-12-12 22:09:56 UTC
Version:           1.9.5 (using KDE 3.5.5, compiled sources)
Compiler:          Target: x86_64-mandriva-linux-gnu
OS:                Linux (x86_64) release 2.6.17-5mdv

Lets suppose i want to write a new message, so i open the compositor window, and from an existent mail message window i drag an address to the TO: field in compositor window.

Now what happens is if the dragged address haves some charathers with accents like for example "Götz" <goetz@gmail.com>, after dragged to compositor window in the address field appears like this:

"=?utf-8?q?G=C3=B6tz?=" <goetz@gmail.com>

So for what i see kmail isnt able to support utf-8 in address fields when dragging to there mail addresses.
Comment 1 2007-04-26 21:41:47 UTC
Can anyone please take some time to fill this bug, its very annoying not to be able to drag&drop mail addresses.
Comment 2 Frank Niethardt 2007-05-15 23:41:56 UTC
I can confirm this on Debian testing, kmail 1.9.5 (KDE 3.5.5.dfsg.1-6). 

Bug appears when dragging an address from header display to a message composer dialog. I tried fancy headers and brief headers with same result. If I write the email address myself in the text field of the composer window, mark it and drag it to the address field it works like expected.

BTW: The address was encoded using iso-8859-1 as I saw in source, but it is utf-8 in the address field I was dragging to.
Comment 3 Martin Koller 2009-08-05 03:08:12 UTC
SVN commit 1007045 by mkoller:

BUG: 138725

decode mailto: URL when dropping


 M  +2 -1      kmlineeditspell.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1007045
Comment 4 Thomas McGuire 2009-08-05 21:56:41 UTC
SVN commit 1007476 by tmcguire:

Backport r1007045 by mkoller from trunk to the 4.3 branch:

CCBUG: 138725

decode mailto: URL when dropping



 M  +2 -1      kmlineeditspell.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1007476
Comment 5 Martin Koller 2009-08-30 20:00:40 UTC
*** Bug 81078 has been marked as a duplicate of this bug. ***