Bug 138451 - No keyboard hotkey for next page in presentation mode
Summary: No keyboard hotkey for next page in presentation mode
Status: RESOLVED FIXED
Alias: None
Product: kpdf
Classification: Applications
Component: general (show other bugs)
Version: 0.5.5
Platform: Debian testing Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 149336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-06 15:32 UTC by Romain Beauxis
Modified: 2007-09-16 01:23 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Romain Beauxis 2006-12-06 15:32:37 UTC
Version:           0.5.5 (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Hi !


Ìt is not possible to set up a custom keyboard hotkey for changing current page on presentation mode ..

It is a bit sad since page next/previous page is available for custom hotkey in normal mode, but these do not apply in presentation mode.

I am aware of bug #102565 but it is not exactly the same issue here: I would like to define my own keys for page next/ previous page on presentation mode.


I think a simple solution would be to let page next/previous page hotkeys defined in normal mode apply in presentation mode.


Thanks you very much for this great app !


Romain
Comment 1 Pino Toscano 2007-04-15 16:34:21 UTC
> I think a simple solution would be to let page next/previous page hotkeys
> defined in normal mode apply in presentation mode. 

That's not "a simple solution", but "the right solution" ;-)
Comment 2 Maciej Pilichowski 2007-08-29 16:01:13 UTC
It is already done (in 50%, see:  https://bugs.kde.org/show_bug.cgi?id=149336 ).
Comment 3 Pino Toscano 2007-08-29 16:31:48 UTC
*** Bug 149336 has been marked as a duplicate of this bug. ***
Comment 4 Maciej Pilichowski 2007-08-29 17:32:21 UTC
Since it is awkward duplicate I paste the whole report.
Summary: alternate keyboard shortcuts are not handled in presentation mode.
Description: Let's say F1 and F2 (alternate) are next page. In normal mode both work, in presentation mode only F1. 
 
Comment 5 Maciej Pilichowski 2007-08-29 17:35:22 UTC
PS. Now it is a bug report, not a wish, so if somebody could please change the status. Thanks in advance.
Comment 6 Pino Toscano 2007-08-29 17:35:52 UTC
Sigh...
your problem is a plain consequence of this report: until there's no way to make the presentation mode use the shortcuts defined for the "main" application, alternate shortcuts won't work either.
When they work, primary and alternate shortcuts will work flawlessy.
Comment 7 Maciej Pilichowski 2007-08-29 17:53:37 UTC
?

The default shortcuts (page down/up) work in both modes, the primary shortcuts also work in both modes. So both wishes are fullfilled: those shortcuts work and they are configurable (in 50%).

So I would rather say it is FIXED or WORKSFORME. And I pointed it out before posting my report.

The only buggy thing is that _alternate_ shortcut does not work in presentation mode. Thus --> bug.
Comment 8 Pino Toscano 2007-08-29 18:08:47 UTC
It seems that you did not understand the problem :)

Try assigning two custom shortcuts to the "Prev/Next page" actions, and see that they won't work in presentation mode. This because the presentation mode has ome shortcuts HARDCODED, with NO way to be configured.
So, the wishes you think are fullfilled, really they are not, and this bug is confirmed.
Comment 9 Maciej Pilichowski 2007-08-29 18:16:52 UTC
Thanks Pino, after time I forgot which shortcut is mine and which is not, so I though the primary one works perfectly well. Thank you for the explanation.
Comment 10 Pino Toscano 2007-09-16 01:23:40 UTC
SVN commit 712996 by pino:

Properly pass the standard accelerators to the presentation mode, and make the presentation mode able to handle those.

BUG: 138451


 M  +6 -0      part.cpp  
 M  +11 -0     ui/presentationwidget.cpp  
 M  +5 -0      ui/presentationwidget.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=712996