Bug 138010 - Cannot print a PDF that prints fine in Acrobat and Foxit
Summary: Cannot print a PDF that prints fine in Acrobat and Foxit
Status: RESOLVED NOT A BUG
Alias: None
Product: kpdf
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL:
Keywords:
: 142826 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-28 11:37 UTC by Iain Cheyne
Modified: 2007-03-11 16:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error message when print previewing (35.18 KB, image/png)
2006-11-28 11:38 UTC, Iain Cheyne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iain Cheyne 2006-11-28 11:37:42 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
Compiler:          Kubuntu Edgy 6.10 
OS:                Linux

If I try to print the attached PDF in Acrobat and Foxit Reader it works fine, but it does not print through CUPS with kpdf. I get no error message from the KPDF GUI but it shows up as an error in the CUPS queue.

If I print preview in KPDF I get an error. I have attached a screenshot of the error:

Ghostscript Messages
Exited with error code 1.
X Error of failed request: BadMatch (invalid paramerter attributes)
Major opcode of failed request: 73
 (X_GetImage)
   Serial number of failed request: 36
   Current serial number in output stream: 36
Comment 1 Iain Cheyne 2006-11-28 11:38:13 UTC
Created attachment 18716 [details]
Error message when print previewing
Comment 2 Iain Cheyne 2006-11-28 11:41:12 UTC
I coult not attach the offending pdf, as it is over 1MB, so I have put it on my website.

http://cheyne.net/tmp/plans.pdf
Comment 3 Albert Astals Cid 2006-11-28 19:50:06 UTC
I can reproduce when using the kubuntu binary but it works when using the program self compiled from kpdf sources. Kubuntu is patching kpdf code greatly so it's probably their fault. Report to them.
Comment 4 Iain Cheyne 2006-11-28 20:13:56 UTC
OK thanks.
Comment 5 Albert Astals Cid 2007-03-11 16:02:42 UTC
*** Bug 142826 has been marked as a duplicate of this bug. ***