Bug 137982 - Fit to window zoom action doesn't scale images that are smaller to the window size [KDE4.1]
Summary: Fit to window zoom action doesn't scale images that are smaller to the window...
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 159608 161035 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-27 21:08 UTC by Josep Febrer
Modified: 2012-10-19 13:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Josep Febrer 2006-11-27 21:08:40 UTC
Version:           1.4.1 (using KDE KDE 3.5.5)
Installed from:    Compiled From Sources
Compiler:          gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20) 
OS:                Linux

In Gwenview 1.4.1 when I select the zoom option "Fit to window" it doesn't work on an image that is smaller to the image window size, however it works if the image is bigger than the image window size.

Also, the zoom options "Fit to width" and "Fit to height" are working correctly with images that are smaller to the image window size and they are scaled acording to the option selected.

Thanks.
Comment 1 Josep Febrer 2007-12-12 16:34:36 UTC
I checked with a current build of the KDE4 version, and this issue is still present, when an image it is smaller than the Gwenview's image view area and the "Zoom To Fit" toolbar button is pressed the image isn't scaled to fit the image view area and it's showed exaclty like if "Actual Size" button were pressed.
Comment 2 Aurelien Gateau 2007-12-13 00:02:49 UTC
In fact, there is an option to do what you want in Gwenview 1.4. It's in the configuration dialog, go to "Image View", then check "Enlarge small images when auto zoom is activated".

Unfortunately, I haven't ported that option to Gwenview 2.0 and since we are freezing for KDE4.0, it won't be there. You will probably have to wait for KDE4.1.
Comment 3 jos poortvliet 2007-12-16 11:38:33 UTC
Would love to have it in 4.1 for sure, and imho it should be on by default (for the sake of simplicity, I wouldn't even make it an option).
Comment 4 Aurelien Gateau 2007-12-16 23:02:51 UTC
Marking as KDE4.1
Comment 5 Josep Febrer 2007-12-17 11:57:15 UTC
Thanks, Aurelien I don't know how I missed this option in 1.4.
Comment 6 Aurelien Gateau 2008-03-29 01:40:40 UTC
*** Bug 159608 has been marked as a duplicate of this bug. ***
Comment 7 Aurelien Gateau 2008-04-27 12:16:51 UTC
*** Bug 161035 has been marked as a duplicate of this bug. ***
Comment 8 Aurelien Gateau 2008-04-27 14:22:31 UTC
SVN commit 801676 by gateau:

New option to enlarge smaller images in zoom to fit mode.
BUG: 137982


 M  +42 -2     app/configdialog.ui  
 M  +4 -0      lib/gwenviewconfig.kcfg  
 M  +15 -1     lib/imageview.cpp  
 M  +2 -0      lib/imageview.h  
 M  +1 -0      part/gvpart.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=801676