Bug 137535 - set remember line on message event, not on switching tab or minimising
Summary: set remember line on message event, not on switching tab or minimising
Status: RESOLVED FIXED
Alias: None
Product: konversation
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-18 14:57 UTC by Frederik Schwarzer
Modified: 2007-11-07 13:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Schwarzer 2006-11-18 14:57:22 UTC
Version:           1.0.1 (using KDE KDE 3.5.5)
Installed from:    Debian testing/unstable Packages

When having two tabs (a and b) open being in tab a.
I see, there's something happening in tab b, switching to in, not interested in the current topic, switching back.
There is the remember line even if nothing happened in the meantime.
I think it would be nice to not set the remember line until something happens in the channel.

Another thing is, that the line seems to be affected by join/part/... messages even if they are hidden.

So my suggestion is to set the remember line only on those events that actually show sth. in the chatwindow.
Comment 1 Eike Hein 2006-11-18 15:07:14 UTC
Good ideas.
Comment 2 Juha Tuomala 2007-01-06 12:39:40 UTC
Also, all chat software other than irc are horrible in that sense that those waste space from window. I like 'scientific alike' sw, where all space taken is well utilized and thus I don't like that this remember line has always lots of empty space after it. 

It could just be colored line between messages, tightly there without any additional space. (in widget wise, don't know how difficult it's to implement)
Comment 3 Eike Hein 2007-01-06 14:18:16 UTC
Regarding the spacing issue: That's how QText* render a <hr>, I'm afraid - personally, I'd prefer a smaller margin, too. A possible switch of text rendering technology in the future may hold an answer here.
Comment 4 Dave Belfer-Shevett 2007-10-04 16:46:40 UTC
I agree with the original bug description.  A reminder line should not appear in a window that has had no activity while it was hidden.
Comment 5 Eike Hein 2007-11-06 20:27:53 UTC
SVN commit 733584 by hein:

Rewrite the remember/marker line system completely to be more useful:
* Distinguish between manually inserted marker lines and marker lines
  inserted automatically when chat windows are hidden, fixing the utter
  chaos in conjunction with the "show in all chat windows" preference.
* Make the automatic marker line "sliding", i.e. remove the last auto-
  matic line when inserting a new one.
BUG:136917
* Only insert the automatic marker line when there's actually new text
  being appended to a chat window.
BUG:137535
* Add an action to clear all marker lines in a chat window.
* Improve marker lines-related terminology and preferences.
* Make the (marker line-related and other) identity default settings
  consistent between the initial identity and additional newly created
  identities.


 M  +1 -7      chatwindow.cpp  
 M  +1 -2      chatwindow.h  
 M  +71 -50    chatwindowbehaviour_preferences.ui  
 M  +1 -1      commit.h  
 M  +6 -6      config/konversation.kcfg  
 M  +2 -8      config/preferences.cpp  
 M  +19 -2     identity.cpp  
 M  +1 -0      identity.h  
 M  +1 -1      identitydialog.cpp  
 M  +110 -22   ircview.cpp  
 M  +20 -4     ircview.h  
 M  +2 -2      konvdcop.cpp  
 M  +2 -2      konvdcop.h  
 M  +5 -5      konversationapplication.cpp  
 M  +21 -14    konversationmainwindow.cpp  
 M  +6 -3      konversationmainwindow.h  
 M  +4 -2      konversationui.rc  
 M  +3 -3      konviface.h  
 M  +71 -20    viewcontainer.cpp  
 M  +6 -2      viewcontainer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=733584
Comment 6 Juha Tuomala 2007-11-07 12:51:06 UTC
Line spacing didn't get attention in this change? Hein, what you think, is that worth of improvement/used time? Should there be another wish for that?

Although removing old lines helps a lot already.
Comment 7 Juha Tuomala 2007-11-07 12:51:44 UTC
And big thanks of course! Konversation is *the* IRC client. :D
Comment 8 Eike Hein 2007-11-07 12:54:37 UTC
> Line spacing didn't get attention in this change?

Actually, it did later that evening:

SVN commit 733613 by hein:
* Fix a small regression with tab notifications from r733584.
* If we can't get rid of the ugly margin around marker lines,
  let's at least make it consistent above and below them.

SVN commit 733618 by hein:
Looking around in QRichText's source code, turns out there is 
a way to make the margin around marker lines less freaking huge.


It's still not 100% like I would like them to be displayed (that will need the aforementioned technology change), but it's certainly a lot more bearable now, and with the behavioral changes marker lines are now actually useful.

Comment 9 Juha Tuomala 2007-11-07 13:12:26 UTC
I can't test it atm (running f8 devel/soon2be release here) but will asap. 

Thanks very much!