Bug 137395 - Warning popups appear with MSN even when Configure Notifications set to "passive only"
Summary: Warning popups appear with MSN even when Configure Notifications set to "pass...
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: general (show other bugs)
Version: 0.12.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
: 137411 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-15 16:40 UTC by Andrew
Modified: 2006-12-12 16:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Example pop-up that appears (11.04 KB, image/png)
2006-11-15 16:58 UTC, Andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2006-11-15 16:40:16 UTC
Version:           0.12.3 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
Compiler:           Target: i486-linux-gnu
OS:                Linux

Periodically, the MSN plugin throws up errors "user blah cannot be contacted because they are not logged in" or somesuch, or "Server not available, please try later".  These errors themselves are fine, however, I have configure-notifications set to only use passive-popups, as I don't want them to interrupt my work.  These popups are full modal dialog boxes that freeze everything until I close them.

This looks like some of the messages are not being routed through the notification system, but are going directly to open the dialog.

This only seems to happen on MSN.  The other plugins seem to work fine.  It only happens when "weird" things happen on MSN, which makes it difficult to reproduce.

The expected behaviour (for me) would be to adhere to the "Configure Notifications" settings.
Comment 1 Andrew 2006-11-15 16:58:25 UTC
Created attachment 18564 [details]
Example pop-up that appears

This is an example of one of the pop-ups that appear
Comment 2 Bram Schoenmakers 2006-11-15 19:16:19 UTC
*** Bug 137411 has been marked as a duplicate of this bug. ***
Comment 3 Michaël Larouche 2006-12-12 16:36:33 UTC
Fixed in SVN r612769.