Bug 136996 - smb:// file browsing with konqueror does not work with Greek Character support (ISO-8859-7)
Summary: smb:// file browsing with konqueror does not work with Greek Character suppor...
Status: RESOLVED DUPLICATE of bug 158639
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: smb (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-07 11:04 UTC by Karakontakis Apostolis
Modified: 2008-06-30 14:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karakontakis Apostolis 2006-11-07 11:04:04 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Mandriva RPMs

When i try to use the shared HDD recources of a windows XP client via konqueror with smb:// command i can not see Greek File names but only squares.The locale settings of the unix box is set to ISO-8859-7.When i try to mount the same shared resources  with the following command from command line 

mount -t smbfs //party2000/c /mnt/smbres 

everything works OK (i have the following parameters set in smb.conf dos charset = CP737 , unix charset = ISO8859-7) I can see and i can write greek filenames from the linux box and the windows machine sees them without a problem.Also when i go to Konqueror File manager Menu Tools -> Select Remote Charset .. and i choose ISO-8859-7 nothing happens (I also tried UTF-8 and nothing happens also).
Comment 1 Jerzy Goca 2007-02-03 16:06:32 UTC
Exactly the same with locale ISO-8859-2.
Similar to bug no. 124518 (see my comment there)

In my samba.conf I have:

[global]
unix charset = ISO-8859-2
display charset = ISO-8859-2
dos charset = cp852
Comment 2 Pino Toscano 2008-06-30 14:25:48 UTC

*** This bug has been marked as a duplicate of 158639 ***