Bug 136596 - kontact / korganizer moves start dates of recurring events
Summary: kontact / korganizer moves start dates of recurring events
Status: RESOLVED DUPLICATE of bug 136221
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Reinhold Kainhofer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-31 21:58 UTC by Tobias G. Pfeiffer
Modified: 2006-11-02 19:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias G. Pfeiffer 2006-10-31 21:58:07 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

In Kontact, using the KOrganizer kpart, I created events representing my university time table. This includes lectures that happen twice a week, say on Mondays and Wednesdays. Now for some (!) of these events, the events that happened last week are simply deleted in the table. I looked at what happened to these events and saw that the start date of this event seems to move with the current date, while the end date doesn't.

Example: My Linear Algebra lecture started on 16.10.06, 10:00 and ended on 16.10.06, 12:00 and happens every Monday and Wednesday, until February of 2007. This looked fine at the beginning. When I look at that event now it says start date is on 01.11.06, 10:00 and end date is still 16.10.06, 12:00. This is why the event isn't displayed before the 01.11., but from then on, everything seems to be ok. Now, the really odd things.

* If I adjust the start and end date to reflect reality, close Kontact and reopen it, everything is as before (i.e. buggy).
* If I close Kontact, open KOrganizer, make the corrections there, close and reopen Korganizer, everything is correct, as it is supposed to be. The std.ics file also contains the correct dates.
* If I close KOrganizer and reopen Kontact, the corrections from KOrganizer have gone and the std.ics file contains the old dates.
* This happens only for several events, not for all, but always for the same three events.

I wonder if there is some process watching the std.ics file that undoes the changes when Kontact starts up, but not when KOrganizer does.
Comment 1 Tobias G. Pfeiffer 2006-10-31 22:16:21 UTC
My supposition that it has to do with some file watching process seems to be wrong. I shut down X, switched to a virtual console and edited the std.ics file to be as I wanted it to be (i.e. I adjusted the times). Then I copied this file to another location, started up KDE and did the following:
$ diff std.ics .kde/share/apps/korganizer/std.ics
$ korganizer
$ # everything looks fine in korganizer
$ diff std.ics .kde/share/apps/korganizer/std.ics
$ # quit korganizer
$ diff std.ics .kde/share/apps/korganizer/std.ics
$ kontact
$ # everything is buggy in kontact / korganizer part
$ diff std.ics .kde/share/apps/korganizer/std.ics
$ # quit kontact
$ diff std.ics .kde/share/apps/korganizer/std.ics
2c2
< PRODID:-//K Desktop Environment//NONSGML KOrganizer 3.5.5//EN
---
> PRODID:-//K Desktop Environment//NONSGML libkcal 3.5//EN
5c5
< DTSTAMP:20061031T210350Z
---
> DTSTAMP:20061031T210614Z
27c27
< DTSTAMP:20061031T210350Z
[... lots of stuff moved to different places within the file ...]

I mean, the diff shows that the file was written by a different library using Kontact than using KOrganizer and this library a) puts all sort of events in different places (I'm sorry I can't just paste the diff due to confidential information) and b) messes up this date. So probably this is an error ob libkcal?

tgp.
Comment 2 Reinhold Kainhofer 2006-10-31 22:26:16 UTC
Am Dienstag, 31. Oktober 2006 22:16 schrieb Tobias G.Pfeiffer:
> ------- Additional Comments From tgpfeiffer web de  2006-10-31 22:16
> ------- My supposition that it has to do with some file watching process
> seems to be wrong. I shut down X, switched to a virtual console and edited
> the std.ics file to be as I wanted it to be (i.e. I adjusted the times).
> Then I copied this file to another location, started up KDE and did the

[...]
> $ diff std.ics .kde/share/apps/korganizer/std.ics
> 2c2
> < PRODID:-//K Desktop Environment//NONSGML KOrganizer 3.5.5//EN
> ---
> > PRODID:-//K Desktop Environment//NONSGML libkcal 3.5//EN


This is not an indication that a different library wrote the file. KOrganizer 
explicitly sets the application name in libkcal to "KOrganizer 3.5.5.", while 
the kontact part does not set the application name, so the generic "libkcal 
3.5" is used. However, the same library is used for everything (actually, the 
same code is used for practically all of korganizer and the kontact part).

I have no idea, why the problems appear that you are seeing..

Cheers,
Reinhold
Comment 3 Tobias G. Pfeiffer 2006-10-31 22:52:32 UTC
Well, then the place where the Kontact and KOrganizer handling of the libkcal differ, there must be a problem. I don't have the time and the skills to look at the source and say: "Ah, it calls myCal->scrambleICSFile() in Kontact where it doesn't in KOrganizer", but... well, I believe that the problems with my recurring events will be fixed when libkcal won't shuffle the std.ics file any more :-)

tgp.
Comment 4 Bram Schoenmakers 2006-10-31 23:42:22 UTC
I think this is the same bug as bug 136221. The summary plugin somehow screws something up regarding recurrences.
Comment 5 Tobias G. Pfeiffer 2006-11-01 07:09:35 UTC
This is probably correct; when removing the events/calendar view from the summary, the events are stores/reloaded correctly.

tgp.
Comment 6 Bram Schoenmakers 2006-11-01 20:47:45 UTC
OK, I'll mark it as a dupe then.

*** This bug has been marked as a duplicate of 136221 ***