Bug 135568 - "Focus follow mouse" make windows blinking and cpu 100%
Summary: "Focus follow mouse" make windows blinking and cpu 100%
Status: RESOLVED DUPLICATE of bug 135250
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 12:07 UTC by patator
Modified: 2006-10-13 16:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description patator 2006-10-13 12:07:51 UTC
Version:           3.5.5 (using KDE KDE 3.5.5)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1.1 
OS:                Linux

-> Open 2 windows. One is covering a little area of the other.
-> if mouse cursor stay over "on top" window, there is no problem.
-> move the cursor over the window below. Normally, this must give
   this window the focus : at this moment, the 2 windows are blinking,
   cpu is 100% and this blocks everything.
-> I think of a focus bug in kwin.
   Kwin wants to give the 2 windows the focus at the same time, so it's blinking.
-> If I choose "Click to have focus", no problem.
-> This is 100% reproducible.

Sorry for my English.

NB: Compiled every kde versions, never had problems.
    3.5.4 version compiled with exactly the same system and no problem.
Comment 1 Lubos Lunak 2006-10-13 16:51:14 UTC

*** This bug has been marked as a duplicate of 135250 ***