Bug 135562 - 'focus events' are generated at ~10 events/sec each time a new window is created. Problem seem also triggered by other situations
Summary: 'focus events' are generated at ~10 events/sec each time a new window is crea...
Status: RESOLVED DUPLICATE of bug 135250
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 10:02 UTC by dc
Modified: 2006-10-13 16:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dc 2006-10-13 10:02:28 UTC
Version:           3.5.5 (using KDE KDE 3.5.5)
Installed from:    Ubuntu Packages
OS:                Linux

Each time a new window is created (or some other undetermined situations), kwin enters in focus-in/focus-out race (> 10 events/sec.), either on one single window or with some others in the same workspace. It makes KDE unusable since each mouse clic may take several seconds to be handled (if ever...). Draging the window, holding a mouse button down for 5-10 seconds or changing workspace (sometimes) stops this behavior until another event triggers the problem again. The problem occurs on two different systems (one laptop and one desktop), which allows to rule-out a graphics card problem. The problem appeared when I installed KDE 3.5.5 on these two systems.
Comment 1 Jörg Afflerbach 2006-10-13 10:34:20 UTC
Happens here, too, since I updated to KDE 3.5.5 (SUSE 10.1 RPMs). Seems to be related with the "Focus follows Mouse" policy. Changing the policy to "Foucs on Click" has helped. Using KDE 3.5.5 with a "Focus follows Mouse" policy is almost impossible.
Comment 2 Lubos Lunak 2006-10-13 16:51:42 UTC

*** This bug has been marked as a duplicate of 135250 ***