Bug 135558 - Apple ipod not ejected after safely remove
Summary: Apple ipod not ejected after safely remove
Status: RESOLVED DUPLICATE of bug 143353
Alias: None
Product: kio
Classification: Frameworks and Libraries
Component: media (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-13 08:36 UTC by shishir verma
Modified: 2007-05-08 15:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shishir verma 2006-10-13 08:36:04 UTC
Version:            (using KDE KDE 3.5.5)
Installed from:    SuSE RPMs
OS:                Linux

I am running
 OS:  Linux 2.6.16.21-0.25-default i686
  Current user:  shiverma@nirvana
  System:  SUSE LINUX 10.1 (i586)
  KDE:  3.5.5 "release 19.1" 

When I plug my Apple iPod Video in, the kded asks me what to do with it. All is fine till then.
Now, after doing whatever i want to do with the ipod, I right click on the ipod icon and click on "Safely Remove",
I assume that this should cause the iPod to be ejected.

But what really happens is that the ipod icon gets removed from the desktop, but the ipod still keeps flashing "Do not disconnect".

Earlier releases(3.5.4, though showed slightly erratic behaviour) used to unmount and eject the iPod, sometimes at one shot, while at other times(just to test), after forcefully pulling the ipod out and plugging it back in, and then issuing safely remove.

Now in 3.5.5, this action does not eject the ipod at all, and even when the ipod icon on the desktop vanishes, the sysinfo shows the ipod as available and i am able to mount it back and do whatever i want to.

I am not sure if this is the expected behaviour, even if it is, there should be some notification asking the user not to pull the ipod out just yet, and asking him to eject /media/ipod for example, or alternatively, have eject also as an option.
Comment 1 bento loewenstein 2006-11-16 23:38:38 UTC
i have this problem with konqueror. it can't eject the ipod (4th gen, 30 Gig).

this happens with any kernel, but kdeeject runing as root does the job, so i configured amarok to run "sudo kdeeject -q %d" as post-disconection command. my user is configured to run sudo without password, BTW.
Comment 2 shishir verma 2006-11-20 16:13:39 UTC
seems to be fixed in release 45.1
Comment 3 Freddy Rietdijk 2006-12-19 19:24:24 UTC
I also have the problem with mounting the Sony memorystick pro duo inside my telephone using an usb cable. Putting the files on the stick goes really fast, but then safely removing takes very long, at least 5 minutes.

Also some programs stopped working after a minute or so. Almost always Amarok and Kopete stop. Starting new programs doesn't work always either.

But almost the biggest problem, besides the time, is that the logo disappears which seems to indicate it is safe to remove. The phone however still sais it is connected, and mount also shows the stick is still mounted. After that long time, mount doesn't show it anymore and it is safe to remove.

I do not have the problem using my Corsair USB stick.
Comment 4 Stephan Kulow 2007-05-08 15:02:31 UTC

*** This bug has been marked as a duplicate of 143353 ***