Bug 135400 - focus follows mouse window flutter
Summary: focus follows mouse window flutter
Status: RESOLVED DUPLICATE of bug 135250
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-10 16:52 UTC by Harmon S. Nine
Modified: 2006-10-10 17:57 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harmon S. Nine 2006-10-10 16:52:25 UTC
Version:           unknown (using KDE 3.5.5, Debian Package 4:3.5.5a-1 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.18-1-686

The problem only appeared after my last update from Debian unstable, and appears only to present itself when the window manager mouse-focus-setting is set to "focus follows mouse".
Very often, with "focus follows mouse", the window that is currently under the mouse will "flutter" uncontrollably, i.e. it appears to gain and lose focus again and again in rapid succession.  During the flutter, the responsiveness of the desktop becomes sluggish.
Rapidly clicking on the title bar seems to halt this behavior, though it reappears when the mouse is moved off and then back on the window.
I changed the window manager mouse-focus-setting to "click to focus" in the mean time, and the problem appears not to occur.
Comment 1 Lubos Lunak 2006-10-10 17:57:02 UTC

*** This bug has been marked as a duplicate of 135250 ***