Bug 134861 - Cyrillic letters "о" (small oh) and "м" (small em) are displayed as < and >
Summary: Cyrillic letters "о" (small oh) and "м" (small em) are displayed as < and >
Status: RESOLVED DUPLICATE of bug 116512
Alias: None
Product: konqueror
Classification: Applications
Component: khtml ecma (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-29 17:11 UTC by Teodosiy Kirilov
Modified: 2006-10-29 19:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Teodosiy Kirilov 2006-09-29 17:11:28 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Fedora RPMs
Compiler:          gcc 4.1 
OS:                Linux

When viewing Cyrillic text, loaded by an Ajax-script (XMLHttpRequest), the letters "о"(U+430E)/o/ and "м" (U+430C) /m/ are being wrongly displayed as ">" and "<". 

Problem noticed while using gmail, but it also persists on other sites using dynamic content in Cyrillic letters.

I've been mostly using Fedora (FC3, FC4, FC5, now FC6 Test3) and since kde 3.4 viewing gmail with Konqueror, but always with the problem described above. With debian it's also that way. With other browsers (Opera 8/9, Firefox(1.0.5-..-2rc1)) everything is normal.

The bug is only with the small letters. М and О are viewed normally
Comment 1 Maksim Orlovich 2006-09-29 17:21:07 UTC
Probably more encoding mess, I guess...
Comment 2 Maksim Orlovich 2006-10-29 19:45:38 UTC

*** This bug has been marked as a duplicate of 116512 ***