Bug 134389 - WISH: Sort images by date - even when spanning albums
Summary: WISH: Sort images by date - even when spanning albums
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-ItemsSort (show other bugs)
Version: 0.7.1
Platform: Gentoo Packages Linux
: NOR wishlist with 244 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-20 13:34 UTC by Chris Bayley
Modified: 2022-02-20 08:46 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Bayley 2006-09-20 13:34:20 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Gentoo Packages

I wish to run a slide show based on a search that pulls in photos from
several albums. BUT I would like to show all the photos in date order
regardless of which album they originate from... For example if I have an event photographed by 3 different photographers and each set of photos is imported into a different album, then I want to make a slide show which shows photos from all 3 albums cronologically not author by author. I don't think is possible at present. I am happy to make these changes myself and submit a patch if desired ??
Comment 1 Sapaka GADEW 2006-11-21 20:35:27 UTC
Hello everybody,

I don't know if that's what is meant here and I hope my wish is compatible with this one.

Let's go :
I would like to be able to see all my pictures in the main board, no matter the album or directory they're coming from. Basically, when launching Digikam, I would like to be able to see all the pictures the software manages. (I also want them ranked chronologically)
For now, I'm obliged to give ALL my pictures a tag called "be there if no tag is selected" and always have it activated hen I want to navigate in all my pictures.

I don't know if I'm clear enough.
Sorry for my bad english.

Thanks a lot
Comment 2 Sapaka GADEW 2006-12-01 10:08:57 UTC
Hello everybody,

I realized I didn't understand well this wish report. So my first Additionnal comment is irrelevant.

I opened a new wish to express what I meant :
Bug 138200 : http://bugs.kde.org/show_bug.cgi?id=138200

Sorry.
Have a good day

Sapaka
Comment 3 Arnd Baecker 2007-01-05 09:15:21 UTC
Sorting images by date, even across albums would 
also apply to the results obtained from filtering by tag
(which I would find very helpful!).

Could the way of presentation be another option in the menu:
- View/Sort Albums/By Folder 
                   By Date 
                   By Collection
                   Merged                <=== new?

Chris, personally I would very much welcome a patch - the final word is
of course to Gilles ;-)
Comment 4 caulier.gilles 2007-01-05 09:40:40 UTC
>the final word is of course to Gilles

... and/or Marcel... we are a team (:=)))... depending of who will parse/apply the patch on svn.

Gilles
Comment 5 Arnd Baecker 2007-01-05 09:54:26 UTC
> >the final word is of course to Gilles
>
> ... and/or Marcel... we are a team (:=)))... depending of who will parse/apply the patch on svn.


Sorry, Marcel, no insult intended!!
I hope Chris is still interested - the more coders the better ;-)
Comment 6 Thomas McGuire 2007-02-14 20:28:34 UTC
Isn't this the same as bug #116606? Both are about sorting the thumbnail view only by date/name/whatever, without the album seperator.
Comment 7 Frank Siegert 2007-02-14 22:51:11 UTC
Yes, it really seems like the same problem, and even the same proposed solution (another item in the View menu about the display style). It's hard to decide, which bug is more valid, but since this one has a broader scope (not only tags, but also searches etc.), I mark the other one as duplicate.
Comment 8 Frank Siegert 2007-02-14 22:52:05 UTC
*** Bug 116606 has been marked as a duplicate of this bug. ***
Comment 9 Christian Schaarschmidt 2007-02-14 23:00:53 UTC
when you implement this wish, please have a look at Bug 140743 as well.
Comment 10 Arnd Baecker 2007-06-12 20:28:45 UTC
Chris, 

have you made any progress in writing a patch
(This is one of the higher voted wishes ;-)?

Arnd
Comment 11 Mikolaj Machowski 2007-08-20 11:41:24 UTC
*** Bug 149025 has been marked as a duplicate of this bug. ***
Comment 12 Mikolaj Machowski 2007-11-22 20:40:57 UTC
*** Bug 152715 has been marked as a duplicate of this bug. ***
Comment 13 Chris Bayley 2007-11-22 21:03:26 UTC
This bug is attracting a lot of duplicates - seems I better get to work on that patch!
Comment 14 Arnd Baecker 2007-11-23 10:06:58 UTC
It is one of the wishes with the largest number of votes (place 6!),
so there is definitively a lot of interest in this feature!

In https://bugs.kde.org/show_bug.cgi?id=116606#c5 Marcel discusses briefly,
what changes would be necessary. 
Maybe https://bugs.kde.org/show_bug.cgi?id=116606#c7 is a good idea,
by using a (to be introduced) "virtual" group ("Merged") in 
AlbumIconView::slotImageListerNewItems ?
((for a quick test one might just fake this and put it all into
one album with a known id ...;-)). This would leave IconView::sort()
untouched (not sure what side-effects/problems there could be).

While it most likely would not make it
into 0.9.3 final (string freeze), it would be great to 
see this as one of the first great
new features for 0.9.4, so the coding may start now!

Chris, if you need any help, don't hesitate to ask here or on the digikam-devel
mailing list.
In particular using the IRC (#digikam on irc.freenode.net) is very efficient
for quick questions/discussions.
Comment 15 Sebastian 2008-12-09 15:58:00 UTC
Hej,

i've tried 
Comment 16 Sebastian 2008-12-09 16:05:36 UTC
first, sorry for double-posting. I've a nervous return key :-(

Hej,

i've tried to work-around this bug creating symlinks (and for experimental reasons hardlinks as well) of all my image files in my folder/album hierarchy into one single extra folder. At first, it worked great. But finally I re-found bug http://bugs.kde.org/show_bug.cgi?id=140175 and got a bunch of 0-Byte files. So do not use my "work-around"!
Comment 17 Chris 2009-06-15 15:32:23 UTC
heya,

don't want to bother, but what's the point ?
I've not found any solution in 0.10.0 under ubuntu....still working on it ?
Comment 18 DEnnis Meulensteen 2009-06-15 16:53:35 UTC
Hi Chris,
My point is that sometimes I want to view images all together regardless of the directory they are stored in. For example all images with a tag "Clouds". That would allow me to sort through them more efficiently than when they are pulled up with an album header in between. Related is my wish to have a free manual sort, ideally also without regard to "albums".

Dennis.



Op Monday 15 June 2009, schreef Chris:
> https://bugs.kde.org/show_bug.cgi?id=134389
> 
> 
> Chris <christoph@unixfrickler.de> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |christoph@unixfrickler.de
> 
> 
> 
> 
> --- Comment #17 from Chris <christoph unixfrickler de>  2009-06-15 15:32:23 ---
> heya,
> 
> don't want to bother, but what's the point ?
> I've not found any solution in 0.10.0 under ubuntu....still working on it ?
>
Comment 19 Chris 2009-06-15 21:52:37 UTC
Sorry. Maybe i didn't express myself very clear. 
I have the same wish......but this thread hasn't been updated for a while.
The last update said something about 0.9.4 the problem will be solved.

The question is: is there any plan when it will be done ?
Comment 20 Marcel Wiesweg 2009-06-15 22:14:35 UTC
Yes. It comes with the icon view reimplementation. It's implemented for 1.0beta1, but there is no menu action for it so you dont get it with beta1. Maybe beta2.
Comment 21 Marcel Wiesweg 2009-07-22 23:13:45 UTC
SVN commit 1001307 by mwiesweg:

Create category header texts for categorization by format or flat list.
For flat list, get the "parent" album that is displayed from ImageAlbumModel
and create an album type specific text.

CCBUG: 134389

 M  +152 -22   imagecategorydrawer.cpp  
 M  +11 -0     imagecategorydrawer.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1001307
Comment 22 Marcel Wiesweg 2009-07-22 23:13:49 UTC
SVN commit 1001308 by mwiesweg:

Store group mode in config

CCBUG: 134389

 M  +15 -1     albumsettings.cpp  
 M  +3 -0      albumsettings.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1001308
Comment 23 Marcel Wiesweg 2009-07-22 23:13:56 UTC
SVN commit 1001309 by mwiesweg:

Add select action to choose the categorization/group mode for images.
Available choices are Flat List, By Album, By Format.

BUG: 134389

 M  +24 -1     digikamapp.cpp  
 M  +2 -0      digikamapp_p.h  
 M  +1 -0      digikamimageview.cpp  
 M  +2 -1      digikamui.rc  
 M  +9 -0      digikamview.cpp  
 M  +1 -0      digikamview.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1001309
Comment 24 Thomas McGuire 2009-07-22 23:44:04 UTC
Great, thanks so much for implementing this, can't wait to try this out :)
Comment 25 DEnnis Meulensteen 2009-07-23 11:17:03 UTC
Op Wednesday 22 July 2009, schreef Marcel Wiesweg:
> Add select action to choose the categorization/group mode for images.
> Available choices are Flat List, By Album, By Format.

Excellent solution! Thanks a million. I can hardly wait to give this a go.

Dennis
Comment 26 Mikolaj Machowski 2009-07-23 21:28:41 UTC
I works great! Thank you very much.