Bug 134221 - Part of the text in extended information is not shown when URL is too long
Summary: Part of the text in extended information is not shown when URL is too long
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlists/Saved Playlists (show other bugs)
Version: 1.4.3
Platform: unspecified Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 129378 136654 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-17 18:39 UTC by Iñaki Ibarrola Atxa
Modified: 2007-12-29 22:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (35.84 KB, image/png)
2006-09-17 18:40 UTC, Iñaki Ibarrola Atxa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Iñaki Ibarrola Atxa 2006-09-17 18:39:45 UTC
Version:           1.4.3 (using KDE 3.5.4 Level "a" , unofficial build of SUSE )
Compiler:          Target: i586-suse-linux
OS:                Linux (i686) release 2.6.16.21-0.21-default

Text in the Extended information pane is hidden if the url is too long. Attachment included.
Comment 1 Iñaki Ibarrola Atxa 2006-09-17 18:40:38 UTC
Created attachment 17815 [details]
screenshot
Comment 2 Alexandre Oliveira 2006-11-01 16:51:34 UTC
*** Bug 136654 has been marked as a duplicate of this bug. ***
Comment 3 Alexandre Oliveira 2006-11-08 15:48:56 UTC
*** Bug 129378 has been marked as a duplicate of this bug. ***
Comment 4 Valent Turkovic 2006-11-09 14:43:28 UTC
This bug is still present in Amarok 1.4.4
Comment 5 Valent Turkovic 2006-11-09 14:46:33 UTC
When I go to playlists, podcasts and choose a podcast I like to read about i click on "Show Extended Info" button. The problem with this is that text isn't wrapped into size of the box but just goes on to the right.

This makes impossible to read any info about the shows because you see only first few words of every line!

Please correct this bug.
Comment 6 Valent Turkovic 2006-12-18 10:27:39 UTC
I can see by the comments that it is so because of missing XING header, but all other players I checked (xmms, audacious, banshee, exaile...) show the correct time when playing lugradio files even if they don't have correct XING header.

Valent form Croatia.

ps. check out my blog - http://kernelreloaded.blog385.com/
Comment 7 Valent Turkovic 2007-01-23 11:35:11 UTC
Is anybody working to fix this bug? All new releases I see are just ignoring this OBVIOUSLY ugly bug (ugly by means of user experience and UI).
Comment 8 Marcel 2007-01-24 14:40:09 UTC
It *is* an annoying bug, indeed.
Comment 9 Martin Aumueller 2007-01-28 12:53:58 UTC
This is somehow related to the stylesheet: removing the call to setUserStyleSheet or passing an empty QString as parameter or referring to a random stylesheet I found on my hard disk corrects the scrolling behaviour.
Comment 10 Alexandre Oliveira 2007-01-28 13:00:05 UTC
probably the: "overflow: hidden;" in .box
Comment 11 Alexandre Oliveira 2007-01-28 13:05:47 UTC
SVN commit 627825 by aoliveira:

Let the horizontal scrollbar show when necessary in our html boxes.
BUG: 134221


 M  +1 -1      htmlview.cpp  


--- trunk/extragear/multimedia/amarok/src/htmlview.cpp #627824:627825
@@ -210,7 +210,7 @@
         styleSheet += QString( ".song-place { font-size: %1px; font-weight: bold; }" ).arg( pxSize + 3 );
 
         //box: the base container for every block (border hilighted on hover, 'A' without underlining)
-        styleSheet += QString( ".box { border: solid %1 1px; text-align: left; margin-bottom: 10px; overflow: hidden;}" ).arg( bg );
+        styleSheet += QString( ".box { border: solid %1 1px; text-align: left; margin-bottom: 10px; }" ).arg( bg );
         styleSheet += QString( ".box a { text-decoration: none; }" );
         styleSheet += QString( ".box:hover { border: solid %1 1px; }" ).arg( text );
 
Comment 12 Martin Aumueller 2007-01-28 13:11:48 UTC
SVN commit 627828 by aumuell:

overflow:hidden would disable horizontal scrolling
CCBUG: 134221


 M  +1 -1      stylesheet.css  


--- trunk/extragear/multimedia/amarok/src/themes/reinhardt/stylesheet.css #627827:627828
@@ -17,7 +17,7 @@
 .song-time { }
 .song-place { font-size: 12px; font-weight: 900; }
 .warning { font-size: AMAROK_FONTSIZEpx; color: InfoText; background-color: InfoBackground; font-weight: bold; padding: none; margin-bottom: 1em; }
-.box { border: solid ButtonShadow 1px; text-align: left; margin-bottom: AMAROK_FONTSIZEpx; overflow: hidden; }
+.box { border: solid ButtonShadow 1px; text-align: left; margin-bottom: AMAROK_FONTSIZEpx; }
 .box a { text-decoration: none; }
 .box:hover { border: solid ButtonShadow 1px; }
 .box-header { color: ButtonText; background-color: ButtonFace; font-size: AMAROK_FONTSIZEpx; font-weight: bold; padding: 1px 0.5em; border-bottom: 1px solid ButtonShadow; }
Comment 13 Valent Turkovic 2007-12-29 21:23:46 UTC
This is the most annoying bug in Amarok and still a year later and it is still present in latest Amarok, I really can't believe that it is that hard to fix this bug :(
Comment 14 Valent Turkovic 2007-12-29 21:33:23 UTC
ps. I use Amarok 1.4.7 the latest version in Fedora 8
Comment 15 Valent Turkovic 2007-12-29 22:43:37 UTC
sorry, I see other bug not this one.
ignore my last two posts :)