Bug 134017 - kmail wordwrap limit is column 78: break it
Summary: kmail wordwrap limit is column 78: break it
Status: RESOLVED DUPLICATE of bug 31951
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.8.2
Platform: Slackware Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-13 16:39 UTC by heavytull
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description heavytull 2006-09-13 16:39:02 UTC
Version:           1.8.2 (using KDE KDE 3.4.2)
Installed from:    Slackware Packages
OS:                Linux

the wordwrap limit is column 78, I don't no why!
actually I would like kmail sets a dynamic wordwrap limit which would change
regarding the window size (composer or editor).
Comment 1 Nick Warne 2006-09-14 20:58:24 UTC
This isn't a bug, nor a 'feature'.  It is by legacy design and perhaps has become an accepted standard... from old archives:



Although this is the 1990's, not everyone in the world has e-mail software that has the word wrap feature (word wrap keeps you from having to hit the Enter key at the end of line of text). There are still a large number of users with dumb (and not so dumb) terminals and teletype devices that do not gracefully handle text longer than the old punch card length of 80 characters. Therefore, keep the number of characters per line below the 80 character limit. Many e-mail packages have a built-in feature that automatically word wraps at a specified character limit so that the problem is essentially solved.


I believe (maybe wrongly) that some type of routers still need the < 80 chars limit on mime encoded 'lines' - but this might be legacy too.

Nick
Comment 2 Ernest ter Kuile 2006-12-22 23:48:57 UTC
This bug is still true for the latest kmail.

Word wrap only up to 78 is still ridiculous. If some routers still need it, they must have crashed by now given that outlook does not word wrap at all.

Either kmail should force the writer always to word wrap to 78 (no more, no less, and remove the option to switch it off)

Or it should allow for more freedom and allow to word wrap at screen edge or allow the user to word wrap at some higher value than 78!

The current possibilities to only allow up to 78 or less (!) or to switch it simply off (causing all those routers you talk about to crash miserably) is not of this time.

Email _readers_ should be smarter, and wrap to screen edge. Why force the whole world to send at 78 chars because a few people still refuse to use an email reader which is incapable to word wrap at reception to their screen width.


KDE Version  unknown (KDE 3.5.5, Debian Package 4:3.5.5a.dfsg.1-5 (4.0))
Application  KMail - Message Composer component
Operating System  Linux (x86_64) release 2.6.19.1
Compiler  Target: x86_64-linux-gnu

Comment 3 Bram Schoenmakers 2007-03-25 23:33:12 UTC

*** This bug has been marked as a duplicate of 31951 ***