Bug 133638 - Image backup with thumbs and metadata database for fast searching
Summary: Image backup with thumbs and metadata database for fast searching
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-WishForNewTools (show other bugs)
Version: 0.9.0
Platform: Gentoo Packages Linux
: NOR wishlist with 2 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-06 09:27 UTC by Marcin Gil
Modified: 2019-07-28 21:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin Gil 2006-09-06 09:27:45 UTC
Version:           0.9.0-beta1 (using KDE KDE 3.5.4)
Installed from:    Gentoo Packages
Compiler:          gcc 4.1.1 
OS:                Linux

My dream is that digikam can create a backup CD/DVD that contains selected images together with database containing thumbnails, metadata, keywords, tags and all other information that can be used for fast-searching discs for a particular image.

Digikam could also store those databases when files are deleted from disc so one can easily find and extract an image from a disc.

Use case:
a) a user creates e.g. 5 DVDs with his RAW image files using digikam (he might even do a double-backup of each DVD).
b) digikam stores a database for each DVD on this particular DVD (burned together with images) and also in its cache.
c) user deletes files from disc to reclaim some HDD space; digikam knows those images and can browse through thumbs and metadata because it has all databases created for burned DVDs
d) user creates a search for images and some of them are on DVDs
e) digikam knows the name and/or hash/something that can identify the DVD on which the image is stored and can display this to user so s/he can get the image (digikam could also ask for the DVD to be inserted into the drive and pull the image from the disc)

Even if digikam data is deleted from users folder all of thumbs, metadata can be restored by importing all of databases distributed on backup CDs/DVDs that user burned using digikam.
Comment 1 caulier.gilles 2006-09-06 10:33:39 UTC
We will work on this tool later 0.9.0 release

Gilles Caulier
Comment 2 Michael G. Hansen 2009-11-27 12:25:52 UTC

*** This bug has been marked as a duplicate of bug 191494 ***
Comment 3 caulier.gilles 2019-07-28 21:19:01 UTC
Fixed with bug #191494