Bug 133454 - Crash after dialog stating that server closed connection
Summary: Crash after dialog stating that server closed connection
Status: RESOLVED DUPLICATE of bug 128131
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-02 20:33 UTC by michal
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michal 2006-09-02 20:33:03 UTC
Version:            (using KDE KDE 3.5.4)
Installed from:    Unlisted Binary Package

I starded KMail. When it was checking for new mail, I changed mailbox in mutt, probably causing write to mailbox KMail was reading. KMail showed dialog stating that connection has been closed by server or timed out and crashed after I clicked OK.

Using host libthread_db library "/lib/tls/libthread_db.so.1".
[KCrash handler]
#6  0xb71affda in QMap<KPIM::ProgressItem*, bool>::isEmpty (this=0x8677db0)
    at /usr/include/qt/qmap.h:722
#7  0xb71adc68 in KPIM::ProgressItem::setComplete (this=0x8677d70)
    at progressmanager.cpp:55
#8  0xb7d6ff67 in KMail::ImapAccountBase::removeJob (this=0x82c9f20, 
    it=@0xbffd4a20) at imapaccountbase.cpp:1174
#9  0xb7d8d0f0 in KMFolderImap::slotListFolderResult (this=0x8266948, 
    job=0x848b188) at kmfolderimap.cpp:1239
#10 0xb7d9334c in KMFolderImap::qt_invoke (this=0x8266948, _id=27, 
    _o=0xbffd4b40) at kmfolderimap.moc:320
#11 0xb5d25b93 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb698f2ed in KIO::Job::result (this=0x848b188, t0=0x848b188)
    at jobclasses.moc:162
#13 0xb697a120 in KIO::Job::emitResult (this=0x848b188) at job.cpp:226
#14 0xb697b7db in KIO::SimpleJob::slotFinished (this=0x848b188) at job.cpp:574
#15 0xb6982ec8 in KIO::ListJob::slotFinished (this=0x848b188) at job.cpp:2095
#16 0xb697b87c in KIO::SimpleJob::slotError (this=0x848b188, error=24, 
    errorText=@0x851fa48) at job.cpp:585
#17 0xb6990337 in KIO::SimpleJob::qt_invoke (this=0x848b188, _id=14, 
    _o=0xbffd4e20) at jobclasses.moc:424
#18 0xb69936c9 in KIO::ListJob::qt_invoke (this=0x848b188, _id=14, 
    _o=0xbffd4e20) at jobclasses.moc:1741
#19 0xb5d25b0d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#20 0xb696cb53 in KIO::SlaveInterface::error (this=0x83d4238, t0=24, 
    t1=@0xbffd4fa0) at slaveinterface.moc:214
#21 0xb696b429 in KIO::SlaveInterface::dispatch (this=0x83d4238, _cmd=102, 
    rawdata=@0xbffd5010) at slaveinterface.cpp:280
#22 0xb696ae6a in KIO::SlaveInterface::dispatch (this=0x83d4238)
    at slaveinterface.cpp:173
#23 0xb6968993 in KIO::Slave::gotInput (this=0x83d4238) at slave.cpp:300
#24 0xb696a36f in KIO::Slave::qt_invoke (this=0x83d4238, _id=4, _o=0xbffd5130)
    at slave.moc:113
#25 0xb5d25b93 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#26 0xb5d25ced in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#27 0xb6031e72 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#28 0xb5d41a6e in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#29 0xb5cca87c in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#30 0xb5cc9ea5 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#31 0xb631f6be in KApplication::notify (this=0xbffd57a0, receiver=0x83cd3f0, 
    event=0xbffd5460) at kapplication.cpp:550
#32 0xb5cba7d5 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#33 0xb5c74cdf in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#34 0xb5cdbb58 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#35 0xb5cdba08 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#36 0xb5ccaab1 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#37 0x0804aa38 in main (argc=7, argv=0xbffd5954) at main.cpp:110
Comment 1 Andreas Kling 2006-09-02 21:19:48 UTC

*** This bug has been marked as a duplicate of 128131 ***