Bug 133329 - Digikam crashes when accessing Camera GUI
Summary: Digikam crashes when accessing Camera GUI
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Gphoto2 (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-31 12:41 UTC by Marco van der Heide
Modified: 2017-08-16 06:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
digiKam 0.9.0-beta2 camera gui screenshot (302.82 KB, image/png)
2006-08-31 12:53 UTC, caulier.gilles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco van der Heide 2006-08-31 12:41:26 UTC
Version:           0.8.1 and 0.8.2 (using KDE KDE 3.5.1)
Installed from:    SuSE RPMs
OS:                Linux

When accessing the Camera GUI, digikam crashes directly without any error-message.

The backtrace:
------------------
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1237846352 (LWP 16313)]
[New Thread -1250186336 (LWP 16323)]
0xb6687438 in pthread_mutex_lock () from /lib/libpthread.so.0
#0  0xb6687438 in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb6ca0056 in pthread_mutex_lock () from /lib/libc.so.6
#2  0xb72e259b in QRecursiveMutexPrivate::lock ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#3  0xb72e21a4 in QMutex::lock () from /usr/lib/qt3/lib/libqt-mt.so.3
#4  0xb6fec4d3 in QApplication::sendPostedEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0xb6fec6cc in QApplication::sendPostedEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0xb6fec776 in QApplication::sendPostedEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0xb6f9a032 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0xb7001a78 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0xb700190e in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0xb6fea7ff in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x0804a28f in ?? ()
#12 0xbfb31a48 in ?? ()
#13 0xbfb31b5c in ?? ()
#14 0x00000000 in ?? ()
--------------------
The version libqt-mt.so.3 is 3.3.5-58.3.
The plugins loaded are from kipi 0.1.2. (also tried with kipi 0.1.0.
Comment 1 caulier.gilles 2006-08-31 12:52:37 UTC
The backtrace is uncomplete because digiKAm have been compiled without debug informations.

Also, camera gui from 0.9.0 have been very improved against 0.8.x. We have fixed a lot of bugs and added some important features. Look the current NEWS file :

http://websvn.kde.org/trunk/extragear/graphics/digikam/NEWS

I recommend you to try with the current version available from svn (next beta2 planed during septembre).

Gilles Caulier
Comment 2 caulier.gilles 2006-08-31 12:53:41 UTC
Created attachment 17585 [details]
digiKam 0.9.0-beta2 camera gui screenshot
Comment 3 mikew 2006-09-03 15:13:41 UTC
just FYI:

I have the same issue on 0.8.2 and have had it on earlier versions as well.

ii  digikam                   0.8.2-2                   digital photo management application for KDE

KDE 3.5

I will try the 1:0.9-beta1-r1-1 package.


(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1507563840 (LWP 16647)]
[New Thread -1516786768 (LWP -1)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5  0xa629e7c7 in raise () from /lib/tls/libc.so.6
#6  0xa62a006b in abort () from /lib/tls/libc.so.6
#7  0xa6297735 in __assert_fail () from /lib/tls/libc.so.6
#8  0xa6569840 in pthread_create@@GLIBC_2.1 () from /lib/tls/libpthread.so.0
#9  0xa6a93310 in QThread::start () from /usr/lib/libqt-mt.so.3
#10 0xa6a933a5 in QThread::start () from /usr/lib/libqt-mt.so.3
#11 0xa7ea0aeb in CameraController::slotProcessNext ()
   from /usr/lib/libdigikam.so.0
#12 0xa7ea164f in CameraController::qt_invoke () from /usr/lib/libdigikam.so.0
#13 0xa6b0654b in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xa6b06fdc in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xa6e9a2ae in QTimer::timeout () from /usr/lib/libqt-mt.so.3
#16 0xa6b2b4a1 in QTimer::event () from /usr/lib/libqt-mt.so.3
#17 0xa6a9c87a in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#18 0xa6a9ca76 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#19 0xa723e52e in KApplication::notify () from /usr/lib/libkdecore.so.4
#20 0xa6a2e001 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#21 0xa6a8e305 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#22 0xa6a41d2a in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#23 0xa6ab5255 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#24 0xa6ab517a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#25 0xa6a9b38d in QApplication::exec () from /usr/lib/libqt-mt.so.3
#26 0x0804a6c4 in main ()

$ ldd /usr/bin/digikam
        linux-gate.so.1 =>  (0xffffe000)
        libdigikam.so.0 => /usr/lib/libdigikam.so.0 (0xa7d17000)
        libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xa7cbd000)
        libkabc.so.1 => /usr/lib/libkabc.so.1 (0xa7c0b000)
        libvcard.so.0 => /usr/lib/libvcard.so.0 (0xa7be7000)
        libkresources.so.1 => /usr/lib/libkresources.so.1 (0xa7bc5000)
        libkipi.so.0 => /usr/lib/libkipi.so.0 (0xa7b90000)
        libkutils.so.1 => /usr/lib/libkutils.so.1 (0xa7b2f000)
        libtiff.so.4 => /usr/lib/libtiff.so.4 (0xa7adb000)
        libkdeprint.so.4 => /usr/lib/libkdeprint.so.4 (0xa7a0d000)
        libkparts.so.2 => /usr/lib/libkparts.so.2 (0xa79c8000)
        libkio.so.4 => /usr/lib/libkio.so.4 (0xa768a000)
        libkdesu.so.4 => /usr/lib/libkdesu.so.4 (0xa7675000)
        libkwalletclient.so.1 => /usr/lib/libkwalletclient.so.1 (0xa7664000)
        libfam.so.0 => /usr/lib/libfam.so.0 (0xa765b000)
        libacl.so.1 => /lib/libacl.so.1 (0xa7652000)
        libattr.so.1 => /lib/libattr.so.1 (0xa764e000)
        libImlib2.so.1 => /usr/lib/libImlib2.so.1 (0xa75ea000)
        libkexif.so.1 => /usr/lib/libkexif.so.1 (0xa75d4000)
        libkdeui.so.4 => /usr/lib/libkdeui.so.4 (0xa72fc000)
        libkdecore.so.4 => /usr/lib/libkdecore.so.4 (0xa70c6000)
        libDCOP.so.4 => /usr/lib/libDCOP.so.4 (0xa7093000)
        libresolv.so.2 => /lib/tls/libresolv.so.2 (0xa7080000)
        libutil.so.1 => /lib/tls/libutil.so.1 (0xa707c000)
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0xa7066000)
        libidn.so.11 => /usr/lib/libidn.so.11 (0xa7036000)
        libkdefx.so.4 => /usr/lib/libkdefx.so.4 (0xa700b000)
        libqt-mt.so.3 => /usr/lib/libqt-mt.so.3 (0xa6824000)
        libaudio.so.2 => /usr/lib/libaudio.so.2 (0xa680f000)
        libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0xa67bf000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xa679f000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xa677a000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0xa6772000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xa6768000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0xa6764000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xa675b000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0xa6758000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0xa6745000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xa66d9000)
        libz.so.1 => /usr/lib/libz.so.1 (0xa66c4000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xa6695000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xa6687000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xa65bc000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xa65b3000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xa659b000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0xa6588000)
        libgphoto2.so.2 => /usr/lib/libgphoto2.so.2 (0xa650e000)
        libexif.so.12 => /usr/lib/libexif.so.12 (0xa64eb000)
        libgphoto2_port.so.0 => /usr/lib/libgphoto2_port.so.0 (0xa64e4000)
        libltdl.so.3 => /usr/lib/libltdl.so.3 (0xa64dd000)
        libdl.so.2 => /lib/tls/libdl.so.2 (0xa64d9000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xa63f7000)
        libm.so.6 => /lib/tls/libm.so.6 (0xa63d1000)
        libc.so.6 => /lib/tls/libc.so.6 (0xa6299000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xa628e000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xa626d000)
        /lib/ld-linux.so.2 (0xa7f60000)
Comment 4 mikew 2006-09-03 15:16:43 UTC
ii  digikam                   0.9-beta1-r1-1            digital photo management application for KDE


Same crash with 0.9

Comment 5 caulier.gilles 2006-09-03 15:32:00 UTC
Your GDB backtrace is not suitable. Please compile digiKam using full debug option like this :

./configure --enable-debug=full

Also, please try the current implementation from svn 'trunk'. A lot of fix have been done into Camera Gui since 0.9.0-beta1

To be sure, please give us with libgphoto2 version that you use and the camera driver configured in digiKam.

Camera gui will provide a lots of debug text messages in the console. Please report these informations in this B.K.O file.

Thanks in advance

Gilles Caulier
Comment 6 mikew 2006-09-04 18:00:45 UTC
Hi Gilles,

Thanks. I've checkedout truck as documented on the digikam site:

http://www.digikam.org/?q=download/svn

I've also followed the direction to build it. It seems the instructions are a little out of date. There is no Makefile.cvs in the libs directory (I assume this means the graphics/digikam/libs directory since that is the only one I find). I skipped this and ran makefile -f Makefile.cvs on in the graphics directory. Doing so resulted in:

$ make -f Makefile.cvs
This Makefile is only for the CVS repository
This will be deleted before making the distribution

./admin/cvs.sh: line 36: --version: command not found
*** AUTOCONF NOT FOUND!.
*** KDE requires autoconf 2.53 or newer
make[1]: *** [cvs] Error 1
make: *** [all] Error 2

Like 36 is trying to use $AUTOCONF which is not set anywhere. Anyhow, I put the following lines in the ./admin/cvs.sh file and reran make.

AUTOCONF=/usr/bin/autoconf2.50
AUTOHEADER=/usr/bin/autoheader2.50
AUTOMAKE=/usr/bin/automake-1.9

$ make -f Makefile.cvs
This Makefile is only for the CVS repository
This will be deleted before making the distribution

*** automake (GNU automake) 1.9.6 found.
*** Creating acinclude.m4
*** Creating list of subdirectories
*** Creating Makefile.am
*** Creating configure.files
*** Creating configure.in
*** Creating aclocal.m4
*** Creating configure
configure.in:43: error: possibly undefined macro: AM_INIT_AUTOMAKE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
configure.in:48: error: possibly undefined macro: AM_CONFIG_HEADER
configure.in:51: error: possibly undefined macro: AC_CHECK_COMPILERS
configure.in:52: error: possibly undefined macro: AC_ENABLE_SHARED
configure.in:53: error: possibly undefined macro: AC_ENABLE_STATIC
configure.in:58: error: possibly undefined macro: AM_KDE_WITH_NLS
configure.in:61: error: possibly undefined macro: AC_PATH_KDE
configure.in:401: error: possibly undefined macro: AM_CONDITIONAL
make[1]: *** [cvs] Error 1
make: *** [all] Error 2

Obviously I'm missing some critical piece I'm missing on trunk. I'm on revision 580838.

What am I doing wrong?

Thanks.
Comment 7 caulier.gilles 2006-09-04 19:26:21 UTC
Nothing about digiKam & co source code is missing from svn. Something is wrong on your computer. Try to chack if automake is properly installed

Gilles
Comment 8 mikew 2006-10-29 02:43:26 UTC
I could not get this to build or run. I'm running a debian system so I did a
complete upgrade, dist-upgrade and my problems went away. Not exactly sure
of the cause however.

Thanks.

- Mike

On 4 Sep 2006 17:26:22 -0000, Gilles Caulier <caulier.gilles@free.fr> wrote:
[bugs.kde.org quoted mail]
I could not get this to build or run. I'm running a debian system so I did a complete upgrade, dist-upgrade and my problems went away. Not exactly sure of the cause however.<br><br>Thanks.<br><br>- Mike<br><br><div><span class="gmail_quote">
On 4 Sep 2006 17:26:22 -0000, <b class="gmail_sendername">Gilles Caulier</b> &lt;<a href="mailto:caulier.gilles@free.fr">caulier.gilles@free.fr</a>&gt; wrote:</span><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
------- You are receiving this mail because: -------<br>You are on the CC list for the bug, or are watching someone who is.<br><br><a href="http://bugs.kde.org/show_bug.cgi?id=133329">http://bugs.kde.org/show_bug.cgi?id=133329
</a><br><br><br><br><br>------- Additional Comments From caulier.gilles free fr&nbsp;&nbsp;2006-09-04 19:26 -------<br>Nothing about digiKam &amp; co source code is missing from svn. Something is wrong on your computer. Try to chack if automake is properly installed
<br><br>Gilles<br></blockquote></div><br>
Comment 9 caulier.gilles 2006-12-12 09:18:57 UTC
Marco,

This crash still reproductible using digiKam/DigikamImagePlugins 0.9.0-RC2 and Exiv2 0.12 ?

Thanks in advance for your feedback.

Gilles Caulier
Comment 10 Arnd Baecker 2007-06-06 19:41:03 UTC
Hi Marco,

is this crash still reproducible using digikam 0.9.2-beta3 and exiv2 0.14 ?

Many thanks in advance for any feedback!
Comment 11 Arnd Baecker 2007-06-26 09:48:43 UTC
Closing this bug now. 
This does not mean it is invalid by itself, but
without updated information (with full debug gdb backtrace) 
using the current 0.9.2 version
it is not possible to find the root of the problem.

Please feel free to re-open if there is any new information.

Thanks a lot for your understanding, 

Arnd