Bug 132672 - kmail crash in imap "find messages"
Summary: kmail crash in imap "find messages"
Status: RESOLVED DUPLICATE of bug 113885
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.1
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-20 05:23 UTC by Thomas Kunz
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kunz 2006-08-20 05:23:12 UTC
Version:           1.9.1 (using KDE 3.5.2, Kubuntu Package 4:3.5.2-0ubuntu18.1 dapper)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.15-23-386

The crash happened while I had the "Find Messages" dialog open and searching an imap folder with search scope "<message>". Kmail was running in Kontact. 
The bug did not happen again with the same configuration, so I can't say it is reproducible.

Backtrace:
(no debugging symbols found)
[KCrash handler]
#6  0xb568a127 in KMFolder::open () from /usr/lib/libkmailprivate.so
#7  0xb57ef1bd in KMFolderSearch::addSerNum ()
   from /usr/lib/libkmailprivate.so
#8  0xb57f1892 in KMFolderSearch::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#9  0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#10 0xb57ecb2c in KMSearch::found () from /usr/lib/libkmailprivate.so
#11 0xb57eeb6f in KMSearch::slotSearchFolderResult ()
   from /usr/lib/libkmailprivate.so
#12 0xb57eed45 in KMSearch::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0xb56a7e33 in FolderStorage::searchResult ()
   from /usr/lib/libkmailprivate.so
#15 0xb5727a44 in KMFolderImap::slotSearchDone ()
   from /usr/lib/libkmailprivate.so
#16 0xb57342b8 in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#17 0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xb585ad2a in KMail::SearchJob::searchDone ()
   from /usr/lib/libkmailprivate.so
#19 0xb585b5bf in KMail::SearchJob::slotSearchFolder ()
   from /usr/lib/libkmailprivate.so
#20 0xb585c599 in KMail::SearchJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#21 0xb7041fe6 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb5727c62 in KMFolderImap::folderComplete ()
   from /usr/lib/libkmailprivate.so
#23 0xb5727cd5 in KMFolderImap::finishMailCheck ()
   from /usr/lib/libkmailprivate.so
#24 0xb572a6cb in KMFolderImap::getMessagesResult ()
   from /usr/lib/libkmailprivate.so
#25 0xb572a7c4 in KMFolderImap::slotGetLastMessagesResult ()
   from /usr/lib/libkmailprivate.so
#26 0xb5734478 in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#27 0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#28 0xb6b2f5ae in KIO::Job::result () from /usr/lib/libkio.so.4
#29 0xb6b80d62 in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#30 0xb6b80ea6 in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#31 0xb6b815a9 in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#32 0xb6b82aef in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#33 0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#34 0xb7042954 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#35 0xb6b2a9d4 in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#36 0xb6b9acc1 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#37 0xb6b41739 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#38 0xb6b46230 in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#39 0xb6b463c5 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#40 0xb7041eb9 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#41 0xb70427c8 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#42 0xb73d606f in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#43 0xb70621fe in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#44 0xb6fd7e56 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#45 0xb6fd8052 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#46 0xb76d5d7d in KApplication::notify () from /usr/lib/libkdecore.so.4
#47 0xb6f69157 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#48 0xb6fc9973 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#49 0xb6f7cf43 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#50 0xb6ff0947 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#51 0xb6ff086a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#52 0xb6fd6965 in QApplication::exec () from /usr/lib/libqt-mt.so.3
Comment 1 Tommi Tervo 2006-08-20 10:11:08 UTC

*** This bug has been marked as a duplicate of 113885 ***