Bug 131412 - [PATCH] kopete does not send photo from global identity for MSN
Summary: [PATCH] kopete does not send photo from global identity for MSN
Status: RESOLVED FIXED
Alias: None
Product: kopete
Classification: Unclassified
Component: MSN Plugin (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kopete Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-26 21:19 UTC by S. Burmeister
Modified: 2008-11-15 16:19 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
One-line patch that solves the bug (I hope) (552 bytes, patch)
2006-12-03 22:38 UTC, Luigi Toscano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2006-07-26 21:19:33 UTC
Version:           0.12.1 (using KDE KDE 3.5.4)
Installed from:    SuSE RPMs
OS:                Linux

I had set a photo in the global identity only. For me this means, use that photo for all my accounts. Yet for MSN it seems that one has to explicitly enable the "export photo", which I would suspect kopete does when enabling a global photo.
Comment 1 Benoit VAUTRIN 2006-10-27 22:31:15 UTC
Same thing here with kopete from KDE 3.5.5 compiled from source
Comment 2 Luigi Toscano 2006-12-03 22:38:50 UTC
Created attachment 18769 [details]
One-line patch that solves the bug (I hope)

I can confirm this bug with the latest svn from 3.5 branch.

If you set the photo for the MSN account, it works. 

I've attacched a small patch (one-line) that fixes the bug (tested with the
official MSN client).
Comment 3 Rafael Fernández López 2006-12-04 00:53:22 UTC
Is not really necessary to pass false to readBoolEntry, since it is the option by default. "true" and "false" should be changed by enums or something, since booleans on parameters don't give information when reading.

I should write that line this way:

if( (configGroup()->readBoolEntry("ExcludeGlobalIdentity") ) &&

Anyway you can check out at

http://developer.kde.org/documentation/library/cvs-api/kdelibs-apidocs/kdecore/html/classKConfigBase.html#a46
Comment 4 Luigi Toscano 2006-12-04 13:37:27 UTC
That's ok by me. I used the code that I found on line 1260 of the same file (in the MSNAccount::slotGlobalIdentityChanged method).
Comment 5 Luigi Toscano 2007-01-13 14:17:59 UTC
Any news about this patch?
It could be nice to have it in KDE 3.5.6 :)
Comment 6 Matt Rogers 2007-01-13 16:44:56 UTC
The patch can be committed.
Comment 7 Médéric Boquien 2008-11-15 15:25:31 UTC
Hi!

Has the patch been committed? Does kopete work as wished now?

Thanks.
Comment 8 Luigi Toscano 2008-11-15 16:19:04 UTC
Sorry, I completely forgot about this bug. 
As I wrote here:
http://markmail.org/message/miywirb4rzxdk7v3
the issue has been solved (at least for me); as no one objected, I'm closing this bug.