Bug 131285 - searching an imap folder crashes kmail
Summary: searching an imap folder crashes kmail
Status: RESOLVED DUPLICATE of bug 113885
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.9.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-24 10:50 UTC by Henty Waker
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henty Waker 2006-07-24 10:50:52 UTC
Version:           1.9.3 (using KDE KDE 3.5.3)
Installed from:    Fedora RPMs
Compiler:          default fedora core 5 
OS:                Linux

ACTION THAT CONSISTENTLY CAUSES CRASH:

This is probably particular to the contents of my inbox, but it's not practical to send my entire inbox as part of the bug report.

Steps after startup:
1) Select the first&latest email in my default imap4 inbox (dovecot maildir).
2) Press "s" to search
3) Choose "From", (stick with "Contains" & other defaults), type in the search term "Felix"
4) Press "Search" button.

-> Crash.


FROM CMD LINE:
kmail &
[1] 4505
[hentyw@dev1 ~]$ QWidget::setMaximumSize: (unnamed/RecipientComboBox) The largest allowed size is (32767,32767)
WeaverThreadLogger: thread (ID: 1) suspended.
WeaverThreadLogger: thread (ID: 3) suspended.
WeaverThreadLogger: thread (ID: 4) suspended.
WeaverThreadLogger: thread (ID: 2) suspended.
*** KMail got signal 11 (Crashing)
KCrash: Application 'kmail' crashing...


FROM BACK TRACE:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208678704 (LWP 4506)]
[New Thread -1243927648 (LWP 4510)]
[New Thread -1233437792 (LWP 4509)]
[New Thread -1222947936 (LWP 4508)]
[New Thread -1212458080 (LWP 4507)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x05c91989 in KMFolder::open () from /usr/lib/libkmailprivate.so
#7  0x05e06e5d in KMFolderSearch::addSerNum ()
   from /usr/lib/libkmailprivate.so
#8  0x05e076df in KMFolderSearch::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#9  0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x05e03e9e in KMSearch::found () from /usr/lib/libkmailprivate.so
#11 0x05e07912 in KMSearch::slotSearchFolderResult ()
   from /usr/lib/libkmailprivate.so
#12 0x05e07d15 in KMSearch::qt_invoke () from /usr/lib/libkmailprivate.so
#13 0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x05cb0f63 in FolderStorage::searchResult ()
   from /usr/lib/libkmailprivate.so
#15 0x05d361b6 in KMFolderImap::slotSearchDone ()
   from /usr/lib/libkmailprivate.so
#16 0x05d4375b in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#17 0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x05e78a2d in KMail::SearchJob::searchDone ()
   from /usr/lib/libkmailprivate.so
#19 0x05e79900 in KMail::SearchJob::slotSearchFolder ()
   from /usr/lib/libkmailprivate.so
#20 0x05e7a22e in KMail::SearchJob::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#21 0x04494601 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#22 0x05d36465 in KMFolderImap::folderComplete ()
   from /usr/lib/libkmailprivate.so
#23 0x05d364f1 in KMFolderImap::finishMailCheck ()
   from /usr/lib/libkmailprivate.so
#24 0x05d38c6f in KMFolderImap::getMessagesResult ()
   from /usr/lib/libkmailprivate.so
#25 0x05d38d8c in KMFolderImap::slotGetLastMessagesResult ()
   from /usr/lib/libkmailprivate.so
#26 0x05d4391b in KMFolderImap::qt_invoke () from /usr/lib/libkmailprivate.so
#27 0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#28 0x04e7bf3e in KIO::Job::result () from /usr/lib/libkio.so.4
#29 0x04eba1ed in KIO::Job::emitResult () from /usr/lib/libkio.so.4
#30 0x04ecda9e in KIO::SimpleJob::slotFinished () from /usr/lib/libkio.so.4
#31 0x04ece18d in KIO::TransferJob::slotFinished () from /usr/lib/libkio.so.4
#32 0x04ebb15a in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#33 0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x0449520d in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x04e7511c in KIO::SlaveInterface::finished () from /usr/lib/libkio.so.4
#36 0x04ed0165 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#37 0x04ee1bda in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#38 0x04e8930c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#39 0x04ec7690 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#40 0x0449469a in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#41 0x044950a2 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#42 0x0481f380 in QSocketNotifier::activated ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#43 0x044b5100 in QSocketNotifier::event ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#44 0x0442bbbb in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#45 0x0442d009 in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#46 0x008a6ac3 in KApplication::notify () from /usr/lib/libkdecore.so.4
#47 0x0441f381 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#48 0x043d4031 in QEventLoop::processEvents ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#49 0x04445060 in QEventLoop::enterLoop ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#50 0x04444f26 in QEventLoop::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#51 0x0442b6cf in QApplication::exec () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#52 0x0804a10e in ?? ()
#53 0x003a3724 in __libc_start_main () from /lib/libc.so.6
#54 0x08049e71 in ?? ()
Comment 1 Tommi Tervo 2006-07-24 11:05:15 UTC

*** This bug has been marked as a duplicate of 113885 ***