Bug 130756 - if some open files are modified by an external program, kate crashes when saving any file
Summary: if some open files are modified by an external program, kate crashes when sav...
Status: RESOLVED DUPLICATE of bug 123315
Alias: None
Product: kate
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-13 10:34 UTC by Gerald Weber
Modified: 2006-07-14 06:52 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Weber 2006-07-13 10:34:35 UTC
Version:           2.5.1 (using KDE 3.5.1 Level "a" , SUSE 10.1)
Compiler:          Target: x86_64-suse-linux
OS:                Linux (x86_64) release 2.6.16.13-4-default

This crash has now happened a couple of times under SuSE 10.1/kate 3.5.1/kde 3.5.1 level "a", arch: x86_64.

I have a couple of files open. One or more files are modified by an external program such as cervisia, e.g., after comiting a file to the cvs. 
Kate then dutifully opens a dialog box alerting that files have changed, I ask to reload the changed files, so far everything seems OK. Then, after some further editing, I save a file with Crtl-S and Kate crashes without saving that file. A small IO window showing a file transfer that never gets completed stays open and has to be closed manually.

This crash only happens after files have been modified externally, otherwise the "save" operation works OK. 

If I reopen kate it starts up with some old session information.

Hope this helps.

best wishes

Gerald

Debug backtrace:

[KCrash handler]
#5  0x00002b141320d41b in operator== () from /usr/lib/qt3/lib64/libqt-mt.so.3
#6  0x00002b141261f607 in KDirWatchPrivate::slotActivated ()
   from /opt/kde3/lib64/libkio.so.4
#7  0x00002b141261f838 in KDirWatchPrivate::qt_invoke ()
   from /opt/kde3/lib64/libkio.so.4
#8  0x00002b1412f877ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#9  0x00002b1412f883ef in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#10 0x00002b1412fa204b in QSocketNotifier::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#11 0x00002b1412f30985 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#12 0x00002b1412f315b7 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#13 0x00002b1412a6f708 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#14 0x00002b1412f2697c in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#15 0x00002b1412ee7410 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#16 0x00002b1412f456a1 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#17 0x00002b141253840a in KIO::NetAccess::enter_loop ()
   from /opt/kde3/lib64/libkio.so.4
#18 0x00002b141257a6f5 in KIO::NetAccess::filecopyInternal ()
   from /opt/kde3/lib64/libkio.so.4
#19 0x00002b141257aa2d in KIO::NetAccess::file_copy ()
   from /opt/kde3/lib64/libkio.so.4
#20 0x00002b14175e79fe in KateDocument::save ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#21 0x00002b14175a9d1b in KateView::save ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#22 0x00002b1417648bb0 in KateView::qt_invoke ()
   from /opt/kde3/lib64/kde3/libkatepart.so
#23 0x00002b1412f877ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#24 0x00002b1412f884c3 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#25 0x00002b1413fbbcf1 in KAction::qt_invoke ()
   from /opt/kde3/lib64/libkdeui.so.4
#26 0x00002b1412f877ac in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#27 0x00002b1412f884c3 in QObject::activate_signal ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#28 0x00002b14129e5f45 in KAccelPrivate::emitActivatedSignal ()
   from /opt/kde3/lib64/libkdecore.so.4
#29 0x00002b1412a3ba1f in KAccelPrivate::eventFilter ()
   from /opt/kde3/lib64/libkdecore.so.4
#30 0x00002b1412f871b2 in QObject::activate_filters ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#31 0x00002b1412f87207 in QObject::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#32 0x00002b1412fba2c8 in QWidget::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#33 0x00002b14130641d5 in QMainWindow::event ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#34 0x00002b14167834af in KateMainWindow::event ()
   from /opt/kde3/lib64/libkateinterfaces.so.0
#35 0x00002b1412f30985 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#36 0x00002b1412f31ab8 in QApplication::notify ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#37 0x00002b1412a6f708 in KApplication::notify ()
   from /opt/kde3/lib64/libkdecore.so.4
#38 0x00002b14129f0c79 in KAccelEventHandler::x11Event ()
   from /opt/kde3/lib64/libkdecore.so.4
#39 0x00002b1412a6d8c2 in KApplication::x11EventFilter ()
   from /opt/kde3/lib64/libkdecore.so.4
#40 0x00002b1412ec9267 in qt_set_x11_event_filter ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#41 0x00002b1412ed7a19 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#42 0x00002b1412ee722f in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#43 0x00002b1412f456a1 in QEventLoop::enterLoop ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#44 0x00002b1412f4554a in QEventLoop::exec ()
   from /usr/lib/qt3/lib64/libqt-mt.so.3
#45 0x00002b14165f9838 in kdemain () from /opt/kde3/lib64/libkdeinit_kate.so
#46 0x0000000000407971 in ?? ()
#47 0x0000000000408150 in ?? ()
#48 0x0000000000408635 in ?? ()
#49 0x0000000000408e2a in ?? ()
#50 0x00002b1413ac0154 in __libc_start_main () from /lib64/libc.so.6
#51 0x00000000004049a9 in ?? ()
#52 0x00007fff98973678 in ?? ()
#53 0x0000000000000000 in ?? ()
Comment 1 Andreas Kling 2006-07-14 06:52:41 UTC

*** This bug has been marked as a duplicate of 123315 ***