Bug 130323 - konqueror crashes with this html file
Summary: konqueror crashes with this html file
Status: RESOLVED DUPLICATE of bug 106795
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-05 22:07 UTC by Tim
Modified: 2006-07-06 08:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
html file causes crash (7.08 KB, text/html)
2006-07-05 22:09 UTC, Tim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2006-07-05 22:07:38 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Compiled From Sources
Compiler:          gcc-4.1.1-1 
OS:                Linux

When I click on the HTML file on my local drive, the file is loaded, and then konqueror crashes immediately
Comment 1 Tim 2006-07-05 22:09:34 UTC
Created attachment 16903 [details]
html file causes crash
Comment 2 Tim 2006-07-05 22:12:07 UTC
Using host libthread_db library "/lib64/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 46912582701216 (LWP 17479)]
[KCrash handler]
#5  0x00002aaab44d0e40 in DOM::Node::nodeType (this=) at dom_node.cpp:202
#6  0x00002aaab44631a3 in KJS::getDOMNode (exec=0xbc2cc0, n=@0x7fff43c72ca0)
    at kjs_dom.cpp:1464
#7  0x00002aaab44861ea in KJS::JSLazyEventListener::parseCode (this=0xb2d710)
    at kjs_events.cpp:201
#8  0x00002aaab44864c9 in KJS::JSLazyEventListener::handleEvent (
    this=0xb2d710, evt=@0x7fff43c72de0) at kjs_events.cpp:149
#9  0x00002aaab43619f6 in DOM::NodeImpl::handleLocalEvents (this=)
    at dom_nodeimpl.cpp:608
#10 0x00002aaab4366f36 in DOM::NodeImpl::dispatchGenericEvent (this=0xbc8c28, 
    evt=0xb2e200) at dom_nodeimpl.cpp:385
#11 0x00002aaab436a482 in DOM::NodeImpl::dispatchWindowEvent (this=0xbc8c28, 
    _id=17, canBubbleArg=) at dom_nodeimpl.cpp:443
#12 0x00002aaab4394d4b in DOM::HTMLDocumentImpl::close (this=)
    at html_documentimpl.cpp:276
#13 0x00002aaab431efa7 in KHTMLPart::checkCompleted (this=0x92b740)
    at khtml_part.cpp:2256
#14 0x00002aaab431f2b4 in KHTMLPart::slotChildCompleted (this=0x92b740, 
    pendingAction=false) at khtml_part.cpp:5050
#15 0x00002aaab4349275 in KHTMLPart::qt_invoke (this=0x92b740, _id=56, 
    _o=0x7fff43c73180) at khtml_part.moc:541
#16 0x00002aaaad05f400 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#17 0x00002aaaad05ffe2 in QObject::activate_signal ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#18 0x00002aaab434a147 in KHTMLView::timerEvent (this=0xd9abc0, e=)
    at khtmlview.cpp:3514
#19 0x00002aaaad05ea37 in QObject::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#20 0x00002aaaad094b08 in QWidget::event ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#21 0x00002aaaad003eb5 in QApplication::internalNotify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#22 0x00002aaaad0052e0 in QApplication::notify ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#23 0x00002aaaac808c18 in KApplication::notify (this=0x7fff43c74080, 
    receiver=0xd9abc0, event=0x7fff43c73600) at kapplication.cpp:550
#24 0x00002aaaacff94ec in QEventLoop::activateTimers ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#25 0x00002aaaacfb4e31 in QEventLoop::processEvents ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#26 0x00002aaaad01abd1 in QEventLoop::enterLoop ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#27 0x00002aaaad01aab2 in QEventLoop::exec ()
   from /usr/lib64/qt-3.3/lib/libqt-mt.so.3
#28 0x00002aaaaad3471c in kdemain (argc=) at konq_main.cc:206
#29 0x00002aaaaafed2b4 in __libc_start_main () from /lib64/libc.so.6
#30 0x00000000004004f9 in _start ()
#31 0x00007fff43c74328 in ?? ()
#32 0x0000000000000000 in ?? ()
Comment 3 Tommi Tervo 2006-07-06 08:28:46 UTC

*** This bug has been marked as a duplicate of 106795 ***