Bug 130290 - Kontact/Konganizer crashed. I'm unable to find a trigger.
Summary: Kontact/Konganizer crashed. I'm unable to find a trigger.
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: 3.5
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Reinhold Kainhofer
URL:
Keywords:
: 138721 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-07-05 13:01 UTC by Raúl
Modified: 2006-12-22 23:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Raúl 2006-07-05 13:01:21 UTC
Version:           3.5 (using KDE 3.5.3, Debian Package 4:3.5.3-1 (testing/unstable))
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.16-p4s

I was running kontact. I can't find a clear trigger of this, I'll go on investigating. This is the backtrace:
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1500514080 (LWP 23952)]
[KCrash handler]
#6  0xa72645bd in ~QImage (this=0x6e617254) at kernel/qimage.cpp:560
#7  0xa788692a in ~KAboutData (this=0x8652e50)
    at /build/buildd/kdelibs-3.5.3/./kdecore/kaboutdata.cpp:87
#8  0xa52284ff in KParts::GenericFactory<KOrganizerPart>::~GenericFactory ()
   from /usr/lib/kde3/libkorganizerpart.so
#9  0xa7883495 in ~KLibrary (this=0x86e92d0)
    at /build/buildd/kdelibs-3.5.3/./kdecore/klibloader.cpp:131
#10 0xa784570c in KLibrary::slotTimeout (this=0x86e92d0)
    at /build/buildd/kdelibs-3.5.3/./kdecore/klibloader.cpp:253
#11 0xa78457c8 in KLibrary::qt_invoke (this=0x8c31158, _id=4, _o=0xafeb7f7c)
    at ./klibloader.moc:91
#12 0xa729754b in QObject::activate_signal (this=0x8ba49d0, clist=0x818acf8, 
    o=0xafeb7f7c) at kernel/qobject.cpp:2356
#13 0xa7297fdc in QObject::activate_signal (this=0x8ba49d0, signal=2)
    at kernel/qobject.cpp:2325
#14 0xa762b2ae in QTimer::timeout (this=0x8ba49d0)
    at .moc/debug-shared-mt/moc_qtimer.cpp:82
#15 0xa72bc4a1 in QTimer::event (this=0x8ba49d0, e=0xafeb82c8)
    at kernel/qtimer.cpp:219
#16 0xa722d87a in QApplication::internalNotify (this=0xafeb861c, 
    receiver=0x8ba49d0, e=0xafeb82c8) at kernel/qapplication.cpp:2635
#17 0xa722da76 in QApplication::notify (this=0xafeb861c, receiver=0x8ba49d0, 
    e=0xafeb82c8) at kernel/qapplication.cpp:2358
#18 0xa790424e in KApplication::notify (this=0xafeb861c, receiver=0x8ba49d0, 
    event=0xafeb82c8)
    at /build/buildd/kdelibs-3.5.3/./kdecore/kapplication.cpp:550
#19 0xa71bf001 in QApplication::sendEvent (receiver=0x8ba49d0, 
    event=0xafeb82c8) at kernel/qapplication.h:520
#20 0xa721f305 in QEventLoop::activateTimers (this=0x80e5d78)
    at kernel/qeventloop_unix.cpp:556
#21 0xa71d2d2a in QEventLoop::processEvents (this=0x80e5d78, flags=4)
    at kernel/qeventloop_x11.cpp:389
#22 0xa7246255 in QEventLoop::enterLoop (this=0x80e5d78)
    at kernel/qeventloop.cpp:198
#23 0xa724617a in QEventLoop::exec (this=0x80e5d78)
    at kernel/qeventloop.cpp:145
#24 0xa722c38d in QApplication::exec (this=0xafeb861c)
    at kernel/qapplication.cpp:2758
#25 0xa673f895 in kdemain (argc=3, argv=0x80ac798)
    at /home/sid-user/kdebase/kdebase-3.5.3/./konqueror/konq_main.cc:206
#26 0xa7f9a524 in kdeinitmain (argc=3, argv=0x80ac798) at konqueror_dummy.cc:3
#27 0x0804e216 in launch (argc=3, _name=0x80abc34 "konqueror", 
    args=0x80abc7d "", cwd=0x0, envc=0, envs=0x80abc81 "", reset_env=false, 
    tty=0x0, avoid_loops=false, 
    startup_id_str=0x6e617254 <Address 0x6e617254 out of bounds>)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:639
#28 0x0804e966 in handle_launcher_request (sock=8)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1206
#29 0x0804ee23 in handle_requests (waitForPid=0)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1407
#30 0x0804ffd2 in main (argc=3, argv=0xafeb9134, envp=0x6e617254)
    at /build/buildd/kdelibs-3.5.3/./kinit/kinit.cpp:1863
#31 0xa7d0deb0 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#32 0x0804b8a1 in _start () at ../sysdeps/i386/elf/start.S:119
Comment 1 Allen Winter 2006-09-12 21:48:28 UTC
Ah, the old processEvents() bug.

I'm pretty sure we removed all that code for KDE 3.5.4.

Have you seen this bug in KDE 3.5.4 (assuming you've upgraded)?

I think I'll close this.  Please re-open if you still encounter this bug.
Comment 2 Bram Schoenmakers 2006-12-22 21:17:04 UTC
Bug 138721 shows the same backtrace, so we haven't got rid of this.
Comment 3 Bram Schoenmakers 2006-12-22 21:17:20 UTC
*** Bug 138721 has been marked as a duplicate of this bug. ***
Comment 4 Bram Schoenmakers 2006-12-22 21:19:50 UTC
Only seems to happen when KOrganizer is embedded inside Konqueror. Something is messy with the KAboutData.

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1234093888 (LWP 4949)]
[KCrash handler]
#9  0xb7f0f864 in QShared::deref (this=0x0) at qshared.h:50
#10 0xb7925f71 in QValueListPrivate<KAboutPerson>::derefAndDelete (this=0x0)
    at qvaluelist.h:234
#11 0xb7925fb7 in ~QValueList (this=0x8371610) at qvaluelist.h:441
#12 0xb75b8274 in ~KAboutData (this=0x83715e8)
    at /home/bram/KDE/kde3/kdelibs/kdecore/kaboutdata.cpp:138
#13 0xb5e6246a in ~GenericFactoryBase (this=0x83a8908) at genericfactory.h:28
#14 0xb5e62511 in ~GenericFactory (this=0x83a8908) at genericfactory.h:96
#15 0xb759d577 in ~KLibrary (this=0x8432ea0)
    at /home/bram/KDE/kde3/kdelibs/kdecore/klibloader.cpp:131
#16 0xb759aa47 in KLibrary::slotTimeout (this=0x8432ea0)
    at /home/bram/KDE/kde3/kdelibs/kdecore/klibloader.cpp:253
#17 0xb759cebc in KLibrary::qt_invoke (this=0x8432ea0, _id=4, _o=0xbf8c9078)
    at klibloader.moc:91
#18 0xb6e9d7a9 in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#19 0xb6e9e3fd in QObject::activate_signal () from /usr/qt/3/lib/libqt-mt.so.3
#20 0xb71d8309 in QTimer::timeout () from /usr/qt/3/lib/libqt-mt.so.3
#21 0xb6ec0dbf in QTimer::event () from /usr/qt/3/lib/libqt-mt.so.3
#22 0xb6e3e6c7 in QApplication::internalNotify ()
   from /usr/qt/3/lib/libqt-mt.so.3
#23 0xb6e3f291 in QApplication::notify () from /usr/qt/3/lib/libqt-mt.so.3
#24 0xb74f6ab4 in KApplication::notify (this=0xbf8c9584, receiver=0x842a5c8, 
    event=0xbf8c9334)
    at /home/bram/KDE/kde3/kdelibs/kdecore/kapplication.cpp:550
#25 0xb6e3382c in QEventLoop::activateTimers ()
   from /usr/qt/3/lib/libqt-mt.so.3
#26 0xb6dee89c in QEventLoop::processEvents () from /usr/qt/3/lib/libqt-mt.so.3
#27 0xb6e55251 in QEventLoop::enterLoop () from /usr/qt/3/lib/libqt-mt.so.3
#28 0xb6e550d6 in QEventLoop::exec () from /usr/qt/3/lib/libqt-mt.so.3
#29 0xb6e3e14f in QApplication::exec () from /usr/qt/3/lib/libqt-mt.so.3
#30 0xb7f0f7a0 in kdemain (argc=1, argv=0xbf8c9a84)
    at /home/bram/KDE/kde3/kdebase/konqueror/konq_main.cc:206
#31 0x080486e6 in main (argc=) at kdeinit_konqueror.cpp:2
Comment 5 Bram Schoenmakers 2006-12-22 23:40:36 UTC
SVN commit 615849 by bram:

Do not use a static KOrg::AboutData, it makes KOrganizer behave funky (read: prepare to crash) when you embed it inside Konqueror.

I close both bugs regarding embedding Korg inside Konq, I was not able to reproduce both of them (before this patch I was able to)

BUG:130280
BUG:130290



 M  +0 -8      aboutdata.cpp  
 M  +0 -5      aboutdata.h  
 M  +1 -2      korganizer_part.cpp  


--- branches/KDE/3.5/kdepim/korganizer/aboutdata.cpp #615848:615849
@@ -28,8 +28,6 @@
 
 using namespace KOrg;
 
-AboutData *AboutData::mSelf = 0;
-
 AboutData::AboutData()
   : KAboutData( "korganizer", I18N_NOOP("KOrganizer"), korgVersion,
                 I18N_NOOP("A Personal Organizer for KDE"),
@@ -75,9 +73,3 @@
   addCredit("Thomas Zander");
   addCredit("Fester Zigterman");
 }
-
-AboutData *AboutData::self()
-{
-  if ( !mSelf ) mSelf = new AboutData;
-  return mSelf;
-}
--- branches/KDE/3.5/kdepim/korganizer/aboutdata.h #615848:615849
@@ -33,11 +33,6 @@
 {
   public:
     AboutData();
-    
-    static AboutData *self();
-    
-  private:
-    static AboutData *mSelf;
 };
 
 }
--- branches/KDE/3.5/kdepim/korganizer/korganizer_part.cpp #615848:615849
@@ -43,7 +43,6 @@
 #include <kpopupmenu.h>
 #include <kinstance.h>
 #include <klocale.h>
-#include <kaboutdata.h>
 #include <kiconloader.h>
 #include <kaction.h>
 #include <kdebug.h>
@@ -140,7 +139,7 @@
 
 KAboutData *KOrganizerPart::createAboutData()
 {
-  return KOrg::AboutData::self();
+  return new KOrg::AboutData;
 }
 
 void KOrganizerPart::startCompleted( KProcess *process )