Bug 130139 - Recently received email message is destroyed if kmail is not closed properly
Summary: Recently received email message is destroyed if kmail is not closed properly
Status: RESOLVED DUPLICATE of bug 121272
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-07-02 12:28 UTC by David Saxton
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Saxton 2006-07-02 12:28:29 UTC
Version:            (using KDE KDE 3.5.3)
Installed from:    Ubuntu Packages

Often when kmail is not closed properly (such as when my computer overheats and crashes itself), I'll restart, only to find that an email that I recently received is now blank; the Subject, Receiver and Date all display in the email list, however there is no text whatsoever displayed. Sometimes the message seems permanently destroyed; other times, the message reappears if I restart kmail.

The email in general is one that I received recently; I am not sure whether such emails are destroyed because they were currently selected, or because they had been received before kmail had closed down properly.

This has happened a lot, and I can (occasionally) reproduce the behaviour by:
(1) Sending a email to myself (and select the email in the sent-mail and inbox folders - not too sure if selecting it is important)
(2) Killing kmail (Ctrl+Alt+Escape *click*)
(3) Restarting kmail, to discover that often at least one of the emails is blank.
Comment 1 Stefan Borggraefe 2006-07-02 14:02:44 UTC
Duplicate of bug 121272?

Sounds like an index corruption. When this happens nect time, try the following: Shut down KMail, and remove the index files for that particular directory or mbox. Please report back whether this helps.
Comment 2 Thomas McGuire 2007-07-17 15:07:10 UTC
>Duplicate of bug 121272?
I think so, too.

*** This bug has been marked as a duplicate of 121272 ***